aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/tex2im/Makefile34
-rw-r--r--textproc/tex2im/distinfo1
-rw-r--r--textproc/tex2im/pkg-comment1
-rw-r--r--textproc/tex2im/pkg-descr11
-rw-r--r--textproc/tex2im/pkg-plist6
6 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 3c660f273d79..ff1d95fb52fe 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -229,6 +229,7 @@
SUBDIR += sp
SUBDIR += tclExpat
SUBDIR += tdtd.el
+ SUBDIR += tex2im
SUBDIR += texi2html
SUBDIR += textutils
SUBDIR += tkdiff
diff --git a/textproc/tex2im/Makefile b/textproc/tex2im/Makefile
new file mode 100644
index 000000000000..763371a1ad42
--- /dev/null
+++ b/textproc/tex2im/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# New ports collection makefile for: tex2im
+# Date created: Nov 28, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tex2im
+PORTVERSION= 1.3
+CATEGORIES= textproc
+MASTER_SITES= http://www.nought.de/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ latex:${PORTSDIR}/print/teTeX \
+ convert:${PORTSDIR}/graphics/ImageMagick
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e "s,^#!/bin/bash,#!${LOCALBASE}/bin/bash,g" ${WRKSRC}/tex2im
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tex2im ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+post-patch:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -$ ${WRKSRC}/examples ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/tex2im/distinfo b/textproc/tex2im/distinfo
new file mode 100644
index 000000000000..191f9b7afd94
--- /dev/null
+++ b/textproc/tex2im/distinfo
@@ -0,0 +1 @@
+MD5 (tex2im-1.3.tar.gz) = 9cb1fb993cc2e695bb9fccfe3b2c5ce7
diff --git a/textproc/tex2im/pkg-comment b/textproc/tex2im/pkg-comment
new file mode 100644
index 000000000000..ab4d1754ead6
--- /dev/null
+++ b/textproc/tex2im/pkg-comment
@@ -0,0 +1 @@
+Converts LaTeX formulas into high resolution pixmap graphics
diff --git a/textproc/tex2im/pkg-descr b/textproc/tex2im/pkg-descr
new file mode 100644
index 000000000000..92131411e2dc
--- /dev/null
+++ b/textproc/tex2im/pkg-descr
@@ -0,0 +1,11 @@
+Tex2im is a simple tool that converts LaTeX formulas into high resolution
+pixmap graphics for inclusion in text processors or presentations. I
+encountered the problem that the formulas generated by the editors of common
+office packages usually were the ugliest part of my scientific presentations;
+on the other hand I didn't want to use latex for my transparencies. On the
+latex side I'm aware of the slitex and foiltex packages, nevertheless I
+consider them to be masochistic. EPS import can be nice, but commonly you get
+either display or printing problems. Also, often its nice just to copy
+formulas out of you latex documents.
+
+WWW: http://www.nought.de/tex2im.php
diff --git a/textproc/tex2im/pkg-plist b/textproc/tex2im/pkg-plist
new file mode 100644
index 000000000000..12784d4428de
--- /dev/null
+++ b/textproc/tex2im/pkg-plist
@@ -0,0 +1,6 @@
+bin/tex2im
+%%PORTDOCS%%share/examples/tex2im/example1.png
+%%PORTDOCS%%share/examples/tex2im/example1.tex
+%%PORTDOCS%%share/examples/tex2im/example2.png
+%%PORTDOCS%%share/examples/tex2im/example2.tex
+%%PORTDOCS%%@dirrm share/examples/tex2im