aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/sudoku_solver/Makefile29
-rw-r--r--games/sudoku_solver/distinfo3
-rw-r--r--games/sudoku_solver/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 4a41a2cd2b13..77a60a15d910 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -582,6 +582,7 @@
SUBDIR += stvef-paks
SUBDIR += stvef-server
SUBDIR += sudoku
+ SUBDIR += sudoku_solver
SUBDIR += sudsol
SUBDIR += super_methane_brothers
SUBDIR += supertux
diff --git a/games/sudoku_solver/Makefile b/games/sudoku_solver/Makefile
new file mode 100644
index 000000000000..8f296b19d432
--- /dev/null
+++ b/games/sudoku_solver/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: sudoku_solver
+# Date created: Apr 9, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sudoku_solver
+PORTVERSION= 1.11
+CATEGORIES= games
+MASTER_SITES= http://www.techfinesse.com/game/
+DISTNAME= solver_${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= A Sudoku Solver in C
+
+ALL_TARGET= # empty
+
+PLIST_FILES= bin/sudoku_solver
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,^CC,#CC, ; s,^CFLAGS,#CFLAGS," \
+ ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/sudoku_solver ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/sudoku_solver/distinfo b/games/sudoku_solver/distinfo
new file mode 100644
index 000000000000..26d89e1c995c
--- /dev/null
+++ b/games/sudoku_solver/distinfo
@@ -0,0 +1,3 @@
+MD5 (solver_1.11.tar.gz) = 5e56f326af726ebd22149025ab0d5a9a
+SHA256 (solver_1.11.tar.gz) = 3e2d39d0863f6dbd83058b81ee6be25a482c1cd6ed8140b7517e1e334eb9ff7b
+SIZE (solver_1.11.tar.gz) = 27787
diff --git a/games/sudoku_solver/pkg-descr b/games/sudoku_solver/pkg-descr
new file mode 100644
index 000000000000..12890d818d95
--- /dev/null
+++ b/games/sudoku_solver/pkg-descr
@@ -0,0 +1,6 @@
+This is a console-based Linux program, written in C language, that solves
+Su Doku puzzles (aka Sudoku, Number Place, etc.) using deductive logic.
+It will only resort to trial-and-error and backtracking approaches upon
+exhausting its deductive moves.
+
+WWW: http://www.techfinesse.com/game/sudoku_solver.php