aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pyldap/Makefile44
-rw-r--r--net/py-pyldap/distinfo2
-rw-r--r--net/py-pyldap/pkg-descr9
4 files changed, 56 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 63e6c31adc98..a5812b9e574d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -971,6 +971,7 @@
SUBDIR += py-port-for
SUBDIR += py-pybeanstalk
SUBDIR += py-pygeoip
+ SUBDIR += py-pyldap
SUBDIR += py-pynmsg
SUBDIR += py-pynsq
SUBDIR += py-pypcap
diff --git a/net/py-pyldap/Makefile b/net/py-pyldap/Makefile
new file mode 100644
index 000000000000..9b7a60ca7c4b
--- /dev/null
+++ b/net/py-pyldap/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= pyldap
+PORTVERSION= 2.4.21
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Fork of python-ldap with Python 3 support
+
+LICENSE= PSFL
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0:${PORTSDIR}/devel/py-pyasn1-modules
+
+CONFLICTS_INSTALL= py27-ldap
+USES= python
+USE_PYTHON= autoplist distutils
+USE_OPENLDAP= yes
+WANT_OPENLDAP_VER= 24
+
+REPLACE_ARGS= -e 's,/usr/include/sasl,${LOCALBASE}/include/sasl,' \
+ -e 's,/usr/local,${LOCALBASE},'
+
+OPTIONS_DEFINE= SASL
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSASL}
+WANT_OPENLDAP_SASL= yes
+CONFLICTS+= openldap24-client-2.*
+.endif
+
+do-configure:
+ @${REINPLACE_CMD} ${REPLACE_ARGS} ${WRKSRC}/setup.cfg
+.if ! ${PORT_OPTIONS:MSASL}
+ @cd ${WRKSRC} && ${PYTHON_CMD} setup.py -q setopt -c _ldap -s HAVE_TLS -o defines
+ @cd ${WRKSRC} && ${PYTHON_CMD} setup.py -q saveopts
+.endif
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_ldap.so
+
+.include <bsd.port.mk>
diff --git a/net/py-pyldap/distinfo b/net/py-pyldap/distinfo
new file mode 100644
index 000000000000..06d00bba0bbe
--- /dev/null
+++ b/net/py-pyldap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyldap-2.4.21.tar.gz) = 7a2b1dc31679466db11320b91bd2058574ba25ef27224967040918046ff4c450
+SIZE (pyldap-2.4.21.tar.gz) = 124575
diff --git a/net/py-pyldap/pkg-descr b/net/py-pyldap/pkg-descr
new file mode 100644
index 000000000000..7c87b6b47f85
--- /dev/null
+++ b/net/py-pyldap/pkg-descr
@@ -0,0 +1,9 @@
+Python modules for implementing LDAP clients
+
+pyldap is a fork of python-ldap, and provides an object-oriented API to access
+LDAP directory servers from Python programs. Mainly it wraps the OpenLDAP 2.x
+libs for that purpose. Additionally the package contains modules for other
+LDAP-related stuff (e.g. processing LDIF, LDAPURLs, LDAPv3 schema, LDAPv3
+extended operations and controls, etc.).
+
+WWW: https://github.com/pyldap/pyldap/