aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/wmglobe/Makefile2
-rw-r--r--astro/wmglobe/files/patch-aa2
-rw-r--r--games/wmtimebomb/Makefile2
-rw-r--r--games/wmtimebomb/files/patch-aa2
4 files changed, 4 insertions, 4 deletions
diff --git a/astro/wmglobe/Makefile b/astro/wmglobe/Makefile
index 0e48d3b05265..7696d6456e8b 100644
--- a/astro/wmglobe/Makefile
+++ b/astro/wmglobe/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.3:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- gif.5:${PORTSDIR}/graphics/giflib \
+ ungif.5:${PORTSDIR}/graphics/libungif \
wraster.3:${PORTSDIR}/x11-wm/windowmaker
USE_X_PREFIX= yes
diff --git a/astro/wmglobe/files/patch-aa b/astro/wmglobe/files/patch-aa
index f6c7958d4aa0..055020c6d1a5 100644
--- a/astro/wmglobe/files/patch-aa
+++ b/astro/wmglobe/files/patch-aa
@@ -6,7 +6,7 @@
- -ltiff -lXpm -lpng -lz -ljpeg -lungif -lwraster
+INC = -I${X11BASE}/include
+LIBS = -lXext -lX11 -lm -L${X11BASE}/lib -L${LOCALBASE}/lib \
-+ -ltiff -lXpm -lpng -lz -ljpeg -lgif -lwraster
++ -ltiff -lXpm -lpng -lz -ljpeg -lungif -lwraster
OBJS = src/wmglobe.o src/rend.o src/wmgutil.o \
src/sunpos.o src/myconvert.o src/mycontext.o
diff --git a/games/wmtimebomb/Makefile b/games/wmtimebomb/Makefile
index 1b755b42a529..db08fb86a41e 100644
--- a/games/wmtimebomb/Makefile
+++ b/games/wmtimebomb/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
PropList.2:${PORTSDIR}/devel/libPropList \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
- gif.5:${PORTSDIR}/graphics/giflib \
+ ungif.5:${PORTSDIR}/graphics/libungif \
png.3:${PORTSDIR}/graphics/png
BUILD_DEPENDS= ${X11BASE}/lib/libWMaker.a:${PORTSDIR}/x11-wm/windowmaker
diff --git a/games/wmtimebomb/files/patch-aa b/games/wmtimebomb/files/patch-aa
index 8aa35c520dda..7279fa8bfecc 100644
--- a/games/wmtimebomb/files/patch-aa
+++ b/games/wmtimebomb/files/patch-aa
@@ -3,7 +3,7 @@
@@ -1,7 +1,9 @@
-XPMLIB = -L/usr/X11R6/lib -lXpm -lm -ljpeg -lpng -lz -ltiff -lgif
-WMAKER = -L/usr/local/lib -lWMaker -lWINGs -lwraster -lPropList
-+XPMLIB = -L@X11BASE@/lib -lXpm -lm -ljpeg -lpng -lz -ltiff -lgif
++XPMLIB = -L@X11BASE@/lib -lXpm -lm -ljpeg -lpng -lz -ltiff -lungif
+WMAKER = -L@LOCALBASE@/lib -lWMaker -lWINGs -lwraster -lPropList
LOCAL_LIBRARIES = $(WMAKER) $(XPMLIB) $(XLIB)