aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/isnprober/Makefile9
-rw-r--r--security/p5-Authen-PAM/Makefile9
-rw-r--r--security/p5-Crypt-AppleTwoFish/Makefile7
-rw-r--r--security/p5-Crypt-Chimera/Makefile7
-rw-r--r--security/p5-Crypt-GOST_PP/Makefile7
-rw-r--r--security/p5-Crypt-HCE_SHA/Makefile3
-rw-r--r--security/p5-Crypt-License/Makefile7
-rw-r--r--security/p5-Crypt-OICQ/Makefile9
-rw-r--r--security/p5-Digest-Bcrypt/Makefile3
-rw-r--r--security/p5-Digest-CRC/Makefile9
-rw-r--r--security/p5-Digest-MD5-Reverse/Makefile3
-rw-r--r--security/p5-Digest-Perl-MD4/Makefile7
-rw-r--r--security/p5-Digest-SV1/Makefile7
-rw-r--r--security/p5-Digest-Tiger/Makefile7
-rw-r--r--security/p5-File-KeePass/Makefile3
-rw-r--r--security/p5-File-Scan/Makefile9
-rw-r--r--security/p5-Nmap-Parser/Makefile3
-rw-r--r--security/p5-openxpki-client-html-mason/Makefile3
-rw-r--r--security/pam_ssh_agent_auth/Makefile2
19 files changed, 49 insertions, 65 deletions
diff --git a/security/isnprober/Makefile b/security/isnprober/Makefile
index 82d592f33be6..c1e9a9d9e75a 100644
--- a/security/isnprober/Makefile
+++ b/security/isnprober/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: isnprober
-# Date created: 28/7/2006
-# Whom: Yonatan <onatan@gmail.com>
-#
+# Created by: Yonatan <onatan@gmail.com>
# $FreeBSD$
-#
PORTNAME= isnprober
PORTVERSION= 1.02
@@ -21,7 +17,8 @@ RUN_DEPENDS= p5-Net-RawIP>=0:${PORTSDIR}/net/p5-Net-RawIP
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
do-install:
diff --git a/security/p5-Authen-PAM/Makefile b/security/p5-Authen-PAM/Makefile
index c22d41a4ad41..bbdd0f9bfb45 100644
--- a/security/p5-Authen-PAM/Makefile
+++ b/security/p5-Authen-PAM/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Authen-PAM
-# Date created: Mon Oct 4 1999
-# Whom: Matt Behrens <matt@zigg.com>
-#
+# Created by: Matt Behrens <matt@zigg.com>
# $FreeBSD$
-#
PORTNAME= Authen-PAM
PORTVERSION= 0.16
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= des@FreeBSD.org
COMMENT= A Perl interface to the PAM library
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= -DPAM_STRERROR_NEEDS_PAMH
MAN3= Authen::PAM.3 \
diff --git a/security/p5-Crypt-AppleTwoFish/Makefile b/security/p5-Crypt-AppleTwoFish/Makefile
index eb60bc9fd488..d13d5e6613f3 100644
--- a/security/p5-Crypt-AppleTwoFish/Makefile
+++ b/security/p5-Crypt-AppleTwoFish/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-AppleTwoFish
-# Date created: 18 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-AppleTwoFish
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension for Apple iTMS internal key descrambling algorithm
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::AppleTwoFish.3
diff --git a/security/p5-Crypt-Chimera/Makefile b/security/p5-Crypt-Chimera/Makefile
index 5345d04b6368..7449b4873fe3 100644
--- a/security/p5-Crypt-Chimera/Makefile
+++ b/security/p5-Crypt-Chimera/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-Chimera
-# Date created: 20 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-Chimera
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension for Chimera key exchange protocol
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::Chimera.3
diff --git a/security/p5-Crypt-GOST_PP/Makefile b/security/p5-Crypt-GOST_PP/Makefile
index 3c2682e9ee48..2f5a3d10be15 100644
--- a/security/p5-Crypt-GOST_PP/Makefile
+++ b/security/p5-Crypt-GOST_PP/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-GOST_PP
-# Date created: 20 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-GOST_PP
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension for GOST Encryption Algorithm in pure Perl
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::GOST_PP.3
diff --git a/security/p5-Crypt-HCE_SHA/Makefile b/security/p5-Crypt-HCE_SHA/Makefile
index 82d1898bb1eb..777a7136cfb2 100644
--- a/security/p5-Crypt-HCE_SHA/Makefile
+++ b/security/p5-Crypt-HCE_SHA/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl5 interface to one way hash chaining block cipher
BUILD_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::HCE_SHA.3
diff --git a/security/p5-Crypt-License/Makefile b/security/p5-Crypt-License/Makefile
index b320d9003435..7146c543ccfa 100644
--- a/security/p5-Crypt-License/Makefile
+++ b/security/p5-Crypt-License/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-License
-# Date created: 20 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-License
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension to examine a license
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::License.3 Crypt::License::Util.3 Crypt::License::Notice.3
diff --git a/security/p5-Crypt-OICQ/Makefile b/security/p5-Crypt-OICQ/Makefile
index bb48da5e40d8..c2e3c9393f20 100644
--- a/security/p5-Crypt-OICQ/Makefile
+++ b/security/p5-Crypt-OICQ/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Crypt-OICQ
-# Date created: Aug 01, 2006
-# Whom: Rong-En Fan <rafan@FreeBSD.org>
-#
+# Created by: Rong-En Fan <rafan@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Crypt-OICQ
PORTVERSION= 1.1
@@ -15,7 +11,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= rafan@FreeBSD.org
COMMENT= Cryptographic algorithm used by OICQ protocol
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::OICQ.3
diff --git a/security/p5-Digest-Bcrypt/Makefile b/security/p5-Digest-Bcrypt/Makefile
index c6abcdada1d7..70d9425f51a3 100644
--- a/security/p5-Digest-Bcrypt/Makefile
+++ b/security/p5-Digest-Bcrypt/Makefile
@@ -15,7 +15,8 @@ LICENSE= ART10
BUILD_DEPENDS= p5-Crypt-Eksblowfish>0:${PORTSDIR}/security/p5-Crypt-Eksblowfish
RUN_DEPENDS= p5-Crypt-Eksblowfish>0:${PORTSDIR}/security/p5-Crypt-Eksblowfish
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::Bcrypt.3
diff --git a/security/p5-Digest-CRC/Makefile b/security/p5-Digest-CRC/Makefile
index 0a54f4989e54..ef245884db36 100644
--- a/security/p5-Digest-CRC/Makefile
+++ b/security/p5-Digest-CRC/Makefile
@@ -1,9 +1,5 @@
-# Ports collection Makefile for: p5-Digest-CRC
-# Date created: 17 Dec 2005
-# Whom: Gabor Kovesdan
-#
+# Created by: Gabor Kovesdan
# $FreeBSD$
-#
PORTNAME= Digest-CRC
PORTVERSION= 0.18
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension for calculating CRC checksums
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::CRC.3
diff --git a/security/p5-Digest-MD5-Reverse/Makefile b/security/p5-Digest-MD5-Reverse/Makefile
index 5c4fe40c15dc..4b0ceb1be5d1 100644
--- a/security/p5-Digest-MD5-Reverse/Makefile
+++ b/security/p5-Digest-MD5-Reverse/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension that looks for MD5 hashes in several databases
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Digest::MD5::Reverse.3
diff --git a/security/p5-Digest-Perl-MD4/Makefile b/security/p5-Digest-Perl-MD4/Makefile
index a25a09d2d53a..37cc2fd42b37 100644
--- a/security/p5-Digest-Perl-MD4/Makefile
+++ b/security/p5-Digest-Perl-MD4/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-Perl-MD4
-# Date created: 21 Dec, 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-Perl-MD4
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension for MD4 hash algorithm in pure Perl
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::Perl::Digest-MD4.3 \
Digest::Perl::MD4.3
diff --git a/security/p5-Digest-SV1/Makefile b/security/p5-Digest-SV1/Makefile
index 626a8bca79b9..ee7a562bc037 100644
--- a/security/p5-Digest-SV1/Makefile
+++ b/security/p5-Digest-SV1/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-SV1
-# Date created: 17 Dec 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-SV1
@@ -15,7 +13,8 @@ COMMENT= Perl extension for SV1 hash algorithm
BUILD_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
p5-Digest-Haval256>=0:${PORTSDIR}/security/p5-Digest-Haval256
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Digest::SV1.3
diff --git a/security/p5-Digest-Tiger/Makefile b/security/p5-Digest-Tiger/Makefile
index f53ecd04922a..017d9afd9837 100644
--- a/security/p5-Digest-Tiger/Makefile
+++ b/security/p5-Digest-Tiger/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-Tiger
-# Date created: 17 Dec 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-Tiger
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension for Tiger hash algorithm
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::Tiger.3
diff --git a/security/p5-File-KeePass/Makefile b/security/p5-File-KeePass/Makefile
index 9b81917ec068..184f881588c1 100644
--- a/security/p5-File-KeePass/Makefile
+++ b/security/p5-File-KeePass/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-Crypt-Rijndael>=1.0:${PORTSDIR}/security/p5-Crypt-Rijndael \
p5-MIME-Base64>=1.0:${PORTSDIR}/converters/p5-MIME-Base64
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::KeePass.3
diff --git a/security/p5-File-Scan/Makefile b/security/p5-File-Scan/Makefile
index 63904b0968ef..0557aded2882 100644
--- a/security/p5-File-Scan/Makefile
+++ b/security/p5-File-Scan/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-File-Scan
-# Date created: May 24 2002
-# Whom: Martin Matuska <martin@tradex.sk>
-#
+# Created by: Martin Matuska <martin@tradex.sk>
# $FreeBSD$
-#
PORTNAME= File-Scan
PORTVERSION= 1.43
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jims@bluenotch.com
COMMENT= Perl5 anti-virus file scanning package
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::Scan.3
diff --git a/security/p5-Nmap-Parser/Makefile b/security/p5-Nmap-Parser/Makefile
index 8dea83c7e811..77cb60368f0f 100644
--- a/security/p5-Nmap-Parser/Makefile
+++ b/security/p5-Nmap-Parser/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-XML-Twig>=3.16:${PORTSDIR}/textproc/p5-XML-Twig \
RUN_DEPENDS:= ${BUILD_DEPENDS} \
nmap:${PORTSDIR}/security/nmap
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Nmap::Parser.3
diff --git a/security/p5-openxpki-client-html-mason/Makefile b/security/p5-openxpki-client-html-mason/Makefile
index 0879b93dd410..3156d8632071 100644
--- a/security/p5-openxpki-client-html-mason/Makefile
+++ b/security/p5-openxpki-client-html-mason/Makefile
@@ -24,7 +24,8 @@ MAN3= OpenXPKI::Client::HTML::Mason.3 \
OpenXPKI::Client::HTML::Mason::Javascript.3 \
OpenXPKI::Client::HTML::Mason::Menu.3
USE_GMAKE= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
post-install:
.if !defined(NOPORTDOCS)
diff --git a/security/pam_ssh_agent_auth/Makefile b/security/pam_ssh_agent_auth/Makefile
index 225d4692e666..9824665479fb 100644
--- a/security/pam_ssh_agent_auth/Makefile
+++ b/security/pam_ssh_agent_auth/Makefile
@@ -13,7 +13,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_func_strnvis=no
CONFIGURE_ARGS= --libexecdir=${LOCALBASE}/lib
-USE_PERL5= yes
+USES= perl5
MAN8= pam_ssh_agent_auth.8
PLIST_FILES= lib/pam_ssh_agent_auth.so