aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/darktable/Makefile12
-rw-r--r--graphics/darktable/distinfo4
-rw-r--r--graphics/darktable/pkg-plist4
3 files changed, 11 insertions, 9 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index de8105d347c0..1613a668d972 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= darktable
-PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTVERSION= 1.2.3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
@@ -38,7 +37,7 @@ GEO_DESC= Geotagging support
FACEBOOK_DESC= Support images export to Facebook
RAWSPEED_DESC= Compile with rawspeed backend
SLIDESHOW_DESC= Build OpenGL/SDL slideshow viewer
-GCC_DESC= Build with a current version of GCC (better OpenMP support)
+GCC_DESC= Build with modern GCC (better OpenMP support)
OPTIONS_DEFAULT= GPHOTO RAWSPEED GCC
@@ -56,7 +55,8 @@ CMAKE_ARGS+= -DUSE_CAMERA_SUPPORT:BOOL=OFF
.if ${PORT_OPTIONS:MGEO}
LIB_DEPENDS+= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
-PLIST_FILES+= lib/darktable/plugins/lighttable/liblocation.so \
+PLIST_FILES+= lib/darktable/plugins/lighttable/libgeotagging.so \
+ lib/darktable/plugins/lighttable/liblocation.so \
lib/darktable/plugins/lighttable/libmap_settings.so \
lib/darktable/views/libmap.so
.else
@@ -127,8 +127,8 @@ LDFLAGS+= -lstdc++
.endif
post-patch:
- @${REINPLACE_CMD} -e '/stats_/s,uint64_t,unsigned long,' \
- ${WRKSRC}/src/common/mipmap_cache.h
+ @${REINPLACE_CMD} -e 's,__APPLE__,__${OPSYS}__,' \
+ ${WRKSRC}/src/common/utility.c
# Do not install useless (to end-user) documentation; adjust manpages path
@${REINPLACE_CMD} -e '/DOC_FILES/d ; s,share/man/man1,man/man1,' \
${WRKSRC}/doc/CMakeLists.txt
diff --git a/graphics/darktable/distinfo b/graphics/darktable/distinfo
index 2c4ad742bc4d..314f5bd1b123 100644
--- a/graphics/darktable/distinfo
+++ b/graphics/darktable/distinfo
@@ -1,2 +1,2 @@
-SHA256 (darktable-1.2.2.tar.xz) = 12902e8c3ef185d2167ce3a5f9d11eddde763c5a3cb0e9267f4b470a252fc859
-SIZE (darktable-1.2.2.tar.xz) = 2307300
+SHA256 (darktable-1.2.3.tar.xz) = 686b62e020c13e64d18c9b465742ddec8604cfee36e06c8858301735c29f7316
+SIZE (darktable-1.2.3.tar.xz) = 2348864
diff --git a/graphics/darktable/pkg-plist b/graphics/darktable/pkg-plist
index 160def48f5fa..5271cd2f2133 100644
--- a/graphics/darktable/pkg-plist
+++ b/graphics/darktable/pkg-plist
@@ -1,6 +1,7 @@
bin/darktable
bin/darktable-cli
bin/darktable-cltest
+share/appdata/darktable.appdata.xml
%%DATADIR%%/darktable.gtkrc
%%DATADIR%%/darktablerc
%%DATADIR%%/gdb_commands
@@ -171,7 +172,6 @@ lib/darktable/plugins/lighttable/libdarktable_label.so
lib/darktable/plugins/lighttable/libexport.so
lib/darktable/plugins/lighttable/libfilmstrip.so
lib/darktable/plugins/lighttable/libfilter.so
-lib/darktable/plugins/lighttable/libgeotagging.so
lib/darktable/plugins/lighttable/libglobal_toolbox.so
lib/darktable/plugins/lighttable/libhinter.so
lib/darktable/plugins/lighttable/libhistogram.so
@@ -215,6 +215,7 @@ share/locale/nl/LC_MESSAGES/darktable.mo
share/locale/pl/LC_MESSAGES/darktable.mo
share/locale/pt_BR/LC_MESSAGES/darktable.mo
share/locale/pt_PT/LC_MESSAGES/darktable.mo
+share/locale/ru/LC_MESSAGES/darktable.mo
share/locale/sq/LC_MESSAGES/darktable.mo
share/locale/sv/LC_MESSAGES/darktable.mo
share/locale/uk/LC_MESSAGES/darktable.mo
@@ -236,3 +237,4 @@ share/locale/uk/LC_MESSAGES/darktable.mo
@dirrm %%DATADIR%%/kernels
@dirrm %%DATADIR%%/js
@dirrm %%DATADIR%%
+@dirrmtry share/appdata