aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/nagios-check_clamav/Makefile30
-rw-r--r--net-mgmt/nagios-check_clamav/distinfo3
-rw-r--r--net-mgmt/nagios-check_clamav/pkg-descr6
4 files changed, 40 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 2afe273f3105..b2bac291029a 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -108,6 +108,7 @@
SUBDIR += nagios2
SUBDIR += nagios-certexp-plugin
SUBDIR += nagios-check_bacula
+ SUBDIR += nagios-check_clamav
SUBDIR += nagios-check_ports
SUBDIR += nagios-check_puppet
SUBDIR += nagios-devel
diff --git a/net-mgmt/nagios-check_clamav/Makefile b/net-mgmt/nagios-check_clamav/Makefile
new file mode 100644
index 000000000000..5b4a29180266
--- /dev/null
+++ b/net-mgmt/nagios-check_clamav/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: nagios-check_clamav
+# Date created: Fri 12 Jun 2009
+# Whom: Alexey V. Degtyarev
+#
+# $FreeBSD$
+#
+
+PORTNAME= check_clamav
+PORTVERSION= 1.2
+CATEGORIES= net-mgmt
+MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
+PKGNAMEPREFIX= nagios-
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Nagios plugin that verifies ClamAV local signature database revision
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+RUN_DEPENDS+= ${LOCALBASE}/libexec/nagios/utils.pm:${PORTSDIR}/net-mgmt/nagios-plugins \
+ clamav>=0:${PORTSDIR}/security/clamav \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
+
+PLIST_FILES= libexec/nagios/check_clamav
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_clamav \
+ ${PREFIX}/libexec/nagios/check_clamav
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-check_clamav/distinfo b/net-mgmt/nagios-check_clamav/distinfo
new file mode 100644
index 000000000000..bf9412609d21
--- /dev/null
+++ b/net-mgmt/nagios-check_clamav/distinfo
@@ -0,0 +1,3 @@
+MD5 (check_clamav-1.2.tar.gz) = 817d489f3a4981b6ba5984b801d35b11
+SHA256 (check_clamav-1.2.tar.gz) = 08c95ca0925370419e011ef5964fd2697303dee87d006a48cac4526779018491
+SIZE (check_clamav-1.2.tar.gz) = 2795
diff --git a/net-mgmt/nagios-check_clamav/pkg-descr b/net-mgmt/nagios-check_clamav/pkg-descr
new file mode 100644
index 000000000000..941fa756ce33
--- /dev/null
+++ b/net-mgmt/nagios-check_clamav/pkg-descr
@@ -0,0 +1,6 @@
+This check plugin is a Perl script which compares your local signature database
+(daily.cvd) version to the version advertised from the ClamAV site. It verifies
+the latest ClamAV revision using a DNS TXT query against
+current.cvd.clamav.net.
+
+WWW: http://bsd.phoenix.az.us/projects/check_clamav