aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/jdupes/Makefile30
-rw-r--r--sysutils/jdupes/distinfo3
-rw-r--r--sysutils/jdupes/pkg-descr7
4 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b80d5dedcc54..d954096d460f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -489,6 +489,7 @@
SUBDIR += jailutils
SUBDIR += javaservicewrapper
SUBDIR += jdiskreport
+ SUBDIR += jdupes
SUBDIR += jkill
SUBDIR += jobd
SUBDIR += jps
diff --git a/sysutils/jdupes/Makefile b/sysutils/jdupes/Makefile
new file mode 100644
index 000000000000..cbb3ca4b8780
--- /dev/null
+++ b/sysutils/jdupes/Makefile
@@ -0,0 +1,30 @@
+# Created by: Thomas Hurst <tom@hur.st>
+# $FreeBSD$
+
+PORTNAME= jdupes
+PORTVERSION= 1.8
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils
+
+MAINTAINER= tom@hur.st
+COMMENT= Powerful duplicate file finder and an enhanced fork of 'fdupes'
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= jbruchon
+
+USES= gmake
+
+PLIST_FILES= bin/jdupes man/man1/jdupes.1.gz
+
+OPTIONS_DEFINE= LOW_MEMORY
+LOW_MEMORY_DESC= Build for lower memory usage instead of speed
+LOW_MEMORY_MAKE_ENV= CFLAGS_EXTRA=-DLOW_MEMORY
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/jdupes/distinfo b/sysutils/jdupes/distinfo
new file mode 100644
index 000000000000..a8e2b9ea5bf2
--- /dev/null
+++ b/sysutils/jdupes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491179702
+SHA256 (jbruchon-jdupes-v1.8_GH0.tar.gz) = f2ba7cfecbc77cb2c43ec490994f3363754b6a84d6a5ca9728a2c33601acd6a0
+SIZE (jbruchon-jdupes-v1.8_GH0.tar.gz) = 59362
diff --git a/sysutils/jdupes/pkg-descr b/sysutils/jdupes/pkg-descr
new file mode 100644
index 000000000000..791e7d1bc29d
--- /dev/null
+++ b/sysutils/jdupes/pkg-descr
@@ -0,0 +1,7 @@
+jdupes is a program for identifying and taking actions upon duplicate
+files. It is a fork of fdupes, but not a drop-in replacement.
+
+See http://www.virkki.com/jyri/articles/index.php/dupd-vs-jdupes-take-2/
+for a comparision to dupd.
+
+WWW: https://github.com/jbruchon/jdupes