aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/bladeenc/Makefile8
-rw-r--r--devel/asmutils/Makefile8
-rw-r--r--devel/crossgo32/Makefile8
-rw-r--r--lang/egcs/Makefile4
-rw-r--r--lang/objc/Makefile4
-rw-r--r--net-mgmt/sendip/Makefile8
-rw-r--r--net/sendip/Makefile8
-rw-r--r--net/tintin++/Makefile8
-rw-r--r--security/pgp6/Makefile8
-rw-r--r--security/slush/Makefile4
10 files changed, 61 insertions, 7 deletions
diff --git a/audio/bladeenc/Makefile b/audio/bladeenc/Makefile
index 0e0981c67724..8cafd7b1bd1a 100644
--- a/audio/bladeenc/Makefile
+++ b/audio/bladeenc/Makefile
@@ -15,6 +15,12 @@ EXTRACT_SUFX= -src-stable.tar.gz
MAINTAINER= dirk@FreeBSD.org
COMMENT= MP3 encoder
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index 7138c3b29a83..6894d0245938 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -15,6 +15,12 @@ COMMENT= A set of UNIX utilities written in assembly language
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
@@ -61,4 +67,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/crossgo32/Makefile b/devel/crossgo32/Makefile
index bb60bc1e33b7..dd9301c4c8e8 100644
--- a/devel/crossgo32/Makefile
+++ b/devel/crossgo32/Makefile
@@ -19,6 +19,12 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} dosrel-1.0${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Cross Development Environment for 32-bit DOS
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=${TARGET}
USE_GMAKE= yes
@@ -57,4 +63,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/dosrel-1.0/go32.exe ${GO32DIR}
${INSTALL_DATA} ${WRKSRC}/dosrel-1.0/emu387 ${GO32DIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/egcs/Makefile b/lang/egcs/Makefile
index e7bd8820c007..50d2cc95e8aa 100644
--- a/lang/egcs/Makefile
+++ b/lang/egcs/Makefile
@@ -22,6 +22,10 @@ USE_BZIP2= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
EGCS_REV= egcs-2.91.66
.if ${PORTOBJFORMAT} == "elf"
diff --git a/lang/objc/Makefile b/lang/objc/Makefile
index 8d26949aca2c..8538c1fd7728 100644
--- a/lang/objc/Makefile
+++ b/lang/objc/Makefile
@@ -23,6 +23,10 @@ CONFIGURE_ARGS= --prefix=$(PREFIX)
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
pre-configure:
cd $(WRKDIR)/${PORTNAME}-bootstrap-$(PORTVERSION);\
./configure --prefix=$(WRKDIR);${MAKE};${MAKE} install
diff --git a/net-mgmt/sendip/Makefile b/net-mgmt/sendip/Makefile
index c846afd9f6b5..76be1bce8c22 100644
--- a/net-mgmt/sendip/Makefile
+++ b/net-mgmt/sendip/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.earth.li/projectpurple/files/
MAINTAINER= joseph@randomnetworks.com
COMMENT= SendIP is a commandline tool to allow sending arbitrary IP packets
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5= yes
@@ -20,4 +26,4 @@ INSTALLS_SHLIB= yes
MAN1= sendip.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/sendip/Makefile b/net/sendip/Makefile
index c846afd9f6b5..76be1bce8c22 100644
--- a/net/sendip/Makefile
+++ b/net/sendip/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.earth.li/projectpurple/files/
MAINTAINER= joseph@randomnetworks.com
COMMENT= SendIP is a commandline tool to allow sending arbitrary IP packets
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5= yes
@@ -20,4 +26,4 @@ INSTALLS_SHLIB= yes
MAN1= sendip.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
index 949c612189ba..4199ae80f92b 100644
--- a/net/tintin++/Makefile
+++ b/net/tintin++/Makefile
@@ -15,7 +15,13 @@ DISTNAME= tintin++v1.5pl9
MAINTAINER= jhp@cocoja.holywar.net
COMMENT= A client program to help playing muds
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/tintin++/v1.5/src
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/pgp6/Makefile b/security/pgp6/Makefile
index ca6d27cf36cb..ed2f5ebf2118 100644
--- a/security/pgp6/Makefile
+++ b/security/pgp6/Makefile
@@ -22,6 +22,12 @@ DISTNAME= pgpsrc658unix
MAINTAINER= mike@fate.com
COMMENT= Public-Key encryption for the masses
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/pgpsrc
USE_GMAKE= yes
@@ -48,4 +54,4 @@ do-install:
cd ${WRKSRC}/clients/pgp/cmdline ; ${GMAKE} install ; \
${INSTALL_MAN} packaging/pgp-6.0/man/man1/pgp.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/slush/Makefile b/security/slush/Makefile
index 7b0bb0511c62..7433404aa138 100644
--- a/security/slush/Makefile
+++ b/security/slush/Makefile
@@ -24,6 +24,10 @@ USE_OPENSSL= YES
BROKEN= does not build
.endif
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
do-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/slush