aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/munin-common/distinfo4
-rw-r--r--sysutils/munin-common/munin.mk4
-rw-r--r--sysutils/munin-master/Makefile1
-rw-r--r--sysutils/munin-master/pkg-plist4
-rw-r--r--sysutils/munin-node/Makefile4
-rw-r--r--sysutils/munin-node/files/munin-node-revive.sh.in27
-rw-r--r--sysutils/munin-node/files/munin-node.in28
-rw-r--r--sysutils/munin-node/files/munin-sched.in27
-rw-r--r--sysutils/munin-node/pkg-deinstall13
-rw-r--r--sysutils/munin-node/pkg-install7
-rw-r--r--sysutils/munin-node/pkg-plist4
11 files changed, 55 insertions, 68 deletions
diff --git a/sysutils/munin-common/distinfo b/sysutils/munin-common/distinfo
index 405598644f9a..f28ee8f7e75a 100644
--- a/sysutils/munin-common/distinfo
+++ b/sysutils/munin-common/distinfo
@@ -1,2 +1,2 @@
-SHA256 (munin-2.0.9.tar.gz) = 6bb2b42de29a438ad80f1d6c53f4a35e9a74cb5a2103ea7a9530cba2d75c7309
-SIZE (munin-2.0.9.tar.gz) = 1328972
+SHA256 (munin-2.0.11.1.tar.gz) = 89ac6a46e82471206c37ed11a9fe2023cbf4c7482517f70a67d5aa5f32366c18
+SIZE (munin-2.0.11.1.tar.gz) = 1331839
diff --git a/sysutils/munin-common/munin.mk b/sysutils/munin-common/munin.mk
index 72fd9ee7272f..68d6e2a95d29 100644
--- a/sysutils/munin-common/munin.mk
+++ b/sysutils/munin-common/munin.mk
@@ -1,5 +1,5 @@
-MUNIN_VERSION= 2.0.9
-MUNIN_SITES= SF/${PORTNAME}/stable/${PORTVERSION}
+MUNIN_VERSION= 2.0.11.1
+MUNIN_SITES= SF/${PORTNAME}/stable/2.0.11
MUNIN_DISTINFO= ${PORTSDIR}/sysutils/munin-common/distinfo
MUNIN_PATCHES= ${PORTSDIR}/sysutils/munin-common/files/patch-Makefile \
${PORTSDIR}/sysutils/munin-common/files/patch-Makefile.config
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 6cc74e312df2..e5786ec8ce83 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -57,6 +57,7 @@ MAN3= Munin::Master::Config.3 \
Munin::Master::GroupRepository.3 \
Munin::Master::HTMLOld.3 \
Munin::Master::Host.3 \
+ Munin::Master::LimitsOld.3 \
Munin::Master::Logger.3 \
Munin::Master::Node.3 \
Munin::Master::ProcessManager.3 \
diff --git a/sysutils/munin-master/pkg-plist b/sysutils/munin-master/pkg-plist
index 3150031ebc6e..0b21d35f1881 100644
--- a/sysutils/munin-master/pkg-plist
+++ b/sysutils/munin-master/pkg-plist
@@ -64,8 +64,6 @@ www/cgi-bin/munin-cgi-html
@dirrmtry www/cgi-bin
@dirrmtry %%WWWDIR%%
@dirrmtry %%DATADIR%%
-@dirrmtry %%DBDIR%%/cgi-tmp
-@dirrmtry %%DBDIR%%
@dirrm %%SITE_PERL%%/Munin/Master
@dirrmtry %%SITE_PERL%%/Munin
@dirrmtry %%ETCDIR%%/static
@@ -74,3 +72,5 @@ www/cgi-bin/munin-cgi-html
@exec mkdir -p %D/%%ETCDIR%%/munin-conf.d
@dirrmtry %%ETCDIR%%/munin-conf.d
@dirrmtry %%ETCDIR%%
+@cwd /var
+@dirrm munin/cgi-tmp
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index cf3106b10fc2..c17fa52de9a8 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -63,7 +63,7 @@ MAN3= ${MAN3_NODE} ${MAN3_PLUGIN}
MAN5= munin-node.conf.5
MAN8= munin.8
-SUB_FILES= pkg-message munin-node-revive.sh
+SUB_FILES= pkg-message
USE_RC_SUBR= munin-node munin-sched
post-patch:
@@ -109,7 +109,7 @@ post-install:
done)
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${ECHO} ${PORTVERSION} > ${PREFIX}/etc/munin/VERSION.node
+ @${ECHO} ${PORTVERSION} > /tmp/.munin-node.version
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/sysutils/munin-node/files/munin-node-revive.sh.in b/sysutils/munin-node/files/munin-node-revive.sh.in
deleted file mode 100644
index 5da4c067bedc..000000000000
--- a/sysutils/munin-node/files/munin-node-revive.sh.in
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-
-#
-# Add the following lines to /etc/rc.conf to enable munin-node:
-# munin_node_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable munin-node
-# munin_node_config (path): Set to "%%PREFIX%%/etc/munin/munin-node.conf" by default.
-#
-
-. /etc/rc.subr
-
-name="munin_node"
-rcvar=munin_node_enable
-
-[ -z "$munin_node_enable" ] && munin_node_enable="NO"
-[ -z "$munin_node_config" ] && munin_node_config="%%PREFIX%%/etc/munin/munin-node.conf"
-
-command="%%PREFIX%%/sbin/munin-node"
-pidfile=`awk '$1 == "pid_file" { print $2 }' $munin_node_config`
-
-load_rc_config $name
-
-#set -x
-pid=`check_pidfile $pidfile %%PREFIX%%/sbin/munin-node`
-if [ -z "$pid" ]; then
- run_rc_command start > /dev/null
-fi
diff --git a/sysutils/munin-node/files/munin-node.in b/sysutils/munin-node/files/munin-node.in
index f481b83621b7..40998c5b0fde 100644
--- a/sysutils/munin-node/files/munin-node.in
+++ b/sysutils/munin-node/files/munin-node.in
@@ -1,10 +1,11 @@
#!/bin/sh
#
-
+# $FreeBSD$
+#
# PROVIDE: munin-node
# REQUIRE: DAEMON
# BEFORE: cron
-
+# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable munin-node:
# munin_node_enable (bool): Set to "NO" by default.
@@ -17,12 +18,25 @@
name="munin_node"
rcvar=munin_node_enable
-[ -z "$munin_node_enable" ] && munin_node_enable="NO"
-[ -z "$munin_node_config" ] && munin_node_config="%%PREFIX%%/etc/munin/munin-node.conf"
+load_rc_config $name
+
+: ${munin_node_enable:=NO}
+: ${munin_node_config="%%PREFIX%%/etc/munin/munin-node.conf"}
command="%%PREFIX%%/sbin/munin-node"
-command_interpreter="%%PERL%%"
-pidfile=`awk '$1 == "pid_file" { print $2 }' $munin_node_config`
+command_interpreter="/usr/bin/perl"
+start_precmd=find_pidfile
+status_precmd=find_pidfile
+stop_precmd=find_pidfile
+
+find_pidfile()
+{
+ if type get_pidfile_from_conf >/dev/null 2>&1 &&
+ get_pidfile_from_conf pid_file $munin_node_config; then
+ pidfile="$_pidfile_from_conf"
+ else
+ pidfile=`awk '$1 == "pid_file" { print $2 }' $munin_node_config`
+ fi
+}
-load_rc_config $name
run_rc_command "$1"
diff --git a/sysutils/munin-node/files/munin-sched.in b/sysutils/munin-node/files/munin-sched.in
index 488d3d205e67..e866e79ef729 100644
--- a/sysutils/munin-node/files/munin-sched.in
+++ b/sysutils/munin-node/files/munin-sched.in
@@ -1,10 +1,11 @@
#!/bin/sh
#
-
+# $FreeBSD$
+#
# PROVIDE: munin-sched
# REQUIRE: DAEMON
# BEFORE: cron
-
+# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable munin-sched:
# munin_sched_enable (bool): Set to "NO" by default.
@@ -17,11 +18,25 @@
name="munin_sched"
rcvar=munin_sched_enable
-[ -z "$munin_sched_enable" ] && munin_sched_enable="NO"
-[ -z "$munin_sched_config" ] && munin_sched_config="%%PREFIX%%/etc/munin/munin-node.conf"
+load_rc_config $name
+
+: ${munin_sched_enable:=NO}
+: ${munin_sched_config="%%PREFIX%%/etc/munin/munin-node.conf"}
command="%%PREFIX%%/sbin/munin-sched"
-pidfile=`awk '$1 == "pid_file" { gsub("node","sched",$2); print $2; }' $munin_sched_config`
+start_precmd=find_pidfile
+status_precmd=find_pidfile
+stop_precmd=find_pidfile
+
+find_pidfile()
+{
+ if type get_pidfile_from_conf >/dev/null 2>&1 &&
+ get_pidfile_from_conf pid_file $munin_node_config; then
+ pidfile="${_pidfile_from_conf%node*}sched"
+ pidfile="${pidfile}${_pidfile_from_conf#*node}"
+ else
+ pidfile=`awk '$1 == "pid_file" { gsub("node","sched",$2); print $2; }' $munin_sched_config`
+ fi
+}
-load_rc_config $name
run_rc_command "$1"
diff --git a/sysutils/munin-node/pkg-deinstall b/sysutils/munin-node/pkg-deinstall
index cc61d62e58f9..adfdda136117 100644
--- a/sysutils/munin-node/pkg-deinstall
+++ b/sysutils/munin-node/pkg-deinstall
@@ -37,18 +37,6 @@ stop_process() {
fi
}
-delete_crontab_entries() {
- local prog
- prog=$1
-
- if grep -q "^[^#]*$prog" /etc/crontab; then
- TMPFILE=`mktemp -t munin` || exit 1
- grep -v $prog /etc/crontab > $TMPFILE
- cat $TMPFILE > /etc/crontab
- rm $/etc/crontab
- fi
-}
-
delnewsyslog() {
tmp="/etc/#munin-node$$"
sed -e '/^\/var\/log\/munin\/munin-node.log[ ]/d' /etc/newsyslog.conf >${tmp}
@@ -74,7 +62,6 @@ Do you want me to delete it?" y; then
case $2 in
DEINSTALL)
if [ -z "${PACKAGE_BUILDING}" ]; then
- delete_crontab_entries ${PKG_PREFIX}/bin/munin-node-revive
stop_process
newsyslog
fi
diff --git a/sysutils/munin-node/pkg-install b/sysutils/munin-node/pkg-install
index 844291440b42..a793c928d3a8 100644
--- a/sysutils/munin-node/pkg-install
+++ b/sysutils/munin-node/pkg-install
@@ -30,8 +30,8 @@ yesno() {
}
init_plugins() {
- if [ -f ${PKG_PREFIX}/etc/munin/VERSION.node ]; then
- prevver=$(cat ${PKG_PREFIX}/etc/munin/VERSION.node)
+ if [ -f /tmp/.munin-node.version ]; then
+ prevver=$(cat /tmp/.munin-node.version)
fi
if [ -n "$prevver" ]; then
@@ -73,9 +73,6 @@ newsyslog() {
/var/log/munin/munin-node.log 644 7 * @T00 Z /var/run/munin/munin-node.pid
EOT
fi
- if [ -f ${PKG_PREFIX}/bin/munin-node-revive ]; then
- create_crontab_entries '4 * * * *' ${PKG_PREFIX}/bin/munin-node-revive
- fi
else
echo "/var/log/munin-node.log will grow without bounds."
fi
diff --git a/sysutils/munin-node/pkg-plist b/sysutils/munin-node/pkg-plist
index af5d767d31f0..5a86fb8e9125 100644
--- a/sysutils/munin-node/pkg-plist
+++ b/sysutils/munin-node/pkg-plist
@@ -224,8 +224,6 @@ sbin/munin-sched
%%DATADIR%%/plugins/varnish_
%%DATADIR%%/plugins/vmstat
%%DATADIR%%/plugins/zimbra_
-@dirrmtry %%DBDIR%%/plugin-state
-@dirrmtry %%DBDIR%%
@dirrm %%DATADIR%%/plugins
@dirrmtry %%DATADIR%%
@dirrm %%SITE_PERL%%/Munin/Plugin
@@ -237,3 +235,5 @@ sbin/munin-sched
@exec mkdir -p %D/%%ETCDIR%%/plugin-conf.d
@dirrmtry %%ETCDIR%%/plugin-conf.d
@dirrmtry %%ETCDIR%%
+@cwd /var
+@dirrmtry munin/plugin-state