aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/jlatexmath/Makefile33
-rw-r--r--math/jlatexmath/distinfo3
-rw-r--r--math/jlatexmath/pkg-descr24
-rw-r--r--math/jlatexmath/pkg-plist26
5 files changed, 87 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 6f3c8369e413..564de28c6b05 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -132,6 +132,7 @@
SUBDIR += jama
SUBDIR += javanns
SUBDIR += javaview
+ SUBDIR += jlatexmath
SUBDIR += jsmath
SUBDIR += jsmath-fonts
SUBDIR += jsmath-fonts-sprite
diff --git a/math/jlatexmath/Makefile b/math/jlatexmath/Makefile
new file mode 100644
index 000000000000..8fdc662eb723
--- /dev/null
+++ b/math/jlatexmath/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: jlatexmath
+# Date created: 11 February 2010
+# Whom: rfarmer@predatorlabs.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= jlatexmath
+PORTVERSION= 0.8.9
+CATEGORIES= math java
+MASTER_SITES= http://forge.scilab.org/upload/jlatexmath/files/ \
+ http://www.predatorlabs.net/dl/
+DISTNAME= ${PORTNAME}-src-all-${PORTVERSION}
+EXTRACT_SUFX= .jar
+
+MAINTAINER= rfarmer@predatorlabs.net
+COMMENT= Java API to display mathematical formulas written in LaTeX
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+JAVA_BUILD= yes
+JAVA_RUN= yes
+USE_ANT= yes
+
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-0.8.9.jar ${JAVAJARDIR}
+.if !defined(NOPORTDOCS)
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/jlatexmath/distinfo b/math/jlatexmath/distinfo
new file mode 100644
index 000000000000..bdae3e5c5590
--- /dev/null
+++ b/math/jlatexmath/distinfo
@@ -0,0 +1,3 @@
+MD5 (jlatexmath-src-all-0.8.9.jar) = cef10764c65fd7b48e5349713a99a608
+SHA256 (jlatexmath-src-all-0.8.9.jar) = d0972c70799a16bfe9689ecc3120295fd77be32a07ab289af938ee5ed07fa8e7
+SIZE (jlatexmath-src-all-0.8.9.jar) = 1077515
diff --git a/math/jlatexmath/pkg-descr b/math/jlatexmath/pkg-descr
new file mode 100644
index 000000000000..98f97ba10139
--- /dev/null
+++ b/math/jlatexmath/pkg-descr
@@ -0,0 +1,24 @@
+The goal of this Java API is to display mathematical formulas written in
+LaTeX. The default encoding is UTF-8.
+
+The most of LaTeX commands are available and :
+
+ 1) macros from amsmath and symbols from amssymb and stmaryrd;
+ 2) \includegraphics (without options);
+ 3) the TeX macro \over;
+ 4) accents from amsxtra package;
+ 5) the macros \definecolor, \textcolor, \colorbox and \fcolorbox from the
+ package color;
+ 6) the macros \rotatebox, \reflectbox and \scalebox from the package graphicx;
+ 7) the most of latin unicode characters are available and cyrillic or
+ greek characters are detected for the loading of the different fonts;
+ 8) the commands \newcommand and \newenvironment;
+ 9) the environments array, matrix, pmatrix,..., eqnarray, cases;
+10) the fonts are embedded in the jar file to be used by fop 0.95 to generate
+ PDF, PS or EPS (SVG export with shaped fonts works fine too);
+11) and probably other things I forgot...
+
+There is no dependency and no external programs to install : JLaTeXMath is
+fully functional by itself.
+
+WWW: http://forge.scilab.org/index.php/p/jlatexmath/
diff --git a/math/jlatexmath/pkg-plist b/math/jlatexmath/pkg-plist
new file mode 100644
index 000000000000..20d3384a780d
--- /dev/null
+++ b/math/jlatexmath/pkg-plist
@@ -0,0 +1,26 @@
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Example1.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Example2.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Example3.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Example4.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/Main.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Basic/lion.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/Convert.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/Example1.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/Example2.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/Example3.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/Example4.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/Main.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/build.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Export/lion.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Macros/FooPackage.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Macros/Main.java
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Macros/Package_Foo.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Macros/README
+share/java/classes/jlatexmath-0.8.9.jar
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Macros/bin
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Macros
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Export
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/Basic
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@exec mkdir -p %D/%%EXAMPLESDIR%%/Macros/bin