aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/gai/Makefile54
-rw-r--r--x11-toolkits/gai/distinfo2
-rw-r--r--x11-toolkits/gai/pkg-descr10
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 178a7343dc11..e20d9ba284b9 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -23,6 +23,7 @@
SUBDIR += fox
SUBDIR += fox-devel
SUBDIR += freeglut
+ SUBDIR += gai
SUBDIR += gal
SUBDIR += gal2
SUBDIR += gauche-gtk
diff --git a/x11-toolkits/gai/Makefile b/x11-toolkits/gai/Makefile
new file mode 100644
index 000000000000..dbb7a306c7f8
--- /dev/null
+++ b/x11-toolkits/gai/Makefile
@@ -0,0 +1,54 @@
+# ex:ts=8
+# Ports collection makefile for: gai
+# Date created: Feb 16, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gai
+PORTVERSION= 0.5.2
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= General Applet Interface Library
+
+LIB_DEPENDS= gtkglext-x11-1.0.2:${PORTSDIR}/x11-toolkits/gtkglext
+
+USE_REINPLACE= yes
+USE_BZIP2= yes
+USE_GL= yes
+USE_SDL= yes
+USE_GNOME= gnomehack gnomeprefix gtk20 pango gnomepanel
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDLCONF=${SDL_CONFIG}
+
+PLIST_FILES= include/gai/gai.h lib/libgai.so.0.5.2 lib/libgai.so.0 \
+ lib/libgai.so libdata/pkgconfig/gai.pc
+PLIST_DIRS= include/gai
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|sdl-config --|${SDL_CONFIG} --|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|lib/pkgconfig/|libdata/pkgconfig/|" ${WRKSRC}/gai/Makefile.in
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for file in FAQ.html referenceguide.html
+ ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
+ @${ECHO_CMD} "${DOCSDIR:S,^${PREFIX},,}/${file}" >> ${TMPPLIST}
+.endfor
+ @${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX},,}" >> ${TMPPLIST}
+ @${MKDIR} ${EXAMPLESDIR}
+.for dir in docking examples templates
+ ${CP} -R ${WRKSRC}/${dir} ${EXAMPLESDIR}
+.endfor
+ @${FIND} ${EXAMPLESDIR} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gai/distinfo b/x11-toolkits/gai/distinfo
new file mode 100644
index 000000000000..42385444a31a
--- /dev/null
+++ b/x11-toolkits/gai/distinfo
@@ -0,0 +1,2 @@
+MD5 (gai-0.5.2.tar.bz2) = a9d53513b002cedabf2a1ee29ad2d712
+SIZE (gai-0.5.2.tar.bz2) = 185549
diff --git a/x11-toolkits/gai/pkg-descr b/x11-toolkits/gai/pkg-descr
new file mode 100644
index 000000000000..42cacdb3e51c
--- /dev/null
+++ b/x11-toolkits/gai/pkg-descr
@@ -0,0 +1,10 @@
+GAI, The General Applet Interface library is a library that will help applet
+programmers alot. The goal of this library is to give programmers a simple yet
+powerful applet interface. This library supports both Dockapps and Gnome 2
+Panel Applets. The applet program doesn't have to care about if the applet
+will be used on the Gnome panel or in the dock. The library handles that.
+Over 50% of the code in a Dockapp and a Gnome 2 Panel applet does actully
+only one thing, setting up the applet window. With GAI, this can be reduced
+to just a few lines of code.
+
+WWW: http://gai.sourceforge.net/