aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/nginx-devel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index bf3161885b12..15d8d3fed692 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -25,6 +25,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_CACHE_MODULE "Enable http_cache module" on \
HTTP_DAV_MODULE "Enable http_webdav module" off \
HTTP_FLV_MODULE "Enable http_flv module" off \
+ HTTP_GEOIP_MODULE "Enable http_geoip module" off \
HTTP_GZIP_STATIC_MODULE "Enable http_gzip_static module" off \
HTTP_PERL_MODULE "Enable http_perl module" off \
HTTP_RANDOM_INDEX_MODULE "Enable http_random_index module" off \
@@ -157,6 +158,11 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-fancyindex-${NGINX_FANCYINDEX_MODUL
CONFIGURE_ARGS+=--with-http_flv_module
.endif
+.if defined(WITH_HTTP_GEOIP_MODULE)
+CONFIGURE_ARGS+=--with-http_geoip_module
+LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
+.endif
+
.if defined(WITH_HTTP_GZIP_STATIC_MODULE)
CONFIGURE_ARGS+=--with-http_gzip_static_module
.endif