aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/node-devel/Makefile2
-rw-r--r--www/node-devel/distinfo4
-rw-r--r--www/node-devel/files/patch-man-and-pkgconfig-path10
-rw-r--r--www/node-devel/files/patch-platform-freebsd17
4 files changed, 12 insertions, 21 deletions
diff --git a/www/node-devel/Makefile b/www/node-devel/Makefile
index 5c82189aa5e2..f230ad249bb1 100644
--- a/www/node-devel/Makefile
+++ b/www/node-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= node
-PORTVERSION= 0.3.7
+PORTVERSION= 0.4.0
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/
PKGNAMESUFFIX= -devel
diff --git a/www/node-devel/distinfo b/www/node-devel/distinfo
index f3567f065d2d..19e14feea522 100644
--- a/www/node-devel/distinfo
+++ b/www/node-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.3.7.tar.gz) = 21c53e74684a8a3c3d14d14a49a07fa8250f0e41514b448182ef0d1f5bbba52f
-SIZE (node-v0.3.7.tar.gz) = 4748183
+SHA256 (node-v0.4.0.tar.gz) = 4a30bd9963373cb86a994479bdd451ab3b6f2124f0089493366315da79d3408e
+SIZE (node-v0.4.0.tar.gz) = 4827760
diff --git a/www/node-devel/files/patch-man-and-pkgconfig-path b/www/node-devel/files/patch-man-and-pkgconfig-path
index 9a6e3dbfb145..b509f022af8a 100644
--- a/www/node-devel/files/patch-man-and-pkgconfig-path
+++ b/www/node-devel/files/patch-man-and-pkgconfig-path
@@ -1,15 +1,15 @@
---- wscript.orig 2010-10-24 07:00:15.000000000 +0800
-+++ wscript 2010-10-26 18:09:54.000000000 +0800
-@@ -571,8 +571,6 @@
+--- wscript.orig 2011-02-05 15:45:34.000000000 +0800
++++ wscript 2011-02-05 15:46:27.000000000 +0800
+@@ -810,8 +810,6 @@
# Only install the man page if it exists.
# Do 'make doc install' to build and install it.
- if os.path.exists('doc/node.1'):
- bld.install_files('${PREFIX}/share/man/man1/', 'doc/node.1')
- bld.install_files('${PREFIX}/bin/', 'bin/*', chmod=0755)
+ bld.install_files('${PREFIX}/bin/', 'tools/node-waf', chmod=0755)
bld.install_files('${PREFIX}/lib/node/wafadmin', 'tools/wafadmin/*.py')
-@@ -584,7 +582,7 @@
+@@ -823,7 +821,7 @@
node_conf.target = 'tools/nodejs.pc'
node_conf.dict = subflags(node)
diff --git a/www/node-devel/files/patch-platform-freebsd b/www/node-devel/files/patch-platform-freebsd
index 465b61b176c8..1b2684957452 100644
--- a/www/node-devel/files/patch-platform-freebsd
+++ b/www/node-devel/files/patch-platform-freebsd
@@ -1,15 +1,6 @@
---- deps/v8/src/platform-freebsd.cc.orig 2011-01-22 10:18:37.000000000 +0800
-+++ deps/v8/src/platform-freebsd.cc 2011-01-22 21:44:50.000000000 +0800
-@@ -416,7 +416,7 @@
-
-
- Thread::Thread(const char* name) : ThreadHandle(ThreadHandle::INVALID) {
-- set_names(name);
-+ set_name(name);
- }
-
-
-@@ -512,6 +512,16 @@
+--- deps/v8/src/platform-freebsd.cc.orig 2011-02-05 15:15:52.000000000 +0800
++++ deps/v8/src/platform-freebsd.cc 2011-02-05 15:34:20.000000000 +0800
+@@ -526,6 +526,16 @@
return result;
}
@@ -26,7 +17,7 @@
private:
pthread_mutex_t mutex_; // Pthread mutex for POSIX platforms.
};
-@@ -590,7 +600,7 @@
+@@ -604,7 +614,7 @@
TickSample sample;
// We always sample the VM state.