aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.php.mk3
-rw-r--r--finance/Makefile1
-rw-r--r--finance/php4-pfpro/Makefile15
-rw-r--r--lang/php4-extensions/Makefile5
-rw-r--r--lang/php4/Makefile.ext5
5 files changed, 26 insertions, 3 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 2c2f19b53967..5736741f6c44 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -254,7 +254,7 @@ _USE_PHP_ALL= bcmath bz2 calendar ctype curl dba dbase \
exif fileinfo filepro fribidi ftp gd gettext gmp \
iconv imagick imap interbase ldap mbstring mcrypt \
mhash ming mssql mysql ncurses odbc \
- openssl panda pcntl pcre pdf pgsql posix \
+ openssl panda pcntl pcre pdf pfpro pgsql posix \
pspell radius readline recode session shmop snmp \
sockets sybase_ct sysvmsg sysvsem sysvshm \
tokenizer wddx xml xmlrpc yaz zip zlib
@@ -308,6 +308,7 @@ panda_DEPENDS= print/pecl-panda
pcntl_DEPENDS= devel/php${PHP_VER}-pcntl
pcre_DEPENDS= devel/php${PHP_VER}-pcre
pdf_DEPENDS= print/pecl-pdflib
+pfpro_DEPENDS= finance/php${PHP_VER}-pfpro
pgsql_DEPENDS= databases/php${PHP_VER}-pgsql
posix_DEPENDS= sysutils/php${PHP_VER}-posix
pspell_DEPENDS= textproc/php${PHP_VER}-pspell
diff --git a/finance/Makefile b/finance/Makefile
index c65d5338cd3b..b26e62a1b79b 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -52,6 +52,7 @@
SUBDIR += p5-Locale-Currency-Format
SUBDIR += p5-Math-Financial
SUBDIR += pfpro
+ SUBDIR += php4-pfpro
SUBDIR += qhacc
SUBDIR += qtstalker
SUBDIR += quantlib
diff --git a/finance/php4-pfpro/Makefile b/finance/php4-pfpro/Makefile
new file mode 100644
index 000000000000..2e64d9adc2f2
--- /dev/null
+++ b/finance/php4-pfpro/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: php4-pfpro
+# Date created: 12 Dec 2005
+# Whom: Mike Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= finance
+PKGNAMESUFFIX= -pfpro
+
+COMMENT= PHP VeriSign PayFlow Pro credit card processing
+
+MASTERDIR= ${.CURDIR}/../../lang/php4
+
+.include "${MASTERDIR}/Makefile"
diff --git a/lang/php4-extensions/Makefile b/lang/php4-extensions/Makefile
index 85934c081e80..f0b429dfb820 100644
--- a/lang/php4-extensions/Makefile
+++ b/lang/php4-extensions/Makefile
@@ -74,6 +74,7 @@ OPTIONS= BCMATH "bc style precision math functions" off \
PCNTL "pcntl support (CLI only)" off \
PCRE "Perl Compatible Regular Expression support" on \
PDF "PDFlib support (implies GD)" off \
+ PFPRO "PayFlow Pro support" off \
PGSQL "PostgreSQL database support" off \
POSIX "POSIX-like functions" on \
PSPELL "pspell support" off \
@@ -109,8 +110,8 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CRACK CTYPE CURL DBA DBASE DBX DIO \
DOMXML EXIF FILEINFO FILEPRO FRIBIDI FTP GD GETTEXT \
GMP ICONV IMAGICK IMAP INTERBASE LDAP MBSTRING MCAL MCRYPT \
MCVE MHASH MIME_MAGIC MING MNOGOSEARCH MSSQL MYSQL NCURSES \
- ODBC OPENSSL ORACLE OVERLOAD PANDA PCNTL PCRE PDF PGSQL POSIX \
- PSPELL READLINE RECODE SESSION SHMOP SNMP SOCKETS \
+ ODBC OPENSSL ORACLE OVERLOAD PANDA PCNTL PCRE PDF PFPRO \
+ PGSQL POSIX PSPELL READLINE RECODE SESSION SHMOP SNMP SOCKETS \
SYBASE_CT SYSVMSG SYSVSEM SYSVSHM TOKENIZER \
WDDX XML XMLRPC XSLT YAZ YP ZIP ZLIB
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index fe616c381db6..830e33195f37 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -262,6 +262,11 @@ CONFIGURE_ARGS+=--with-pcre-regex=yes
PHP_HEADER_DIRS=pcrelib
.endif
+.if ${PHP_MODNAME} == "pfpro"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libpfpro.so:${PORTSDIR}/finance/pfpro
+CONFIGURE_ARGS+=--with-pfpro
+.endif
+
.if ${PHP_MODNAME} == "pgsql"
USE_PGSQL= YES