aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-GPS-Babel/Makefile26
-rw-r--r--astro/p5-GPS-Babel/distinfo3
-rw-r--r--astro/p5-GPS-Babel/pkg-descr3
-rw-r--r--astro/p5-GPS-Babel/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index ee369feccb56..8b1868a7bcc9 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -53,6 +53,7 @@
SUBDIR += p5-Astro-Sunrise
SUBDIR += p5-Astro-satpass
SUBDIR += p5-GPS
+ SUBDIR += p5-GPS-Babel
SUBDIR += p5-Geo-METAR
SUBDIR += p5-Weather-Underground
SUBDIR += phoon
diff --git a/astro/p5-GPS-Babel/Makefile b/astro/p5-GPS-Babel/Makefile
new file mode 100644
index 000000000000..50d88c7fb9d6
--- /dev/null
+++ b/astro/p5-GPS-Babel/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: p5-GPS-Babel
+# Date created: 30 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GPS-Babel
+PORTVERSION= 0.11
+CATEGORIES= astro perl5 geography
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl interface to gpsbabel
+
+BUILD_DEPENDS= p5-Geo-Gpx>=0.25:${PORTSDIR}/graphics/p5-Geo-Gpx \
+ p5-File-Which>=0.05:${PORTSDIR}/sysutils/p5-File-Which
+RUN_DEPENDS= p5-Geo-Gpx>=0.25:${PORTSDIR}/graphics/p5-Geo-Gpx \
+ p5-File-Which>=0.05:${PORTSDIR}/sysutils/p5-File-Which
+
+PERL_CONFIGURE= yes
+
+MAN3= GPS::Babel.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-GPS-Babel/distinfo b/astro/p5-GPS-Babel/distinfo
new file mode 100644
index 000000000000..2264520143a9
--- /dev/null
+++ b/astro/p5-GPS-Babel/distinfo
@@ -0,0 +1,3 @@
+MD5 (GPS-Babel-0.11.tar.gz) = c9a06535d8d0208ffc9c7264fb02154f
+SHA256 (GPS-Babel-0.11.tar.gz) = 4ff7b06987acf159ed99495d242d169884ea99f336c610c725eb70929a74bed7
+SIZE (GPS-Babel-0.11.tar.gz) = 76313
diff --git a/astro/p5-GPS-Babel/pkg-descr b/astro/p5-GPS-Babel/pkg-descr
new file mode 100644
index 000000000000..53273c5790ca
--- /dev/null
+++ b/astro/p5-GPS-Babel/pkg-descr
@@ -0,0 +1,3 @@
+p5-GPS-Babel is a perl interface to gpsbabel.
+
+WWW: http://search.cpan.org/dist/GPS-Babel/
diff --git a/astro/p5-GPS-Babel/pkg-plist b/astro/p5-GPS-Babel/pkg-plist
new file mode 100644
index 000000000000..e7767f00dda6
--- /dev/null
+++ b/astro/p5-GPS-Babel/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/GPS/Babel.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GPS/Babel/.packlist
+@dirrmtry %%SITE_PERL%%/GPS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GPS/Babel
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GPS