aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Algorithm-MDiff/Makefile23
-rw-r--r--devel/p5-Algorithm-MDiff/distinfo1
-rw-r--r--devel/p5-Algorithm-MDiff/pkg-comment1
-rw-r--r--devel/p5-Algorithm-MDiff/pkg-descr9
-rw-r--r--devel/p5-Algorithm-MDiff/pkg-plist6
6 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 92dadb819fc3..6967fda187b7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -211,6 +211,7 @@
SUBDIR += omniORB
SUBDIR += p5-Agent
SUBDIR += p5-Algorithm-Diff
+ SUBDIR += p5-Algorithm-MDiff
SUBDIR += p5-Alias
SUBDIR += p5-AppConfig
SUBDIR += p5-B-Graph
diff --git a/devel/p5-Algorithm-MDiff/Makefile b/devel/p5-Algorithm-MDiff/Makefile
new file mode 100644
index 000000000000..b5031f804017
--- /dev/null
+++ b/devel/p5-Algorithm-MDiff/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Algorithm::MDiff
+# Date created: 04 Nov 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-MDiff
+PORTVERSION= 0.94
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Algorithm::MDiff.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Algorithm-MDiff/distinfo b/devel/p5-Algorithm-MDiff/distinfo
new file mode 100644
index 000000000000..663c3ce881a6
--- /dev/null
+++ b/devel/p5-Algorithm-MDiff/distinfo
@@ -0,0 +1 @@
+MD5 (Algorithm-MDiff-0.94.tar.gz) = bfb35980fdeb6e93c963ff017a1b75e5
diff --git a/devel/p5-Algorithm-MDiff/pkg-comment b/devel/p5-Algorithm-MDiff/pkg-comment
new file mode 100644
index 000000000000..e9f3863a5817
--- /dev/null
+++ b/devel/p5-Algorithm-MDiff/pkg-comment
@@ -0,0 +1 @@
+Perl interface to calculate m-difference between two objects
diff --git a/devel/p5-Algorithm-MDiff/pkg-descr b/devel/p5-Algorithm-MDiff/pkg-descr
new file mode 100644
index 000000000000..54537268968a
--- /dev/null
+++ b/devel/p5-Algorithm-MDiff/pkg-descr
@@ -0,0 +1,9 @@
+Algorithm::MDiff is another form of comparing two different perl objects.
+M-difference works as follows: Two strings are m-different if at least m
+of the characters in the string differ; that is, if m=3, then there are at
+least 3 indices (i, j, k) such that str1[i] != str2[i], str1[j] != str2[j],
+and str1[k] != str2[k].
+
+Author: Jettero Heller <jettero@voltar.org>
+
+--will
diff --git a/devel/p5-Algorithm-MDiff/pkg-plist b/devel/p5-Algorithm-MDiff/pkg-plist
new file mode 100644
index 000000000000..90b03ec2efae
--- /dev/null
+++ b/devel/p5-Algorithm-MDiff/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Algorithm/MDiff.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Algorithm/MDiff/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Algorithm/MDiff/MDiff.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Algorithm/MDiff/MDiff.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Algorithm/MDiff/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Algorithm/MDiff