aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/mcollective-puppet-agent/Makefile19
-rw-r--r--sysutils/mcollective-puppet-agent/distinfo2
-rw-r--r--sysutils/mcollective-puppet-agent/pkg-descr4
-rw-r--r--sysutils/mcollective-puppet-agent/pkg-plist65
-rw-r--r--sysutils/mcollective-puppet-client/Makefile20
-rw-r--r--sysutils/mcollective-puppet-common/Makefile46
-rw-r--r--sysutils/mcollective-puppet-common/distinfo2
-rw-r--r--sysutils/mcollective-puppet-common/pkg-descr3
9 files changed, 80 insertions, 83 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 3080c441ee75..f2fa9a2083f6 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -551,6 +551,8 @@
SUBDIR += mcollective-nettest-common
SUBDIR += mcollective-nrpe-agent
SUBDIR += mcollective-puppet-agent
+ SUBDIR += mcollective-puppet-client
+ SUBDIR += mcollective-puppet-common
SUBDIR += mcollective-service-agent
SUBDIR += mcollective-service-client
SUBDIR += mcollective-service-common
diff --git a/sysutils/mcollective-puppet-agent/Makefile b/sysutils/mcollective-puppet-agent/Makefile
index 9a12be294fe5..43ad97b675c4 100644
--- a/sysutils/mcollective-puppet-agent/Makefile
+++ b/sysutils/mcollective-puppet-agent/Makefile
@@ -2,23 +2,18 @@
# $FreeBSD$
PORTNAME= mcollective-puppet-agent
-PORTVERSION= 1.7.0
-CATEGORIES= sysutils
-MAINTAINER= anes@anes.su
-COMMENT= Puppet agent manager for mcollective
+COMMENT= MCollective agent to manage the Puppet Agent
-RUN_DEPENDS= mcollective>=2:sysutils/mcollective
+# See MASTERDIR for MAINTAINER.
-USE_GITHUB= yes
-GH_ACCOUNT= puppetlabs
+RUN_DEPENDS= mcollective-puppet-common>=${PORTVERSION}:${PORTSDIR}/sysutils/mcollective-puppet-common
-NO_BUILD= yes
+MASTERDIR= ${.CURDIR}/../mcollective-puppet-common
-MCOLLECTIVEDIR= ${STAGEDIR}${PREFIX}/share/mcollective
+PLIST_FILES= share/mcollective/agent/puppet.rb
do-install:
- @${MKDIR} ${MCOLLECTIVEDIR}
- @cd ${WRKSRC} && ${PAX} -r -w . ${MCOLLECTIVEDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "agent/*.rb" ${STAGEDIR}${PREFIX}/share/mcollective
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/mcollective-puppet-agent/distinfo b/sysutils/mcollective-puppet-agent/distinfo
deleted file mode 100644
index 4d1665204839..000000000000
--- a/sysutils/mcollective-puppet-agent/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (puppetlabs-mcollective-puppet-agent-1.7.0_GH0.tar.gz) = 45260fa83b9f9f532612d75e5873ad646faa50c852e761df22b9673b7863f115
-SIZE (puppetlabs-mcollective-puppet-agent-1.7.0_GH0.tar.gz) = 38030
diff --git a/sysutils/mcollective-puppet-agent/pkg-descr b/sysutils/mcollective-puppet-agent/pkg-descr
deleted file mode 100644
index 848de0b8c2bf..000000000000
--- a/sysutils/mcollective-puppet-agent/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-This agent manages the puppet agent, unlike the older puppetd plugin this one
-supports Puppet 3 and recent changes made to its locking and status files.
-
-WWW: https://github.com/puppetlabs/mcollective-puppet-agent/
diff --git a/sysutils/mcollective-puppet-agent/pkg-plist b/sysutils/mcollective-puppet-agent/pkg-plist
deleted file mode 100644
index f6c0400fb4f5..000000000000
--- a/sysutils/mcollective-puppet-agent/pkg-plist
+++ /dev/null
@@ -1,65 +0,0 @@
-share/mcollective/.gitignore
-share/mcollective/.rspec
-share/mcollective/.travis.yml
-share/mcollective/CHANGELOG.md
-share/mcollective/Gemfile
-share/mcollective/README.md
-share/mcollective/Rakefile
-share/mcollective/agent/puppet.ddl
-share/mcollective/agent/puppet.rb
-share/mcollective/aggregate/boolean_summary.ddl
-share/mcollective/aggregate/boolean_summary.rb
-share/mcollective/application/puppet.rb
-share/mcollective/data/puppet_data.ddl
-share/mcollective/data/puppet_data.rb
-share/mcollective/data/resource_data.ddl
-share/mcollective/data/resource_data.rb
-share/mcollective/ext/build_defaults.yaml
-share/mcollective/ext/packaging.rake
-share/mcollective/ext/project_data.yaml
-share/mcollective/ext/debian/changelog.erb
-share/mcollective/ext/debian/compat
-share/mcollective/ext/debian/control
-share/mcollective/ext/debian/copyright
-share/mcollective/ext/debian/mcollective-puppet-agent.install
-share/mcollective/ext/debian/mcollective-puppet-client.install
-share/mcollective/ext/debian/mcollective-puppet-common.install
-share/mcollective/ext/debian/rules
-share/mcollective/ext/redhat/mcollective-puppet.spec.erb
-share/mcollective/spec/spec_helper.rb
-share/mcollective/spec/agent/puppet_agent_spec.rb
-share/mcollective/spec/aggregate/boolean_summary_spec.rb
-share/mcollective/spec/application/puppet_spec.rb
-share/mcollective/spec/data/puppet_data_spec.rb
-share/mcollective/spec/data/resource_data_spec.rb
-share/mcollective/spec/fixtures/last_run_report.yaml
-share/mcollective/spec/fixtures/last_run_summary.yaml
-share/mcollective/spec/util/puppet_agent_mgr_spec.rb
-share/mcollective/spec/util/puppetrunner_spec.rb
-share/mcollective/spec/util/puppet_agent_mgr/common_spec.rb
-share/mcollective/spec/util/v2/manager_spec.rb
-share/mcollective/spec/util/v2/unix_spec.rb
-share/mcollective/spec/util/v3/manager_spec.rb
-share/mcollective/spec/util/v3/unix_spec.rb
-share/mcollective/spec/util/v3/windows_spec.rb
-share/mcollective/spec/validator/puppet_resource_validator_spec.rb
-share/mcollective/spec/validator/puppet_server_address_validator_spec.rb
-share/mcollective/spec/validator/puppet_tags_validator_spec.rb
-share/mcollective/spec/validator/puppet_variable_validator_spec.rb
-share/mcollective/util/puppet_agent_mgr.rb
-share/mcollective/util/puppetrunner.rb
-share/mcollective/util/puppet_agent_mgr/common.rb
-share/mcollective/util/puppet_agent_mgr/v2/manager.rb
-share/mcollective/util/puppet_agent_mgr/v2/unix.rb
-share/mcollective/util/puppet_agent_mgr/v2/windows.rb
-share/mcollective/util/puppet_agent_mgr/v3/manager.rb
-share/mcollective/util/puppet_agent_mgr/v3/unix.rb
-share/mcollective/util/puppet_agent_mgr/v3/windows.rb
-share/mcollective/validator/puppet_resource_validator.ddl
-share/mcollective/validator/puppet_resource_validator.rb
-share/mcollective/validator/puppet_server_address_validator.ddl
-share/mcollective/validator/puppet_server_address_validator.rb
-share/mcollective/validator/puppet_tags_validator.ddl
-share/mcollective/validator/puppet_tags_validator.rb
-share/mcollective/validator/puppet_variable_validator.ddl
-share/mcollective/validator/puppet_variable_validator.rb
diff --git a/sysutils/mcollective-puppet-client/Makefile b/sysutils/mcollective-puppet-client/Makefile
new file mode 100644
index 000000000000..5bef713cdd43
--- /dev/null
+++ b/sysutils/mcollective-puppet-client/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= mcollective-puppet-client
+
+COMMENT= MCollective client to manage the Puppet Agent
+
+# See MASTERDIR for MAINTAINER.
+
+RUN_DEPENDS= mcollective-puppet-common>=${PORTVERSION}:${PORTSDIR}/sysutils/mcollective-puppet-common
+
+MASTERDIR= ${.CURDIR}/../mcollective-puppet-common
+
+PLIST_FILES= share/mcollective/application/puppet.rb \
+ share/mcollective/aggregate/boolean_summary.ddl \
+ share/mcollective/aggregate/boolean_summary.rb
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "aggregate application" ${STAGEDIR}${PREFIX}/share/mcollective
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/mcollective-puppet-common/Makefile b/sysutils/mcollective-puppet-common/Makefile
new file mode 100644
index 000000000000..8511c6e3a82c
--- /dev/null
+++ b/sysutils/mcollective-puppet-common/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME?= mcollective-puppet-common
+PORTVERSION= 1.10.0
+CATEGORIES= sysutils
+
+MAINTAINER= anes@anes.su
+COMMENT?= MCollective common files to manage the Puppet Agent
+
+LICENSE= APACHE20
+
+RUN_DEPENDS?= mcollective>=2:${PORTSDIR}/sysutils/mcollective
+
+USE_GITHUB= yes
+GH_ACCOUNT= puppetlabs
+GH_PROJECT= mcollective-puppet-agent
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES?= share/mcollective/agent/puppet.ddl \
+ share/mcollective/data/puppet_data.ddl \
+ share/mcollective/data/puppet_data.rb \
+ share/mcollective/data/resource_data.ddl \
+ share/mcollective/data/resource_data.rb \
+ share/mcollective/util/puppet_agent_mgr.rb \
+ share/mcollective/util/puppet_agent_mgr/mgr_v2.rb \
+ share/mcollective/util/puppet_agent_mgr/mgr_v3.rb \
+ share/mcollective/util/puppet_agent_mgr/mgr_windows.rb \
+ share/mcollective/util/puppet_server_address_validation.rb \
+ share/mcollective/util/puppetrunner.rb \
+ share/mcollective/validator/puppet_resource_validator.ddl \
+ share/mcollective/validator/puppet_resource_validator.rb \
+ share/mcollective/validator/puppet_server_address_validator.ddl \
+ share/mcollective/validator/puppet_server_address_validator.rb \
+ share/mcollective/validator/puppet_tags_validator.ddl \
+ share/mcollective/validator/puppet_tags_validator.rb \
+ share/mcollective/validator/puppet_variable_validator.ddl \
+ share/mcollective/validator/puppet_variable_validator.rb
+
+.if !target(do-install)
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "agent/*.ddl data util validator" ${STAGEDIR}${PREFIX}/share/mcollective
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/mcollective-puppet-common/distinfo b/sysutils/mcollective-puppet-common/distinfo
new file mode 100644
index 000000000000..7c4802e56ed2
--- /dev/null
+++ b/sysutils/mcollective-puppet-common/distinfo
@@ -0,0 +1,2 @@
+SHA256 (puppetlabs-mcollective-puppet-agent-1.10.0_GH0.tar.gz) = 8b074bced98e70fdc668396516892c96aff0c83e79c3726f881ca221e947ea86
+SIZE (puppetlabs-mcollective-puppet-agent-1.10.0_GH0.tar.gz) = 44759
diff --git a/sysutils/mcollective-puppet-common/pkg-descr b/sysutils/mcollective-puppet-common/pkg-descr
new file mode 100644
index 000000000000..2f94991138e6
--- /dev/null
+++ b/sysutils/mcollective-puppet-common/pkg-descr
@@ -0,0 +1,3 @@
+The mcollective puppet agent manages the puppet agent via MCollective.
+
+WWW: https://github.com/puppetlabs/mcollective-puppet-agent