aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/v8/Makefile18
-rw-r--r--lang/v8/distinfo34
-rw-r--r--lang/v8/files/patch-build_config_compiler_BUILD.gn56
-rw-r--r--lang/v8/files/patch-buildtools_third__party_libc++_BUILD.gn15
4 files changed, 61 insertions, 62 deletions
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 9b2f9c5a7db0..d7dccba0eb58 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -1,8 +1,8 @@
# We follow the stable channel on https://omahaproxy.appspot.com/
-# https://chromium.googlesource.com/v8/v8/+/refs/heads/9.2-lkgr
+# https://chromium.googlesource.com/v8/v8/+/refs/heads/9.3-lkgr
PORTNAME= v8
-PORTVERSION= 9.2.230.22
+PORTVERSION= 9.3.345.19
CATEGORIES= lang
MASTER_SITES= LOCAL/sunpoet/v8/${PORTVERSION:R:R}
DISTFILES= build-${BUILD_REV}.tar.gz \
@@ -26,7 +26,7 @@ BUILD_DEPENDS= binutils>=0:devel/binutils \
${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR}
LIB_DEPENDS= libicudata.so:devel/icu
-USES= cpe gnome ninja pkgconfig python:3.5+,build tar:xz
+USES= compiler:c++17-lang cpe gnome ninja pkgconfig python:3.5+,build tar:xz
USE_GNOME= glib20
BINARY_ALIAS= python3=${PYTHON_CMD}
@@ -39,13 +39,13 @@ USE_GITHUB= yes
CPE_VENDOR= google
-BUILD_REV= 4036cf1b17581f5668b487a25e252d56e0321a7f
-BUILDTOOLS_REV= 20b1d0fc13ebaa263a1248f08814f523a86e6bed
-CLANG_REV= a38f01b956e091d5e698d2af484c81cd4e9a2a2d
+BUILD_REV= 2d999384c270a340f592cce0a0fb3f8f94c15290
+BUILDTOOLS_REV= 2500c1d8f3a20a66a7cbafe3f69079a2edb742dd
+CLANG_REV= 9d0a403e85d25b5b0d3016a342d4b83b12941fd5
COMMON_REV= d5bb24e5d9802c8c917fcaa4375d5239a586c168
-GOOGLETEST_REV= 23ef29555ef4789f555f1ba8c51b4c52975f0907
-ICU_REV= f022e298b4f4a782486bb6d5ce6589c998b51fe2
-ZLIB_REV= 5b8d433953beb2a75a755ba321a3076b95f7cdb9
+GOOGLETEST_REV= 4ec4cd23f486bf70efcc5d2caa40f24368f752e3
+ICU_REV= b9dfc58bf9b02ea0365509244aca13841322feb0
+ZLIB_REV= dfbc590f5855bc2765256a743cad0abc56330a30
# Run "gn args --list out/Release" for all variables.
# Some parts don't have use_system_* flag, and can be turned on/off by using
diff --git a/lang/v8/distinfo b/lang/v8/distinfo
index 38d25d012a94..430c4b938fac 100644
--- a/lang/v8/distinfo
+++ b/lang/v8/distinfo
@@ -1,17 +1,17 @@
-TIMESTAMP = 1628103044
-SHA256 (v8/9.2/build-4036cf1b17581f5668b487a25e252d56e0321a7f.tar.gz) = 7b057e4abdec05622d77f7b8abbcdd69f42a77e8afb0b80374e0d4918979ddb3
-SIZE (v8/9.2/build-4036cf1b17581f5668b487a25e252d56e0321a7f.tar.gz) = 1319052
-SHA256 (v8/9.2/buildtools-20b1d0fc13ebaa263a1248f08814f523a86e6bed.tar.gz) = 436a5a1806de6b67d894d85a21cc6c0b630f7ca71bb408a145864858d73b759f
-SIZE (v8/9.2/buildtools-20b1d0fc13ebaa263a1248f08814f523a86e6bed.tar.gz) = 85282
-SHA256 (v8/9.2/clang-a38f01b956e091d5e698d2af484c81cd4e9a2a2d.tar.gz) = c0e4d3b06d1f5cd30b92f6f1bcf8e2e8c29e5ed1184ff62fbdf8b6a544761b64
-SIZE (v8/9.2/clang-a38f01b956e091d5e698d2af484c81cd4e9a2a2d.tar.gz) = 287739
-SHA256 (v8/9.2/common-d5bb24e5d9802c8c917fcaa4375d5239a586c168.tar.gz) = 3f9c1a015f2d1ce9ffb74d3c2c97e5b3d15c7b82797c635466b9d171ae38c174
-SIZE (v8/9.2/common-d5bb24e5d9802c8c917fcaa4375d5239a586c168.tar.gz) = 10404
-SHA256 (v8/9.2/googletest-23ef29555ef4789f555f1ba8c51b4c52975f0907.tar.gz) = f53d2434aa73478a37cc2c8410e1b6111d62738065a065985e3739cd4d67cd74
-SIZE (v8/9.2/googletest-23ef29555ef4789f555f1ba8c51b4c52975f0907.tar.gz) = 873497
-SHA256 (v8/9.2/icu-f022e298b4f4a782486bb6d5ce6589c998b51fe2.tar.gz) = 01b685eb27d2d7886c34e8e8b032601636803d8aea1473b50659936ce5aac2eb
-SIZE (v8/9.2/icu-f022e298b4f4a782486bb6d5ce6589c998b51fe2.tar.gz) = 43673754
-SHA256 (v8/9.2/zlib-5b8d433953beb2a75a755ba321a3076b95f7cdb9.tar.gz) = 35453f228afb9027307f8f66a8a2e49ea3d9b4c2e11fbd7b870a4c7af19a32e7
-SIZE (v8/9.2/zlib-5b8d433953beb2a75a755ba321a3076b95f7cdb9.tar.gz) = 309627
-SHA256 (v8/9.2/v8-v8-9.2.230.22_GH0.tar.gz) = 18be54a1aa6bf07fc704141c1450c4221f6443a63295bca8d0845be9248d798a
-SIZE (v8/9.2/v8-v8-9.2.230.22_GH0.tar.gz) = 27146501
+TIMESTAMP = 1632036874
+SHA256 (v8/9.3/build-2d999384c270a340f592cce0a0fb3f8f94c15290.tar.gz) = a9334d354661e6a57b30dc3947eb03035fa179961ac3cd47dcb8c5126c8a6608
+SIZE (v8/9.3/build-2d999384c270a340f592cce0a0fb3f8f94c15290.tar.gz) = 1328866
+SHA256 (v8/9.3/buildtools-2500c1d8f3a20a66a7cbafe3f69079a2edb742dd.tar.gz) = 9bd8855fa25ada8c13774394dfdfc68010d0234d368dbbb87f23b3ae8f3f33fb
+SIZE (v8/9.3/buildtools-2500c1d8f3a20a66a7cbafe3f69079a2edb742dd.tar.gz) = 86060
+SHA256 (v8/9.3/clang-9d0a403e85d25b5b0d3016a342d4b83b12941fd5.tar.gz) = bb635538b3cfe95dcbf3e26cef1a7fe02be5351c7a383b7c4471e58b3745e695
+SIZE (v8/9.3/clang-9d0a403e85d25b5b0d3016a342d4b83b12941fd5.tar.gz) = 289476
+SHA256 (v8/9.3/common-d5bb24e5d9802c8c917fcaa4375d5239a586c168.tar.gz) = 12f544af0133bc92760971357d8369b0caff91d0081297e1ca161ae4dc217633
+SIZE (v8/9.3/common-d5bb24e5d9802c8c917fcaa4375d5239a586c168.tar.gz) = 10408
+SHA256 (v8/9.3/googletest-4ec4cd23f486bf70efcc5d2caa40f24368f752e3.tar.gz) = cebe048b4144505ff2f656fabbac07c70422a682f4bdbf96c880011c58bcb8fe
+SIZE (v8/9.3/googletest-4ec4cd23f486bf70efcc5d2caa40f24368f752e3.tar.gz) = 886821
+SHA256 (v8/9.3/icu-b9dfc58bf9b02ea0365509244aca13841322feb0.tar.gz) = 03e15831ec4573894fd0677353a573902ed8ea5a97dfbafe7fc31ed3cea92ca7
+SIZE (v8/9.3/icu-b9dfc58bf9b02ea0365509244aca13841322feb0.tar.gz) = 43743513
+SHA256 (v8/9.3/zlib-dfbc590f5855bc2765256a743cad0abc56330a30.tar.gz) = 1797490cd58608bb24ac2b4fc2c30c76496aed25c018c6e849187575d392dfc4
+SIZE (v8/9.3/zlib-dfbc590f5855bc2765256a743cad0abc56330a30.tar.gz) = 311694
+SHA256 (v8/9.3/v8-v8-9.3.345.19_GH0.tar.gz) = ff17118d966f781742869fa8fbfb5c8429f38e44969aa677168daed54967f000
+SIZE (v8/9.3/v8-v8-9.3.345.19_GH0.tar.gz) = 26651059
diff --git a/lang/v8/files/patch-build_config_compiler_BUILD.gn b/lang/v8/files/patch-build_config_compiler_BUILD.gn
index 8075725e310d..48c46d0b0706 100644
--- a/lang/v8/files/patch-build_config_compiler_BUILD.gn
+++ b/lang/v8/files/patch-build_config_compiler_BUILD.gn
@@ -1,15 +1,15 @@
---- build/config/compiler/BUILD.gn.orig 2021-05-26 12:26:11 UTC
+--- build/config/compiler/BUILD.gn.orig 2021-09-19 10:01:13 UTC
+++ build/config/compiler/BUILD.gn
-@@ -133,7 +133,7 @@ declare_args() {
+@@ -139,7 +139,7 @@ declare_args() {
#
- # TODO(crbug.com/977230): Enabling this when 'use_xcode_clang' is true may
- # call an old clang that doesn't support auto-init.
-- init_stack_vars = !is_android && !use_xcode_clang
-+ init_stack_vars = !is_android && !use_xcode_clang && !is_bsd
+ # TODO(crbug.com/1131993): Enabling this when 'is_android' is true breaks
+ # content_shell_test_apk on both ARM and x86.
+- init_stack_vars = !is_android
++ init_stack_vars = !is_android && !is_bsd
# This argument is to control whether enabling text section splitting in the
# final binary. When enabled, the separated text sections with prefix
-@@ -333,7 +333,7 @@ config("compiler") {
+@@ -354,7 +354,7 @@ config("compiler") {
}
# Linker warnings.
@@ -18,16 +18,7 @@
ldflags += [ "-Wl,--fatal-warnings" ]
}
if (fatal_linker_warnings && is_apple) {
-@@ -428,7 +428,7 @@ config("compiler") {
-
- # Compiler instrumentation can introduce dependencies in DSOs to symbols in
- # the executable they are loaded into, so they are unresolved at link-time.
-- if (!using_sanitizer) {
-+ if (!using_sanitizer && !is_bsd) {
- ldflags += [
- "-Wl,-z,defs",
- "-Wl,--as-needed",
-@@ -518,7 +518,7 @@ config("compiler") {
+@@ -530,7 +530,7 @@ config("compiler") {
ldflags += [ "-Wl,-z,keep-text-section-prefix" ]
}
@@ -36,7 +27,7 @@
cflags += [ "-fcrash-diagnostics-dir=" + clang_diagnostic_dir ]
# TODO(hans): Remove this once Clang generates better optimized debug info
-@@ -851,7 +851,7 @@ config("compiler_cpu_abi") {
+@@ -867,7 +867,7 @@ config("compiler_cpu_abi") {
cflags += [ "-mtune=$arm_tune" ]
}
} else if (current_cpu == "arm64") {
@@ -45,7 +36,7 @@
cflags += [ "--target=aarch64-linux-gnu" ]
ldflags += [ "--target=aarch64-linux-gnu" ]
}
-@@ -1201,7 +1201,7 @@ config("compiler_deterministic") {
+@@ -1217,7 +1217,7 @@ config("compiler_deterministic") {
"-Xclang",
".",
]
@@ -54,7 +45,7 @@
# We don't use clang -cc1as on Windows (yet? https://crbug.com/762167)
asmflags = [ "-Wa,-fdebug-compilation-dir,." ]
}
-@@ -1584,7 +1584,7 @@ config("default_warnings") {
+@@ -1594,7 +1594,7 @@ config("default_warnings") {
cflags += [ "-Wno-nonportable-include-path" ]
}
@@ -63,16 +54,16 @@
# Flags NaCl (Clang 3.7) and Xcode 9.2 (Clang clang-900.0.39.2) do not
# recognize.
cflags += [
-@@ -1832,7 +1832,7 @@ config("export_dynamic") {
- config("thin_archive") {
- # The macOS and iOS default linker ld64 does not support reading thin
+@@ -1856,7 +1856,7 @@ config("thin_archive") {
# archives.
-- if ((is_posix && !is_nacl && (!is_apple || use_lld)) || is_fuchsia) {
-+ if ((is_posix && !is_nacl && (!is_apple || use_lld) && !is_bsd) || is_fuchsia) {
+ # TODO(crbug.com/1221615): Enable on is_apple if use_lld once that no longer
+ # confuses lldb.
+- if ((is_posix && !is_nacl && !is_apple) || is_fuchsia) {
++ if ((is_posix && !is_nacl && !is_apple && !is_bsd) || is_fuchsia) {
arflags = [ "-T" ]
} else if (is_win && use_lld) {
arflags = [ "/llvmlibthin" ]
-@@ -2373,7 +2373,7 @@ config("symbols") {
+@@ -2387,7 +2387,7 @@ config("symbols") {
# flag, so we can use use -g1 for pnacl and nacl-clang compiles.
# gcc nacl is is_nacl && !is_clang, pnacl and nacl-clang are && is_clang.
if (!is_nacl || is_clang) {
@@ -80,8 +71,8 @@
+ cflags += [ "-g0" ]
}
- # TODO(https://crbug.com/1050118): Investigate missing debug info on mac.
-@@ -2406,7 +2406,7 @@ config("symbols") {
+ if (is_apple) {
+@@ -2412,7 +2412,7 @@ config("symbols") {
# DWARF info may be corrupt; offsets in a range list entry are in different
# sections" there. Maybe just a bug in nacl_switch_32.S.
if (!is_apple && !is_nacl && current_cpu != "x86" &&
@@ -90,3 +81,12 @@
if (is_clang) {
# This flag enables the GNU-format pubnames and pubtypes sections,
# which lld needs in order to generate a correct GDB index.
+@@ -2425,7 +2425,7 @@ config("symbols") {
+ }
+
+ # TODO(https://crbug.com/1050118): Investigate missing debug info on mac.
+- if (is_clang && !is_nacl && !use_xcode_clang && !is_apple) {
++ if (is_clang && !is_nacl && !use_xcode_clang && !is_apple && !is_bsd) {
+ # Use constructor homing for debug info. This option reduces debug info
+ # by emitting class type info only when constructors are emitted.
+ cflags += [
diff --git a/lang/v8/files/patch-buildtools_third__party_libc++_BUILD.gn b/lang/v8/files/patch-buildtools_third__party_libc++_BUILD.gn
index 5de32dfc94cb..da2a4bc2e17a 100644
--- a/lang/v8/files/patch-buildtools_third__party_libc++_BUILD.gn
+++ b/lang/v8/files/patch-buildtools_third__party_libc++_BUILD.gn
@@ -1,11 +1,10 @@
---- buildtools/third_party/libc++/BUILD.gn.orig 2020-07-22 17:57:09 UTC
+--- buildtools/third_party/libc++/BUILD.gn.orig 2021-09-19 10:01:13 UTC
+++ buildtools/third_party/libc++/BUILD.gn
-@@ -14,7 +14,7 @@ config("config") {
- # its implementation.
- cflags += [ "-Wno-macro-redefined" ]
- } else {
-- cflags += [ "-fPIC" ]
-+ cflags += [ "-fPIC", "-I%%LOCALBASE%%/include" ]
+@@ -23,6 +23,7 @@ config("config") {
+ cflags += [
+ "-fPIC",
+ "-std=c++17",
++ "-I%%LOCALBASE%%/include",
+ ]
}
}
-