aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/spim/Makefile15
-rw-r--r--emulators/spim/distinfo4
-rw-r--r--emulators/spim/files/patch-aa22
-rw-r--r--emulators/spim/pkg-plist7
4 files changed, 23 insertions, 25 deletions
diff --git a/emulators/spim/Makefile b/emulators/spim/Makefile
index 3e1aa8f5d63f..8ac669a3b73b 100644
--- a/emulators/spim/Makefile
+++ b/emulators/spim/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= spim
-PORTVERSION= 6.5
+PORTVERSION= 7.0
CATEGORIES= emulators
MASTER_SITES= http://www.cs.wisc.edu/~larus/SPIM/
-DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= MIPS R2000 Simulator
@@ -24,11 +23,17 @@ MAKEFILE= Makefile.std
ALL_TARGET= spim xspim
MAN1= spim.1 xspim.1
+PORTDOCS= cycle.ps.gz
+PLIST_FILES= bin/spim bin/xspim %%DATADIR%%/exceptions.s
+PLIST_DIRS= %%DATADIR%%
+
+post-build:
+
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/spim
- ${INSTALL_DATA} ${WRKSRC}/Documentation/*.ps ${PREFIX}/share/doc/spim
- ${GZIP_CMD} ${PREFIX}/share/doc/spim/*.ps
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/cycle.ps ${DOCSDIR}
+ ${GZIP_CMD} ${DOCSDIR}/cycle.ps
.endif
.include <bsd.port.mk>
diff --git a/emulators/spim/distinfo b/emulators/spim/distinfo
index df5c41ec4455..c69ee3f9a7d3 100644
--- a/emulators/spim/distinfo
+++ b/emulators/spim/distinfo
@@ -1,2 +1,2 @@
-MD5 (spim.tar.gz) = be9cf6ff2798e507736d05eb5c70914f
-SIZE (spim.tar.gz) = 444075
+MD5 (spim-7.0.tar.gz) = b163deae4727e5db9d3f234bb89fa915
+SIZE (spim-7.0.tar.gz) = 305477
diff --git a/emulators/spim/files/patch-aa b/emulators/spim/files/patch-aa
index addb52150e1b..50dbcae0ee76 100644
--- a/emulators/spim/files/patch-aa
+++ b/emulators/spim/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.std.orig Mon Jan 15 05:55:16 2001
-+++ Makefile.std Tue Feb 27 21:16:12 2001
+--- Makefile.std.orig Mon Aug 23 00:58:00 2004
++++ Makefile.std Thu Dec 30 01:35:28 2004
@@ -46,21 +46,21 @@
@@ -13,9 +13,9 @@
+TOPDIR = ${X11BASE}
- # Full path for directory that will hold the trap handler file:
--TRAP_DIR = .
-+TRAP_DIR = ${PREFIX}/share/spim
+ # Full path for directory that will hold the exception handler file:
+-EXCEPTION_DIR = .
++EXCEPTION_DIR = ${PREFIX}/share/spim
# Full path for the directory that will hold the executable files:
-BIN_DIR = /usr/unsup/bin
@@ -26,10 +26,10 @@
+MAN_DIR = ${PREFIX}/man/man1
- # Full path for the trap handler file:
+ # Full path for the exception handler file:
@@ -93,8 +93,8 @@
- DEFINES = $(ENDIAN) $(MEM_SIZES) -DDEFAULT_TRAP_HANDLER=$(TRAP_PATH) -DSPIM_VERSION="\"`cat VERSION`\""
+ DEFINES = $(ENDIAN) $(MEM_SIZES) -DDEFAULT_EXCEPTION_HANDLER=$(EXCEPTION_PATH) -DSPIM_VERSION="\"`cat VERSION`\""
-CC = cc
-CFLAGS = $(DEFINES)
@@ -61,19 +61,19 @@
force: configuration
-@@ -200,11 +200,12 @@
+@@ -192,11 +192,12 @@
spim.tar.* spim.aux spim.log spim.dvi spim.shar*
install: spim xspim
- install -c -s spim $(BIN_DIR)
- install -c -s xspim $(BIN_DIR)
-- install -c -m 0444 trap.handler $(TRAP_DIR)
+- install -c -m 0444 exceptions.s $(EXCEPTION_DIR)
- install -c -m 0444 spim.man $(MAN_DIR)
- install -c -m 0444 xspim.man $(MAN_DIR)
-+ -mkdir -p $(BIN_DIR) $(TRAP_DIR) $(MAN_DIR)
++ -mkdir -p $(BIN_DIR) $(EXCEPTION_DIR) $(MAN_DIR)
+ ${BSD_INSTALL_PROGRAM} spim $(BIN_DIR)
+ ${BSD_INSTALL_PROGRAM} xspim $(BIN_DIR)
-+ ${BSD_INSTALL_DATA} trap.handler $(TRAP_DIR)
++ ${BSD_INSTALL_DATA} exceptions.s $(EXCEPTION_DIR)
+ ${BSD_INSTALL_MAN} spim.man $(MAN_DIR)/spim.1
+ ${BSD_INSTALL_MAN} xspim.man $(MAN_DIR)/xspim.1
diff --git a/emulators/spim/pkg-plist b/emulators/spim/pkg-plist
deleted file mode 100644
index 361c35233e3f..000000000000
--- a/emulators/spim/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/spim
-bin/xspim
-%%PORTDOCS%%share/doc/spim/spim.ps.gz
-%%PORTDOCS%%share/doc/spim/cycle.ps.gz
-share/spim/trap.handler
-@dirrm share/spim
-%%PORTDOCS%%@dirrm share/doc/spim