aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/mod_antiloris/Makefile6
-rw-r--r--www/mod_backtrace/Makefile9
-rw-r--r--www/mod_cfg_ldap/Makefile10
-rw-r--r--www/mod_whatkilledus/Makefile5
4 files changed, 14 insertions, 16 deletions
diff --git a/www/mod_antiloris/Makefile b/www/mod_antiloris/Makefile
index 5290c2642368..2016c7da53a4 100644
--- a/www/mod_antiloris/Makefile
+++ b/www/mod_antiloris/Makefile
@@ -10,6 +10,7 @@ MASTER_SITES= ftp://ftp.monshouwer.eu/pub/linux/mod_antiloris/
MAINTAINER= alex@vts.su.ac.rs
COMMENT= Protect Apache 2.x against the Slowloris HTTP DoS attack
+LICENSE= APACHE20
USE_BZIP2= yes
USE_APACHE= 22
@@ -27,11 +28,10 @@ PLIST_FILES+= ${APACHEETCDIR}/Includes/mod_antiloris.conf
SUB_FILES+= pkg-message.rules
.endif
-NO_STAGE= yes
post-install:
.if !defined(SKIP_RULES)
- @${INSTALL_DATA} ${WRKDIR}/mod_antiloris.conf ${PREFIX}/${APACHEETCDIR}/Includes/
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/Includes
+ @${INSTALL_DATA} ${WRKDIR}/mod_antiloris.conf ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/Includes
.endif
.include <bsd.port.mk>
diff --git a/www/mod_backtrace/Makefile b/www/mod_backtrace/Makefile
index 88abce05ed5f..4018b949b58b 100644
--- a/www/mod_backtrace/Makefile
+++ b/www/mod_backtrace/Makefile
@@ -14,7 +14,9 @@ EXTRACT_ONLY= # empty
MAINTAINER= fw@moov.de
COMMENT= Collects backtraces when a child process crashes
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+LICENSE= APACHE20
+
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
MANUAL_PACKAGE_BUILD= yes
@@ -27,7 +29,6 @@ SHORTMODNAME= backtrace
WRKSRC= ${WRKDIR}
-NO_STAGE= yes
pre-everything::
@${ECHO_MSG} "*********************** PLEASE NOTE! ***********************"
@${ECHO_MSG} "Apache httpd must be built with the --enable-exception-hook"
@@ -35,7 +36,7 @@ pre-everything::
@${ECHO_MSG} "*********************** PLEASE NOTE! ***********************"
do-extract:
- ${MKDIR} ${WRKSRC}/
- ${CP} ${DISTDIR}/${PORTNAME}.c ${WRKSRC}/
+ @${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${PORTNAME}.c ${WRKSRC}
.include <bsd.port.mk>
diff --git a/www/mod_cfg_ldap/Makefile b/www/mod_cfg_ldap/Makefile
index 608480403604..bcb4f01a34ec 100644
--- a/www/mod_cfg_ldap/Makefile
+++ b/www/mod_cfg_ldap/Makefile
@@ -11,6 +11,7 @@ DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows you to keep your virtual host configuration in a LDAP directory
+LICENSE= BSD3CLAUSE
USE_APACHE= 22+
USE_OPENLDAP= yes
@@ -25,13 +26,8 @@ AP_LIB+= ${LDAP_LIB}
PORTDOCS= AUTHORS cfg_ldap.conf ChangeLog COPYING INSTALL \
mod_cfg_ldap.schema README TODO
-NO_STAGE= yes
post-install:
-.if !defined (NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/mod_whatkilledus/Makefile b/www/mod_whatkilledus/Makefile
index b6d458011580..07dd8069a1e2 100644
--- a/www/mod_whatkilledus/Makefile
+++ b/www/mod_whatkilledus/Makefile
@@ -12,6 +12,8 @@ EXTRACT_ONLY= # empty
MAINTAINER= fw@moov.de
COMMENT= Logs a report when a child process crashes
+LICENSE= APACHE20
+
MANUAL_PACKAGE_BUILD= yes
USE_APACHE= 22
@@ -21,9 +23,8 @@ SHORTMODNAME= whatkilledus
WRKSRC= ${WRKDIR}
-NO_STAGE= yes
do-extract:
- ${MKDIR} ${WRKSRC}
+ @${MKDIR} ${WRKSRC}
${CP} ${DISTDIR}/mod_whatkilledus.c ${WRKSRC}
${CP} ${DISTDIR}/test_char.h ${WRKSRC}