aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/py-metar/Makefile12
-rw-r--r--astro/py-metar/distinfo4
-rw-r--r--astro/py-metar/files/patch-setup.py11
3 files changed, 14 insertions, 13 deletions
diff --git a/astro/py-metar/Makefile b/astro/py-metar/Makefile
index ce97b284adb8..3b6f38eabcb5 100644
--- a/astro/py-metar/Makefile
+++ b/astro/py-metar/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= metar
-PORTVERSION= 0.19
-PORTREVISION= 2
+PORTVERSION= 0.20
CATEGORIES= astro python geography
MASTER_SITES= http://www.schwarzvogel.de/pkgs/ \
LOCAL/sunpoet
@@ -15,19 +14,10 @@ COMMENT= Python module that provides access to NOAA METAR weather reports
LICENSE= GPLv2
-OPTIONS_DEFINE= DOCS
-OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}/options
-
USE_PYTHON= autoplist distutils
USES= python:2 shebangfix
-PORTDOCS= COPYING README THANKS librarydoc.txt
-
SHEBANG_FILES= bin/py${PORTNAME}
python_CMD= ${PYTHON_CMD}
-post-patch:
- @${REINPLACE_CMD} -e 's|share/\(man/man1\)|\1|' \
- -e 's|"share/doc/pymetar-%s"%pymetar.__version__|"${DOCSDIR}"|' ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/astro/py-metar/distinfo b/astro/py-metar/distinfo
index 958c4568fe23..ce7c3068e103 100644
--- a/astro/py-metar/distinfo
+++ b/astro/py-metar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pymetar-0.19.tar.gz) = 2666c9bcb171bcc5cd6c174073a280836f049fbbd9c264ea24a2a023edb647c9
-SIZE (pymetar-0.19.tar.gz) = 22123
+SHA256 (pymetar-0.20.tar.gz) = bcbf3b08558a92c38553fb3b07bfd87b552e1270b8e37b08b3e6b262487abee7
+SIZE (pymetar-0.20.tar.gz) = 22738
diff --git a/astro/py-metar/files/patch-setup.py b/astro/py-metar/files/patch-setup.py
new file mode 100644
index 000000000000..4bbc4f22030c
--- /dev/null
+++ b/astro/py-metar/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2015-04-20 08:17:26 UTC
++++ setup.py
+@@ -26,7 +26,5 @@ setup(name="pymetar", version=pymetar.__
+ packages=[""],
+ py_modules=["pymetar"],
+ scripts=["bin/pymetar"],
+- data_files=[("share/doc/pymetar-%s" % pymetar.__version__,
+- ['README', 'COPYING', 'THANKS', 'librarydoc.txt']),
+- ("share/man/man1", ['pymetar.1'])]
++ data_files=[("man/man1", ['pymetar.1'])]
+ )