aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/cfitsio/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 15972fbdf882..a14921a55095 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cfitsio
PORTVERSION= 3.360
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro
MASTER_SITES= http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/ \
http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/oldvers/ \
@@ -24,9 +24,9 @@ OPTIONS_DEFINE= DOCS
ALL_TARGET= libcfitsio.a shared
CFLAGS+= -I${INCLUDEDIR}
CONFIGURE_ARGS= ac_cv_prog_FC=f2c
+CONFIGURE_ENV= LIBS="-L${LIBDIR} -lz"
GNU_CONFIGURE= yes
MAKE_ARGS= ZLIB_SOURCES="zlib/zcompress.c zlib/zuncompress.c"
-LDFLAGS+= -L${LIBDIR} -lz
USE_LDCONFIG= yes
USES= pkgconfig
WRKSRC= ${WRKDIR}/${PORTNAME}