aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/xastir/Makefile4
-rw-r--r--graphics/cimg/Makefile4
-rw-r--r--graphics/darktable/Makefile3
-rw-r--r--graphics/gimp-gmic-plugin/Makefile3
-rw-r--r--math/octave/Makefile6
-rw-r--r--science/gnudatalanguage/Makefile4
6 files changed, 13 insertions, 11 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 829130e04715..1881f54e0707 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xastir
PORTVERSION= 2.0.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTNAME}-${PORTVERSION}
@@ -48,7 +48,7 @@ CONFIGURE_ARGS+= --without-shapelib
.endif
.if ${PORT_OPTIONS:MMAGICK}
-LIB_DEPENDS+= libGraphicsMagickWand.so:${PORTSDIR}/graphics/GraphicsMagick13
+LIB_DEPENDS+= libGraphicsMagickWand.so:${PORTSDIR}/graphics/GraphicsMagick
.else
CONFIGURE_ARGS+= --without-imagemagick --without-graphicsmagick
.endif
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 09ff95a8ebe4..a5b23df1456e 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cimg
PORTVERSION= 1.5.8
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
@@ -47,7 +47,7 @@ LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libopencv_legacy.so:${PORTSDIR}/graphics/opencv \
libopencv_core.so:${PORTSDIR}/graphics/opencv-core\
- libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick13
+ libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick
ALL_TARGET= Mlinux
. else
ALL_TARGET= dlinux
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 684268faefef..d166c4e26356 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -3,6 +3,7 @@
PORTNAME= darktable
PORTVERSION= 1.4.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
@@ -63,7 +64,7 @@ GNOMEKEYRING_CMAKE_OFF= -DUSE_GNOME_KEYRING:BOOL=OFF
GPHOTO_LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
GPHOTO_CMAKE_OFF= -DUSE_CAMERA_SUPPORT:BOOL=OFF
-GRAPHMAGICK_LIB_DEPENDS=libGraphicsMagick.so:${PORTSDIR}/graphics/GraphicsMagick13
+GRAPHMAGICK_LIB_DEPENDS=libGraphicsMagick.so:${PORTSDIR}/graphics/GraphicsMagick
GRAPHMAGICK_CMAKE_OFF= -DUSE_GRAPHICSMAGICK:BOOL=OFF
LUA_USES= lua
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index 8422c661c753..c6f406a94bc8 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gmic
PORTVERSION= 1.5.9.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/older_versions/ \
SF/${PORTNAME}/
@@ -12,7 +13,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= rm@FreeBSD.org
COMMENT= GREYC's Magic Image Converter
-LIB_DEPENDS= libGraphicsMagick++.so:${PORTSDIR}/graphics/GraphicsMagick13 \
+LIB_DEPENDS= libGraphicsMagick++.so:${PORTSDIR}/graphics/GraphicsMagick \
libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libMagick++.so:${PORTSDIR}/graphics/ImageMagick \
libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
diff --git a/math/octave/Makefile b/math/octave/Makefile
index a529759007cf..bae8e7cae128 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave
PORTVERSION= 3.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= octave
@@ -20,7 +20,7 @@ BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
gsed:${PORTSDIR}/textproc/gsed \
${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
-LIB_DEPENDS= libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick13 \
+LIB_DEPENDS= libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick \
libarpack.so:${PORTSDIR}/math/arpack \
libcurl.so:${PORTSDIR}/ftp/curl \
libfftw3.so:${PORTSDIR}/math/fftw3 \
@@ -34,7 +34,7 @@ LIB_DEPENDS= libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick13 \
libumfpack.so:${PORTSDIR}/math/suitesparse \
libglpk.so:${PORTSDIR}/math/glpk \
libgl2ps.so:${PORTSDIR}/print/gl2ps \
- qscintilla2:${PORTSDIR}/devel/qscintilla2
+ libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
USES= charsetfix fortran gmake libtool perl5 pkgconfig tar:bzip2
USE_PERL5= build
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index ea67e9859bef..cc4b86e37c3c 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnudatalanguage
DISTVERSION= 0.9.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science lang
MASTER_SITES= SF/${PORTNAME}/gdl/${DISTVERSION}
.if defined(BUILD_PYTHON_MODULE)
@@ -63,7 +63,7 @@ PLIST_SUB+= MASTER=""
.endif
.if !defined(WITHOUT_GRAPHICSMAGICK)
-LIB_DEPENDS+= libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick13
+LIB_DEPENDS+= libGraphicsMagick.so.14:${PORTSDIR}/graphics/GraphicsMagick
CMAKE_ARGS+= -DGRAPHICSMAGICK:BOOL=YES
.else
CMAKE_ARGS+= -DGRAPHICSMAGICK:BOOL=NO