aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/corebird/Makefile3
-rw-r--r--net-im/kopete-kde4/Makefile3
-rw-r--r--net-im/telepathy-gabble/Makefile3
-rw-r--r--net-im/telepathy-logger/Makefile3
-rw-r--r--net-im/telepathy-salut/Makefile3
-rw-r--r--net-mgmt/pmacct/Makefile2
-rw-r--r--net-mgmt/rackmonkey/Makefile4
-rw-r--r--net/asterisk11/Makefile3
-rw-r--r--net/asterisk13/Makefile3
-rw-r--r--net/freeradius2/Makefile2
-rw-r--r--net/freeradius3/Makefile2
-rw-r--r--net/kget/Makefile3
-rw-r--r--net/liferea/Makefile3
-rw-r--r--net/ntopng/Makefile3
-rw-r--r--net/prosearch/Makefile2
-rw-r--r--net/quiterss/Makefile3
-rw-r--r--net/turnserver/Makefile2
-rw-r--r--security/softhsm2/Makefile3
-rw-r--r--sysutils/bulk_extractor/Makefile2
-rw-r--r--sysutils/fusefs-sqlfs/Makefile7
-rw-r--r--sysutils/lnav/Makefile3
-rw-r--r--sysutils/tracker/Makefile4
-rw-r--r--sysutils/zeitgeist/Makefile3
-rw-r--r--textproc/soothsayer/Makefile3
24 files changed, 27 insertions, 45 deletions
diff --git a/net-im/corebird/Makefile b/net-im/corebird/Makefile
index c6cc85acfaf7..685eca3eb3bc 100644
--- a/net-im/corebird/Makefile
+++ b/net-im/corebird/Makefile
@@ -20,10 +20,9 @@ LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
USE_GITHUB= yes
GH_ACCOUNT= baedert
-USES= autoreconf gettext gmake libtool pkgconfig
+USES= autoreconf gettext gmake libtool pkgconfig sqlite
GNU_CONFIGURE= yes
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 intltool libxml2 pango
-USE_SQLITE= yes
INSTALLS_ICONS= yes
OPTIONS_DEFINE= GSTREAMER
diff --git a/net-im/kopete-kde4/Makefile b/net-im/kopete-kde4/Makefile
index 03305300ec0e..ca640b1b3247 100644
--- a/net-im/kopete-kde4/Makefile
+++ b/net-im/kopete-kde4/Makefile
@@ -20,13 +20,12 @@ LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
libjasper.so:${PORTSDIR}/graphics/jasper
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
-USES= cmake:outsource jpeg pkgconfig shebangfix tar:xz webplugin:native
+USES= cmake:outsource jpeg pkgconfig shebangfix sqlite tar:xz webplugin:native
USE_GNOME= libxml2 libxslt
USE_KDE4= kdelibs kdeprefix pimlibs \
automoc4 qimageblitz
USE_QT4= corelib gui network qt3support sql xml \
moc_build qmake_build rcc_build uic_build uic3_build
-USE_SQLITE= yes
USE_XORG= x11 xdamage xext xscrnsaver xtst
USE_LDCONFIG= yes
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index aef4fc4c6b3a..1901dc6b0887 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -23,9 +23,8 @@ RUN_DEPENDS= ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss \
PORTSCOUT= limitw:1,even
-USES= alias gmake libtool pathfix pkgconfig python:build
+USES= alias gmake libtool pathfix pkgconfig python:build sqlite
USE_GNOME= glib20 gtksourceview3 libxslt:build
-USE_SQLITE= 3
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
diff --git a/net-im/telepathy-logger/Makefile b/net-im/telepathy-logger/Makefile
index 22f3da7698a6..1fb07c28aad2 100644
--- a/net-im/telepathy-logger/Makefile
+++ b/net-im/telepathy-logger/Makefile
@@ -16,12 +16,11 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib
USES= gettext-tools gmake libtool pathfix pkgconfig python:build \
- tar:bzip2
+ sqlite tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= glib20 gnomedocutils intltool libxml2 \
libxslt:build introspection:build
-USE_SQLITE= yes
GLIB_SCHEMAS= org.freedesktop.Telepathy.Logger.gschema.xml
INSTALL_TARGET= install-strip
diff --git a/net-im/telepathy-salut/Makefile b/net-im/telepathy-salut/Makefile
index 07b29bad014a..3d3d7a1d5478 100644
--- a/net-im/telepathy-salut/Makefile
+++ b/net-im/telepathy-salut/Makefile
@@ -16,10 +16,9 @@ LIB_DEPENDS= libavahi-glib.so:${PORTSDIR}/net/avahi-app \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig python:build
+USES= gmake libtool pathfix pkgconfig python:build sqlite
USE_GNOME= glib20 libxslt:build
USE_OPENSSL= yes
-USE_SQLITE= 3
CONFIGURE_ARGS= --disable-Werror --enable-avahi-tests=no
LDFLAGS+= -lpthread
INSTALL_TARGET= install-strip
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index 992b6c113208..4b61b5b49b26 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -51,7 +51,7 @@ PLIST_SUB+= WITH_PGSQL="@comment "
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
CONFIGURE_ARGS+=--enable-sqlite3 \
--with-sqlite3-includes=${LOCALBASE}/include
.else
diff --git a/net-mgmt/rackmonkey/Makefile b/net-mgmt/rackmonkey/Makefile
index 637bbac05db2..a155275a1e89 100644
--- a/net-mgmt/rackmonkey/Makefile
+++ b/net-mgmt/rackmonkey/Makefile
@@ -34,7 +34,7 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
.if ${PORT_OPTIONS:MMYSQL}
@@ -65,7 +65,7 @@ do-install:
cd ${WRKSRC}/perl && ${COPYTREE_SHARE} RackMonkey ${STAGEDIR}${WWWDIR}/
${MKDIR} ${WRKDIR}/build_conf; \
${CP} ${WRKSRC}/conf/rackmonkey.conf-default ${WRKDIR}/build_conf/rackmonkey.conf; \
- if [ "${USE_SQLITE}" ]; then \
+ if [ "${USES:MSQLITE}" ]; then \
${ECHO} "Building with SQLite............."; \
${SED} -i '' -e 's%dbconnect =%dbconnect = dbi:SQLite:dbname=${WWWDIR}/rackmonkey.db%' ${WRKDIR}/build_conf/rackmonkey.conf; \
if [ "${INIT_DB}" ]; then \
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index 2f1e2ea1d833..34a96045b68b 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -21,12 +21,11 @@ EXTRACT_ONLY:= ${DISTNAME}${EXTRACT_SUFX}
ONLY_FOR_ARCHS= i386 amd64 powerpc sparc64
-USES= bison cpe gmake iconv localbase ncurses shebangfix
+USES= bison cpe gmake iconv localbase ncurses shebangfix sqlite
USE_CSTD= gnu89
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USE_SQLITE= 3
USE_RC_SUBR= asterisk
GNU_CONFIGURE= yes
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index 36159370cab0..a8513ecb9514 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -24,12 +24,11 @@ EXTRACT_ONLY:= ${DISTNAME}${EXTRACT_SUFX}
ONLY_FOR_ARCHS= i386 amd64 powerpc sparc64
-USES= bison cpe gmake iconv localbase ncurses shebangfix
+USES= bison cpe gmake iconv localbase ncurses shebangfix sqlite
USE_CSTD= gnu89
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USE_SQLITE= 3
USE_RC_SUBR= asterisk
GNU_CONFIGURE= yes
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index f025fe0dbf0f..7cfc9dc45848 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -177,7 +177,7 @@ PLIST_SUB+= UNIXODBC="@comment "
.endif
.if ${PORT_OPTIONS:MFIREBIRD}
-USE_FIREBIRD= YES
+USES+= firebird
CONFIGURE_ARGS+=--with-rlm_sql_firebird
PLIST_SUB+= FIREBIRD=""
.else
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index 61114a9db6a8..45ecb5f8512d 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -154,7 +154,7 @@ PLIST_SUB+= UNIXODBC="@comment "
.endif
.if ${PORT_OPTIONS:MFIREBIRD}
-USE_FIREBIRD= YES
+USES+= firebird
CONFIGURE_ARGS+=--with-rlm_sql_firebird
PLIST_SUB+= FIREBIRD=""
.else
diff --git a/net/kget/Makefile b/net/kget/Makefile
index ef8100dcb017..0ea2a148a3eb 100644
--- a/net/kget/Makefile
+++ b/net/kget/Makefile
@@ -16,11 +16,10 @@ LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
libqca.so:${PORTSDIR}/devel/qca \
libboost_thread.so:${PORTSDIR}/devel/boost-libs
-USE_SQLITE= yes
USE_KDE4= kdelibs kdeprefix workspace libkonq \
nepomuk-core nepomuk-widgets automoc4 ontologies \
soprano
-USES= cmake:outsource shebangfix tar:xz
+USES= cmake:outsource shebangfix sqlite tar:xz
SHEBANG_FILES= conf/*.pl
USE_QT4= gui sql moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 947faa2d34a0..1e552dfaf372 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -19,10 +19,9 @@ RUN_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-sc
${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py-libpeas
USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- python:2 tar:bzip2
+ python:2 sqlite tar:bzip2
USE_GNOME= dconf:run gtk30 intltool introspection:build \
libxslt:build libxml2
-USE_SQLITE= 3
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index 12c463c9cb6f..b200b684a61d 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -21,10 +21,9 @@ LIB_DEPENDS= librrd.so:${PORTSDIR}/databases/rrdtool \
libzmq.so:${PORTSDIR}/net/libzmq4
GNU_CONFIGURE= yes
-USE_SQLITE= yes
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES= autoreconf cpe gmake libtool pathfix pkgconfig tar:tgz
+USES= autoreconf cpe gmake libtool pathfix pkgconfig sqlite tar:tgz
SUB_FILES= ntopng-geoipupdate.sh
CPE_VENDOR= ntop
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index 7697850c0994..23da4d5d2c57 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -129,7 +129,7 @@ WANT_PGSQL= client server
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
RUN_DEPENDS+=\
p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
diff --git a/net/quiterss/Makefile b/net/quiterss/Makefile
index 0962837f1512..de8c9835065b 100644
--- a/net/quiterss/Makefile
+++ b/net/quiterss/Makefile
@@ -15,8 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
NO_WRKSUBDIR= yes
-USES= desktop-file-utils pkgconfig qmake:outsource
-USE_SQLITE= yes
+USES= desktop-file-utils pkgconfig qmake:outsource sqlite
INSTALLS_ICONS= yes
OPTIONS_DEFINE= DEBUG
diff --git a/net/turnserver/Makefile b/net/turnserver/Makefile
index ab4bc1f7bfbd..df4bb07b269e 100644
--- a/net/turnserver/Makefile
+++ b/net/turnserver/Makefile
@@ -94,7 +94,7 @@ CONFIGURE_ENG+= TURN_NO_MONGO=1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
.else
CONFIGURE_ENV+= TURN_NO_SQLITE=1
.endif
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index 44dba46911c7..608b5fa5e66b 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -18,12 +18,11 @@ LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sqlite3=${LOCALBASE} --localstatedir="${PREFIX}/var"
INSTALL_TARGET= install-strip
-USES= libtool
+USES= libtool sqlite
CONFLICTS= softhsm-1.*
USE_LDCONFIG= yes
-USE_SQLITE= yes
OPTIONS_SINGLE= CRYP
OPTIONS_SINGLE_CRYP= CRYP_OPEN CRYP_BOTAN
diff --git a/sysutils/bulk_extractor/Makefile b/sysutils/bulk_extractor/Makefile
index 8bf24d031763..6ad459a8fb47 100644
--- a/sysutils/bulk_extractor/Makefile
+++ b/sysutils/bulk_extractor/Makefile
@@ -12,13 +12,13 @@ COMMENT= Program that scans a disk image and extracts useful information
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= sqlite
LIB_DEPENDS= libafflib.so:${PORTSDIR}/sysutils/afflib \
libewf.so:${PORTSDIR}/devel/libewf \
libexiv2.so:${PORTSDIR}/graphics/exiv2 \
libexpat.so:${PORTSDIR}/textproc/expat2
USE_OPENSSL= yes
-USE_SQLITE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-exiv2=true
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/fusefs-sqlfs/Makefile b/sysutils/fusefs-sqlfs/Makefile
index 7d81ffbaa947..b8d51707a0e7 100644
--- a/sysutils/fusefs-sqlfs/Makefile
+++ b/sysutils/fusefs-sqlfs/Makefile
@@ -13,8 +13,7 @@ DISTNAME= lib${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= SQLite backed FUSE file system
-USES= fuse
-USE_SQLITE= 3
+USES= fuse sqlite
OPTIONS_DEFINE= DOCS
@@ -22,8 +21,6 @@ PORTDOCS= README
PLIST_FILES= bin/sqlfs
-.include <bsd.port.pre.mk>
-
do-build:
(cd ${WRKSRC} && ${CC} -DFUSE -DFUSE_USE_VERSION=25 \
-D_FILE_OFFSET_BITS=64 -D_REENTRANT ${CFLAGS} \
@@ -37,4 +34,4 @@ do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/lnav/Makefile b/sysutils/lnav/Makefile
index f6f151da8329..bf6143a5133e 100644
--- a/sysutils/lnav/Makefile
+++ b/sysutils/lnav/Makefile
@@ -17,8 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= tstack
GNU_CONFIGURE= yes
-USES= autoreconf execinfo ncurses python readline
-USE_SQLITE= 3
+USES= autoreconf execinfo ncurses python readline sqlite
PLIST_FILES= bin/lnav man/man1/lnav.1.gz
diff --git a/sysutils/tracker/Makefile b/sysutils/tracker/Makefile
index 7b4c3588e437..4b5c5cc3729d 100644
--- a/sysutils/tracker/Makefile
+++ b/sysutils/tracker/Makefile
@@ -25,10 +25,10 @@ RUN_DEPENDS= xdg-desktop-icon:${PORTSDIR}/devel/xdg-utils \
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig tar:xz
+USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
+ sqlite tar:xz
USE_GNOME= gtk30 intltool introspection:build libxslt:build
USE_LDCONFIG= yes
-USE_SQLITE= 3
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/sysutils/zeitgeist/Makefile b/sysutils/zeitgeist/Makefile
index cc71283805c1..d585d97360ce 100644
--- a/sysutils/zeitgeist/Makefile
+++ b/sysutils/zeitgeist/Makefile
@@ -22,8 +22,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
USE_GNOME= intlhack glib20 introspection:build
GNU_CONFIGURE= yes
-USES= gmake gettext pathfix python:2 pkgconfig libtool tar:xz
-USE_SQLITE= 3
+USES= gmake gettext pathfix python:2 pkgconfig libtool sqlite tar:xz
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
diff --git a/textproc/soothsayer/Makefile b/textproc/soothsayer/Makefile
index 237bd65901a9..b003dc2bad01 100644
--- a/textproc/soothsayer/Makefile
+++ b/textproc/soothsayer/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
-USES= libtool pkgconfig
-USE_SQLITE= 3
+USES= libtool pkgconfig sqlite
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_CPPUNIT_CONFIG=no \
ac_cv_path_PYTHON=no \