aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/axel/Makefile3
-rw-r--r--ftp/oftpd/Makefile3
-rw-r--r--ftp/pavuk/Makefile4
-rw-r--r--ftp/pftpd/Makefile4
-rw-r--r--ftp/quftp/Makefile9
-rw-r--r--net-im/freetalk/Makefile2
-rw-r--r--net-im/libpurple/Makefile5
-rw-r--r--net-im/licq/Makefile2
-rw-r--r--net-im/pidgin-skype/Makefile4
-rw-r--r--net-im/telepathy-salut/Makefile3
-rw-r--r--net-mgmt/aircrack-ng/Makefile3
-rw-r--r--net-mgmt/driftnet/Makefile2
-rw-r--r--net-mgmt/driftnet/files/patch-Makefile13
-rw-r--r--net-mgmt/fprobe/Makefile3
-rw-r--r--net-mgmt/iftop/Makefile4
-rw-r--r--net-mgmt/ipcad/Makefile4
-rw-r--r--www/epiphany/Makefile5
-rw-r--r--www/nginx-devel/Makefile3
-rw-r--r--www/nginx/Makefile3
-rw-r--r--www/rubygem-passenger/Makefile3
20 files changed, 21 insertions, 61 deletions
diff --git a/ftp/axel/Makefile b/ftp/axel/Makefile
index 22eed1c87638..975156099670 100644
--- a/ftp/axel/Makefile
+++ b/ftp/axel/Makefile
@@ -25,7 +25,6 @@ NLS_CONFIGURE_OFF= --i18n=0
DEBUG_CONFIGURE_ON=--debug=1 --strip=0
post-configure:
- @${REINPLACE_CMD} -e 's|gcc|${CC}|; \
- s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.settings
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile.settings
.include <bsd.port.mk>
diff --git a/ftp/oftpd/Makefile b/ftp/oftpd/Makefile
index 47cf112d3757..482f97636e70 100644
--- a/ftp/oftpd/Makefile
+++ b/ftp/oftpd/Makefile
@@ -20,8 +20,7 @@ PLIST_FILES= sbin/oftpd man/man8/oftpd.8.gz
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g ; \
- s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|-D_THREAD_SAFE||g' ${WRKSRC}/configure
.if defined(MAX_NUM_CLIENTS)
${REINPLACE_CMD} -e 's|MAX_NUM_CLIENTS 300|MAX_NUM_CLIENTS ${MAX_NUM_CLIENTS}|g' ${WRKSRC}/src/oftpd.h
.endif
diff --git a/ftp/pavuk/Makefile b/ftp/pavuk/Makefile
index d3a5fa257bb1..5def0392b48e 100644
--- a/ftp/pavuk/Makefile
+++ b/ftp/pavuk/Makefile
@@ -39,10 +39,6 @@ DANTE_CONFIGURE_ON= --with-socks-includes=${LOCALBASE}/include \
DANTE_LIB_DEPENDS= libsocks.so:${PORTSDIR}/net/dante
pre-patch:
- @${REINPLACE_CMD} -e \
- 's|-pthread -DHAVE_MT|${PTHREAD_CFLAGS} -DHAVE_MT|g ; \
- s|-pthread|${PTHREAD_LIBS}|g ; \
- s|-lpthreads|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|$$(datadir)/icons|$$(pkgdatadir)/icons|g'
diff --git a/ftp/pftpd/Makefile b/ftp/pftpd/Makefile
index 5d31552ffa59..e2ae38fcb9d3 100644
--- a/ftp/pftpd/Makefile
+++ b/ftp/pftpd/Makefile
@@ -16,10 +16,6 @@ PLIST_FILES= sbin/pftpd \
man/man1/pftpd.1.gz \
man/man1/rpad.1.gz
-post-patch:
- @${FIND} ${WRKSRC} -name "configure" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g'
-
do-install:
(cd ${WRKSRC}/src && ${INSTALL_PROGRAM} pftpd ${STAGEDIR}${PREFIX}/sbin)
(cd ${WRKSRC}/doc && ${INSTALL_MAN} *.1 ${STAGEDIR}${MANPREFIX}/man/man1)
diff --git a/ftp/quftp/Makefile b/ftp/quftp/Makefile
index e0479c6a5733..897d54fd674c 100644
--- a/ftp/quftp/Makefile
+++ b/ftp/quftp/Makefile
@@ -15,17 +15,14 @@ LICENSE= GPLv2
USES= ncurses readline
GNU_CONFIGURE= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-
+LDFLAGS+= -lpthread
PLIST_FILES= bin/quftp man/man1/quftp.1.gz
post-patch:
- @${REINPLACE_CMD} -e \
- '/^CFLAGS/s|+=.*|= ${CFLAGS} ${CPPFLAGS}|' \
+ @${REINPLACE_CMD} -e '/^CFLAGS/s|+=.*|= ${CFLAGS} ${CPPFLAGS}|' \
${WRKSRC}/Makefile.in
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/quftp
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/quftp
.include <bsd.port.mk>
diff --git a/net-im/freetalk/Makefile b/net-im/freetalk/Makefile
index 4a2c30e423f0..e709aac5f1f7 100644
--- a/net-im/freetalk/Makefile
+++ b/net-im/freetalk/Makefile
@@ -21,7 +21,7 @@ USES= pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -lpthread -L${LOCALBASE}/lib
OPTIONS_SUB= yes
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 56d7a46343d5..2def4cb4c144 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -317,9 +317,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} \
- -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g' \
- -e 's|-lsilc -lsilcclient ${PTHREAD_LIBS} $$LIBDL|-lsilc -lsilcclient ${PTHREAD_LIBS} ${ICONV_LIB}|' \
- ${WRKSRC}/configure
+ -e 's|-lpthread $$LIBDL|-lpthread ${ICONV_LIB}|' \
+ ${WRKSRC}/configure
.if defined(PIDGIN_SLAVE)
@${FIND} ${BUILD_WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|$$(top_builddir)/libpurple/libpurple.la|-lpurple|'
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 646cf55bc987..4dba02d02883 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -18,7 +18,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
LICQ_PORT?= net-im/licq
# workaround for installed autoconf/automake
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib ${ICONV_LIB} -Wl,--export-dynamic
+LDFLAGS+= -lpthread -L${LOCALBASE}/lib ${ICONV_LIB} -Wl,--export-dynamic
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -Wl,--export-dynamic -DGTEST_USE_OWN_TR1_TUPLE
diff --git a/net-im/pidgin-skype/Makefile b/net-im/pidgin-skype/Makefile
index acc5d471d1bb..0d65c0da5b36 100644
--- a/net-im/pidgin-skype/Makefile
+++ b/net-im/pidgin-skype/Makefile
@@ -33,14 +33,14 @@ ${DISTFILES}:
upload-tarball: build-tarball
scp ${DISTFILES} freefall.freebsd.org:public_distfiles/
-mycflags= -shared -fPIC -DPIC ${PTHREAD_CFLAGS} \
+mycflags= -shared -fPIC -DPIC \
-I${LOCALBASE}/include \
-I${LOCALBASE}/include/libpurple \
-I${LOCALBASE}/include/pidgin \
-I${LOCALBASE}/include/glib-2.0 \
-I${LOCALBASE}/lib/glib-2.0/include \
-DPURPLE_PLUGINS
-mylibs= ${PTHREAD_LIBS}
+mylibs= -lpthread
# DBUS: No DBUS here, does not work with Skype 2.1 beta
# NLS: While the build works and enables translations,
diff --git a/net-im/telepathy-salut/Makefile b/net-im/telepathy-salut/Makefile
index 96b960acb5c6..07b29bad014a 100644
--- a/net-im/telepathy-salut/Makefile
+++ b/net-im/telepathy-salut/Makefile
@@ -21,8 +21,7 @@ USE_GNOME= glib20 libxslt:build
USE_OPENSSL= yes
USE_SQLITE= 3
CONFIGURE_ARGS= --disable-Werror --enable-avahi-tests=no
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
+LDFLAGS+= -lpthread
INSTALL_TARGET= install-strip
PLIST_SUB+= VERSION=${PORTVERSION}
diff --git a/net-mgmt/aircrack-ng/Makefile b/net-mgmt/aircrack-ng/Makefile
index ed42b9e97b6d..20f2ab73c49d 100644
--- a/net-mgmt/aircrack-ng/Makefile
+++ b/net-mgmt/aircrack-ng/Makefile
@@ -50,9 +50,6 @@ post-patch:
@${REINPLACE_CMD} \
-E 's/air(driver|mon)-ng\.1 //' \
${WRKSRC}/manpages/Makefile
- @${REINPLACE_CMD} \
- -e 's|-lpthread|${PTHREAD_LIBS}|' \
- ${WRKSRC}/src/Makefile
post-install:
@${STRIP_CMD} ${BIN_FILES:S,^,${STAGEDIR}${PREFIX}/bin/,} \
diff --git a/net-mgmt/driftnet/Makefile b/net-mgmt/driftnet/Makefile
index 9faf47d3aaa8..0ed4c5fe39c5 100644
--- a/net-mgmt/driftnet/Makefile
+++ b/net-mgmt/driftnet/Makefile
@@ -22,8 +22,6 @@ USE_GNOME= gtk12
USES= gmake
ALL_TARGET= default
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
-
PLIST_FILES= bin/driftnet man/man1/driftnet.1.gz
do-install:
diff --git a/net-mgmt/driftnet/files/patch-Makefile b/net-mgmt/driftnet/files/patch-Makefile
index fefd985d3e20..bdcae0ef83e4 100644
--- a/net-mgmt/driftnet/files/patch-Makefile
+++ b/net-mgmt/driftnet/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Jul 9 12:26:41 2002
-+++ Makefile Sat Sep 28 22:19:21 2002
+--- Makefile.orig 2002-07-09 19:26:41 UTC
++++ Makefile
@@ -16,23 +16,23 @@
#CC = gcc
@@ -19,19 +19,18 @@
+#CFLAGS += -D_BSD_SOURCE
# We always need the pcap and pthread libraries.
--LDLIBS += -lpcap -lpthread
-+LDLIBS += -lpcap ${PTHREAD_LIBS}
+ LDLIBS += -lpcap -lpthread
# Optional C compiler and linker flags. Typical driftnet builds have support
# for displaying captured images in an X window, and need the following flags:
-CFLAGS += `gtk-config --cflags`
-LDLIBS += -ljpeg -lungif `gtk-config --libs`
-+CFLAGS += ${PTHREAD_CFLAGS} `${GTK_CONFIG} --cflags`
++CFLAGS += `${GTK_CONFIG} --cflags`
+LDLIBS += -ljpeg -lgif `${GTK_CONFIG} --libs`
# Alternatively, you can build a version of driftnet which can only be used
# in `adjunct' mode as the back end for some other image-processing program. To
-@@ -43,7 +43,7 @@
+@@ -43,7 +43,7 @@ LDLIBS += -ljpeg -lungif `gtk-config --
# On systems with a C99 compiler, driftnet will use <stdint.h> for the
# definitions of types such as uint8_t. On other systems like Solaris, these
# are in <sys/types.h>, and you should uncomment this line.
@@ -40,7 +39,7 @@
# On Solaris, it is necessary to link against -lposix4 for the definition of
# nanosleep; uncomment the below.
-@@ -51,7 +51,7 @@
+@@ -51,7 +51,7 @@ LDLIBS += -ljpeg -lungif `gtk-config --
# added 20020604 edobbs
# On BSD systems, may need to use /usr/local/include
diff --git a/net-mgmt/fprobe/Makefile b/net-mgmt/fprobe/Makefile
index 39680b3a67a4..b8c5dc20f78d 100644
--- a/net-mgmt/fprobe/Makefile
+++ b/net-mgmt/fprobe/Makefile
@@ -19,9 +19,6 @@ PORTDOCS= ChangeLog README
OPTIONS_DEFINE= DOCS
-post-patch:
- ${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ChangeLog README
diff --git a/net-mgmt/iftop/Makefile b/net-mgmt/iftop/Makefile
index 18b2dd7f08a8..09b676cd3843 100644
--- a/net-mgmt/iftop/Makefile
+++ b/net-mgmt/iftop/Makefile
@@ -16,10 +16,6 @@ GNU_CONFIGURE= yes
PORTDOCS= README
PLIST_FILES= sbin/iftop man/man8/iftop.8.gz
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
diff --git a/net-mgmt/ipcad/Makefile b/net-mgmt/ipcad/Makefile
index 87ded8b819cc..7a98a7ee4553 100644
--- a/net-mgmt/ipcad/Makefile
+++ b/net-mgmt/ipcad/Makefile
@@ -17,8 +17,8 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
- s|/usr/local|${PREFIX}|g; s|pthread_detach|pthread_create|g'\
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
+ s|pthread_detach|pthread_create|g'\
${WRKSRC}/configure
post-install:
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 4cdc659b17c8..a568cfc0901e 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -51,10 +51,7 @@ PLIST_SUB+= EPHY_VERSION=${PORTVERSION:R}
CONFIGURE_ARGS+= --enable-compile-warnings=no
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g'
- @${REINPLACE_CMD} -e 's|execinfo.h|#|g ; \
- s|-ldl"$$|"|g' \
+ @${REINPLACE_CMD} -e 's|execinfo.h|#|g ; s|-ldl"$$|"|g' \
${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 50d377a64d61..4f43574a9aec 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -909,9 +909,6 @@ post-patch:
s!-leio!!; \
s!-Iext/libeio!!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/build/common_library.rb
- @${REINPLACE_CMD} \
- 's!-lpthread!${PTHREAD_LIBS}!g' \
- ${WRKDIR}/passenger-${PASSENGER_VERSION}/lib/phusion_passenger/platform_info/cxx_portability.rb
.endif
.if ${PORT_OPTIONS:MPOSTGRES}
@${REINPLACE_CMD} \
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 4a4d8d2a3d78..39ce8279aea3 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -922,9 +922,6 @@ post-patch:
s!-leio!!; \
s!-Iext/libeio!!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/build/common_library.rb
- @${REINPLACE_CMD} \
- 's!-lpthread!${PTHREAD_LIBS}!g' \
- ${WRKDIR}/passenger-${PASSENGER_VERSION}/lib/phusion_passenger/platform_info/cxx_portability.rb
.endif
.if ${PORT_OPTIONS:MPOSTGRES}
@${REINPLACE_CMD} \
diff --git a/www/rubygem-passenger/Makefile b/www/rubygem-passenger/Makefile
index 2c87c4dac757..f3ed29a6f7c6 100644
--- a/www/rubygem-passenger/Makefile
+++ b/www/rubygem-passenger/Makefile
@@ -101,9 +101,6 @@ pre-patch:
s!/usr/include/libeio!${LOCALBASE}/include!; \
s!-leio!-L${LOCALBASE}/lib -leio!' \
${WRKSRC}/build/common_library.rb
- @${REINPLACE_CMD} \
- 's!-lpthread!${PTHREAD_LIBS}!g' \
- ${WRKSRC}/lib/phusion_passenger/platform_info/cxx_portability.rb
post-build:
.if ${PORT_OPTIONS:MAPACHE22}