aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--korean/kaistfonts/Makefile4
-rw-r--r--korean/kaistfonts/files/patch-Makefile (renamed from korean/kaistfonts/files/patch-aa)7
2 files changed, 3 insertions, 8 deletions
diff --git a/korean/kaistfonts/Makefile b/korean/kaistfonts/Makefile
index 1d8dce1acceb..98dd38e2de6c 100644
--- a/korean/kaistfonts/Makefile
+++ b/korean/kaistfonts/Makefile
@@ -21,7 +21,6 @@ USES= gmake
NO_WRKSUBDIR= yes
MAKE_ENV= DISTDIR=${DISTDIR} DISTFILES="${DISTFILES}"
-NO_STAGE= yes
do-extract:
@${RM} -fr ${WRKDIR} && \
${MKDIR} ${WRKDIR} && \
@@ -30,7 +29,4 @@ do-extract:
${GUNZIP_CMD} -c < ${_DISTDIR}/$$file > `${ECHO_CMD} $$file | ${SED} -e 's/\.Z//' -e 's/\.gz//'`; \
done
-post-install:
- ${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/korean/kaistfonts/files/patch-aa b/korean/kaistfonts/files/patch-Makefile
index 737b1fec5584..b387e1c1e64a 100644
--- a/korean/kaistfonts/files/patch-aa
+++ b/korean/kaistfonts/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig Wed Oct 1 22:41:26 1997
+++ Makefile Wed Oct 1 22:46:06 1997
-@@ -0,0 +1,17 @@
+@@ -0,0 +1,16 @@
+.SUFFIXES: .bdf .pcf
+
+TMP= ${DISTFILES:%.gz=%}
@@ -10,11 +10,10 @@
+all: ${PCF}
+
+install:
-+ -mkdir -p ${PREFIX}/lib/X11/fonts/local
++ -mkdir -p ${DESTDIR}${PREFIX}/lib/X11/fonts/local
+ for i in ${PCF}; do \
-+ gzip -c < $$i > ${PREFIX}/lib/X11/fonts/local/$$i.gz; \
++ gzip -c < $$i > ${DESTDIR}${PREFIX}/lib/X11/fonts/local/$$i.gz; \
+ done
-+ cd ${PREFIX}/lib/X11/fonts/local/ ; mkfontdir
+
+.bdf.pcf:
+ bdftopcf $*.bdf > $*.pcf