aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-HTML-QRCode/Makefile26
-rw-r--r--textproc/p5-HTML-QRCode/distinfo2
-rw-r--r--textproc/p5-HTML-QRCode/pkg-descr3
-rw-r--r--textproc/p5-HTML-QRCode/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 9d03cb60d199..e9dc4d7750da 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -471,6 +471,7 @@
SUBDIR += p5-HTML-Fraction
SUBDIR += p5-HTML-HTML5-Parser
SUBDIR += p5-HTML-HTMLDoc
+ SUBDIR += p5-HTML-QRCode
SUBDIR += p5-HTML-RewriteAttributes
SUBDIR += p5-HTML-SBC
SUBDIR += p5-HTML-SuperForm
diff --git a/textproc/p5-HTML-QRCode/Makefile b/textproc/p5-HTML-QRCode/Makefile
new file mode 100644
index 000000000000..5f2c0d1bf2c3
--- /dev/null
+++ b/textproc/p5-HTML-QRCode/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-HTML-QRCode
+# Date created: 2011/02/14
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-QRCode
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Generate HTML based QR Code
+
+BUILD_DEPENDS= p5-Text-QRCode>0:${PORTSDIR}/textproc/p5-Text-QRCode \
+ libqrencode>=2.0.0:${PORTSDIR}/graphics/libqrencode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
+MAN3= HTML::QRCode.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-HTML-QRCode/distinfo b/textproc/p5-HTML-QRCode/distinfo
new file mode 100644
index 000000000000..e8c32d7c99e0
--- /dev/null
+++ b/textproc/p5-HTML-QRCode/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTML-QRCode-0.01.tar.gz) = 26e23ae91f4ed816a3f45c5784ba69c44f6406a68897313517d797a407b3b22f
+SIZE (HTML-QRCode-0.01.tar.gz) = 36975
diff --git a/textproc/p5-HTML-QRCode/pkg-descr b/textproc/p5-HTML-QRCode/pkg-descr
new file mode 100644
index 000000000000..d89f50daac54
--- /dev/null
+++ b/textproc/p5-HTML-QRCode/pkg-descr
@@ -0,0 +1,3 @@
+HTML::QRCode is HTML based QRCode generator, using Text::QRCode
+
+WWW: http://search.cpan.org/dist/HTML-QRCode/
diff --git a/textproc/p5-HTML-QRCode/pkg-plist b/textproc/p5-HTML-QRCode/pkg-plist
new file mode 100644
index 000000000000..1932ac463dea
--- /dev/null
+++ b/textproc/p5-HTML-QRCode/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/HTML/QRCode.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/QRCode/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/QRCode
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML
+