aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/fwbuilder-devel/Makefile5
-rw-r--r--security/fwbuilder/Makefile5
-rw-r--r--security/fwbuilder2/Makefile5
3 files changed, 3 insertions, 12 deletions
diff --git a/security/fwbuilder-devel/Makefile b/security/fwbuilder-devel/Makefile
index 03600ba79e67..3ce96d5c6ae4 100644
--- a/security/fwbuilder-devel/Makefile
+++ b/security/fwbuilder-devel/Makefile
@@ -17,15 +17,12 @@ COMMENT= Firewall Builder GUI and policy compilers
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS= fwbuilder.6:${PORTSDIR}/security/libfwbuilder
-.if !exists(/usr/include/getopt.h)
-USE_GETOPT_LONG= yes
-.endif
-
USE_QT_VER= 3
QTDIR?= ${X11BASE}
USE_OPENSSL= yes
+USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/security/fwbuilder/Makefile b/security/fwbuilder/Makefile
index 03600ba79e67..3ce96d5c6ae4 100644
--- a/security/fwbuilder/Makefile
+++ b/security/fwbuilder/Makefile
@@ -17,15 +17,12 @@ COMMENT= Firewall Builder GUI and policy compilers
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS= fwbuilder.6:${PORTSDIR}/security/libfwbuilder
-.if !exists(/usr/include/getopt.h)
-USE_GETOPT_LONG= yes
-.endif
-
USE_QT_VER= 3
QTDIR?= ${X11BASE}
USE_OPENSSL= yes
+USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/security/fwbuilder2/Makefile b/security/fwbuilder2/Makefile
index 03600ba79e67..3ce96d5c6ae4 100644
--- a/security/fwbuilder2/Makefile
+++ b/security/fwbuilder2/Makefile
@@ -17,15 +17,12 @@ COMMENT= Firewall Builder GUI and policy compilers
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS= fwbuilder.6:${PORTSDIR}/security/libfwbuilder
-.if !exists(/usr/include/getopt.h)
-USE_GETOPT_LONG= yes
-.endif
-
USE_QT_VER= 3
QTDIR?= ${X11BASE}
USE_OPENSSL= yes
+USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \