aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--korean/hpscat/Makefile2
-rw-r--r--misc/explosions/Makefile3
-rw-r--r--misc/kcd/Makefile3
-rw-r--r--misc/p5-Array-Diff/Makefile9
-rw-r--r--misc/p5-Array-PrintCols/Makefile3
-rw-r--r--misc/p5-Asterisk/Makefile3
-rw-r--r--misc/p5-Business-ISIN/Makefile9
-rw-r--r--misc/p5-Geo-Cache/Makefile9
-rw-r--r--misc/p5-Geo-Postcodes-NO/Makefile9
-rw-r--r--misc/p5-Locale-Geocode/Makefile9
-rw-r--r--misc/p5-Locale-Msgcat/Makefile9
-rw-r--r--misc/p5-Locale-SubCountry/Makefile3
-rw-r--r--misc/p5-Locale-US/Makefile9
-rw-r--r--misc/p5-Net-vCard/Makefile9
-rw-r--r--misc/p5-Software-License/Makefile3
-rw-r--r--misc/p5-Tie-DxHash/Makefile9
-rw-r--r--misc/p5-Zen-Koans/Makefile9
-rw-r--r--misc/quotes/Makefile3
18 files changed, 43 insertions, 70 deletions
diff --git a/korean/hpscat/Makefile b/korean/hpscat/Makefile
index d3951771416f..a448b01e5feb 100644
--- a/korean/hpscat/Makefile
+++ b/korean/hpscat/Makefile
@@ -31,7 +31,7 @@ PLIST_DIRS= ${FONTDIR_REL}
PLIST_DIRSTRY= share/fonts
SUB_FILES= hpscat.sh pkg-message
SUB_LIST= FONTDIR=${FONTDIR}
-USE_PERL5= yes
+USES= perl5
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/hpscat ${PREFIX}/bin/hpscat.bin
diff --git a/misc/explosions/Makefile b/misc/explosions/Makefile
index bc474112746a..caa481680c6c 100644
--- a/misc/explosions/Makefile
+++ b/misc/explosions/Makefile
@@ -13,7 +13,8 @@ COMMENT= 3D objects flying around resembling explosions with various effects
USE_SDL= sdl image
USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
.include <bsd.port.options.mk>
diff --git a/misc/kcd/Makefile b/misc/kcd/Makefile
index b39146924c6c..db7c3629e357 100644
--- a/misc/kcd/Makefile
+++ b/misc/kcd/Makefile
@@ -12,8 +12,7 @@ COMMENT= Change directory in full-screen visual mode
LICENSE= GPLv2
-USES= gettext
-USE_PERL5= yes
+USES= gettext perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/misc/p5-Array-Diff/Makefile b/misc/p5-Array-Diff/Makefile
index 8df7105339c9..ebd714547e33 100644
--- a/misc/p5-Array-Diff/Makefile
+++ b/misc/p5-Array-Diff/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Array-Diff
-# Date created: March 09, 2008
-# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
-#
+# Created by: Yen-Ming Lee <leeym@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Array-Diff
PORTVERSION= 0.07
@@ -18,7 +14,8 @@ RUN_DEPENDS= p5-Algorithm-Diff>=1.19:${PORTSDIR}/devel/p5-Algorithm-Diff \
p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Array::Diff.3
diff --git a/misc/p5-Array-PrintCols/Makefile b/misc/p5-Array-PrintCols/Makefile
index 4a3cad9f4a3b..5a21c67b1207 100644
--- a/misc/p5-Array-PrintCols/Makefile
+++ b/misc/p5-Array-PrintCols/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module to print arrays of elements in sorted columns
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Array::PrintCols.3
diff --git a/misc/p5-Asterisk/Makefile b/misc/p5-Asterisk/Makefile
index df15a93d140e..e41be65ed28b 100644
--- a/misc/p5-Asterisk/Makefile
+++ b/misc/p5-Asterisk/Makefile
@@ -12,7 +12,8 @@ DISTNAME= asterisk-perl-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= Asterisk perl library
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/asterisk-perl-${PORTVERSION}
MAN3= Asterisk::AGI.3 \
diff --git a/misc/p5-Business-ISIN/Makefile b/misc/p5-Business-ISIN/Makefile
index ae1d2e214945..4f3c2e01e7bc 100644
--- a/misc/p5-Business-ISIN/Makefile
+++ b/misc/p5-Business-ISIN/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Business::ISIN
-# Date created: 24 Jan 2002
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Business-ISIN
PORTVERSION= 0.20
@@ -18,7 +14,8 @@ COMMENT= Validate International Securities Identification Numbers
BUILD_DEPENDS= p5-Locale-Codes>=0:${PORTSDIR}/misc/p5-Locale-Codes
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::ISIN.3
diff --git a/misc/p5-Geo-Cache/Makefile b/misc/p5-Geo-Cache/Makefile
index 06f4ed304f3f..cfdc3c996f0c 100644
--- a/misc/p5-Geo-Cache/Makefile
+++ b/misc/p5-Geo-Cache/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Geo-Cache
-# Date created: 18 Feb 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Geo-Cache
PORTVERSION= 0.11
@@ -18,7 +14,8 @@ RUN_DEPENDS= p5-Time-modules>=0:${PORTSDIR}/devel/p5-Time-modules \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::Cache.3
diff --git a/misc/p5-Geo-Postcodes-NO/Makefile b/misc/p5-Geo-Postcodes-NO/Makefile
index d6500215b99c..f45ed5809ae2 100644
--- a/misc/p5-Geo-Postcodes-NO/Makefile
+++ b/misc/p5-Geo-Postcodes-NO/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-Postcodes-NO
-# Date created: 2006-07-19
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Geo-Postcodes-NO
PORTVERSION= 0.31
@@ -17,7 +13,8 @@ COMMENT= Norwegian postcodes with associated information
BUILD_DEPENDS= p5-Geo-Postcodes>=0.31:${PORTSDIR}/misc/p5-Geo-Postcodes
RUN_DEPENDS= p5-Geo-Postcodes>=0.31:${PORTSDIR}/misc/p5-Geo-Postcodes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::Postcodes::NO.3
diff --git a/misc/p5-Locale-Geocode/Makefile b/misc/p5-Locale-Geocode/Makefile
index c15383c5d47d..d91fc9bb71f2 100644
--- a/misc/p5-Locale-Geocode/Makefile
+++ b/misc/p5-Locale-Geocode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Locale-Geocode
-# Date created: 2008/08/31
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= Locale-Geocode
PORTVERSION= 1.20
@@ -21,7 +17,8 @@ RUN_DEPENDS= p5-XML-SAX-Expat>=0.39:${PORTSDIR}/textproc/p5-XML-SAX-Expat \
p5-XML-Simple>=2.16:${PORTSDIR}/textproc/p5-XML-Simple
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Locale::Geocode.3 \
Locale::Geocode::Division.3 \
diff --git a/misc/p5-Locale-Msgcat/Makefile b/misc/p5-Locale-Msgcat/Makefile
index ff5096a447f6..c339456e3d64 100644
--- a/misc/p5-Locale-Msgcat/Makefile
+++ b/misc/p5-Locale-Msgcat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Locale-Codes
-# Date created: 28 December 2002
-# Whom: Sebastien gioria <gioria@FreeBSD.org>
-#
+# Created by: Sebastien gioria <gioria@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Msgcat
PORTVERSION= 1.03
@@ -17,6 +13,7 @@ COMMENT= Perl module for systems to support the XPG4 message catalog functions
MAN3= Locale::Msgcat.3
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/misc/p5-Locale-SubCountry/Makefile b/misc/p5-Locale-SubCountry/Makefile
index b42c073f41ba..2f6852599bb9 100644
--- a/misc/p5-Locale-SubCountry/Makefile
+++ b/misc/p5-Locale-SubCountry/Makefile
@@ -13,7 +13,8 @@ COMMENT= Convert state, province, county etc. names to/from code
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Locale::SubCountry.3 \
Locale::SubCountry::Data.3
diff --git a/misc/p5-Locale-US/Makefile b/misc/p5-Locale-US/Makefile
index 99550db9271a..a2ea7a12a2d9 100644
--- a/misc/p5-Locale-US/Makefile
+++ b/misc/p5-Locale-US/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Locale-US
-# Date created: 2008-07-31
-# Whom: Tomoyuki Sakurai <cherry@trombik.org>
-#
+# Created by: Tomoyuki Sakurai <cherry@trombik.org>
# $FreeBSD$
-#
PORTNAME= Locale-US
PORTVERSION= 2.112.150
@@ -18,7 +14,8 @@ COMMENT= Two letter codes for state identification in the United States
BUILD_DEPENDS= p5-Data-Section-Simple>=0:${PORTSDIR}/devel/p5-Data-Section-Simple
RUN_DEPENDS= p5-Data-Section-Simple>=0:${PORTSDIR}/devel/p5-Data-Section-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Locale::US.3
diff --git a/misc/p5-Net-vCard/Makefile b/misc/p5-Net-vCard/Makefile
index d3eb76ca3384..86407f6f6e4d 100644
--- a/misc/p5-Net-vCard/Makefile
+++ b/misc/p5-Net-vCard/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Net-vCard
-# Date created: 16 April 2003
-# Whom: Mathieu Arnold <m@absolight.net>
-#
+# Created by: Mathieu Arnold <m@absolight.net>
# $FreeBSD$
-#
PORTNAME= Net-vCard
PORTVERSION= 0.5
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Read and write vCard files (RFC 2426)
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::vFile.3 Net::vCard.3
diff --git a/misc/p5-Software-License/Makefile b/misc/p5-Software-License/Makefile
index 08f7678d909f..e1ff6a10f140 100644
--- a/misc/p5-Software-License/Makefile
+++ b/misc/p5-Software-License/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= p5-Data-Section>=0:${PORTSDIR}/devel/p5-Data-Section \
p5-Text-Template>=0:${PORTSDIR}/textproc/p5-Text-Template \
p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Software::License.3 \
Software::License::AGPL_3.3 \
diff --git a/misc/p5-Tie-DxHash/Makefile b/misc/p5-Tie-DxHash/Makefile
index d71992ffa498..ab70fbad29b0 100644
--- a/misc/p5-Tie-DxHash/Makefile
+++ b/misc/p5-Tie-DxHash/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Tie::DxHash
-# Date created: 25 Jan 2002
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Tie-DxHash
PORTVERSION= 1.05
@@ -17,7 +13,8 @@ COMMENT= Perl module implementing ordered hashes with duplicate keys
BUILD_DEPENDS= p5-version>0:${PORTSDIR}/devel/p5-version
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tie::DxHash.3
diff --git a/misc/p5-Zen-Koans/Makefile b/misc/p5-Zen-Koans/Makefile
index aa76d64d54ba..282bd7602c08 100644
--- a/misc/p5-Zen-Koans/Makefile
+++ b/misc/p5-Zen-Koans/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Zen-Koans
-# Date created: 21 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Zen-Koans
PORTVERSION= 0.05
@@ -17,6 +13,7 @@ COMMENT= Library containing over 100 Zen Koans
MAN3= Zen::Koan.3 Zen::Koans.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/misc/quotes/Makefile b/misc/quotes/Makefile
index 631185563f5a..fd88bbac66e1 100644
--- a/misc/quotes/Makefile
+++ b/misc/quotes/Makefile
@@ -13,8 +13,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Quote, currency, and Slashdot headline fetcher based on Perl
NO_BUILD= yes
-USE_PERL5= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= quotes quotesmailer QuExample.pm
.include <bsd.port.options.mk>