aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-pkginfo/Makefile3
-rw-r--r--sysutils/py3-pkginfo/Makefile8
3 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 8a1a4ef28422..7678186598f1 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -899,6 +899,7 @@
SUBDIR += py-zfs
SUBDIR += pydf
SUBDIR += py3-iocage
+ SUBDIR += py3-pkginfo
SUBDIR += qchroot
SUBDIR += qjail
SUBDIR += qjail2
diff --git a/sysutils/py-pkginfo/Makefile b/sysutils/py-pkginfo/Makefile
index b24d82834aa9..a632febbd2fb 100644
--- a/sysutils/py-pkginfo/Makefile
+++ b/sysutils/py-pkginfo/Makefile
@@ -11,7 +11,8 @@ COMMENT= Query metadatdata from sdists / bdists / installed packages
LICENSE= MIT
-USES= python
+NO_ARCH= yes
+USES?= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/sysutils/py3-pkginfo/Makefile b/sysutils/py3-pkginfo/Makefile
new file mode 100644
index 000000000000..b61d7e097b66
--- /dev/null
+++ b/sysutils/py3-pkginfo/Makefile
@@ -0,0 +1,8 @@
+# Created by: rs.os
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-pkginfo
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"