aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/gnuradio/Makefile3
-rw-r--r--comms/mgetty+sendfax/Makefile2
-rw-r--r--math/R/Makefile3
-rw-r--r--math/cvc3/Makefile8
-rw-r--r--math/maxima/Makefile3
-rw-r--r--math/octave/Makefile5
-rw-r--r--math/p5-Parse-Range/Makefile7
-rw-r--r--math/proofgeneral/Makefile3
-rw-r--r--math/pspp/Makefile4
-rw-r--r--math/stp/Makefile5
-rw-r--r--x11-fonts/terminus-font/Makefile10
-rw-r--r--x11-fonts/wqy/Makefile9
-rw-r--r--x11/kdelibs4/Makefile3
-rw-r--r--x11/libexo/Makefile4
-rw-r--r--x11/libxfce4util/Makefile4
-rw-r--r--x11/mlterm/Makefile4
-rw-r--r--x11/xfce4-conf/Makefile5
-rw-r--r--x11/xkbset/Makefile3
18 files changed, 33 insertions, 52 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index b39a39c5e904..ec37b44dbfe7 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -32,14 +32,13 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_SITELIBDIR}/ephem/__init__.py:${PORTSDIR}/astro/pyephem\
${PYTHON_SITELIBDIR}/PyQt4/Qt.py:${PORTSDIR}/devel/py-qt4
-USES= cmake:outsource
+USES= cmake:outsource perl5
CMAKE_VERBOSE= yes
DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
USE_PYTHON= 2.7+
USE_WX= 2.6+
USE_QT4= gui xml qmake moc rcc uic
WX_COMPS= wx wx:build wx:run python:build python:run
-USE_PERL5= yes
USE_LDCONFIG= yes
PLIST_SUB+= MAJOR_VERSION="3"
diff --git a/comms/mgetty+sendfax/Makefile b/comms/mgetty+sendfax/Makefile
index 7dac74af87e2..f342ecf1bbfc 100644
--- a/comms/mgetty+sendfax/Makefile
+++ b/comms/mgetty+sendfax/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Handle external logins, send and receive faxes
USE_CSTD= gnu89
-USE_PERL5= yes
+USES= perl5
SUB_FILES= pkg-message mgettycfg
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/math/R/Makefile b/math/R/Makefile
index 61edf9f4adfe..76bfebd37144 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -66,7 +66,8 @@ OPTIONS_DEFAULT+= ICU PCRE_PORT THREADS
RUN_DEPENDS+= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
USE_LDCONFIG= ${PREFIX}/lib/R/lib
#now only used to build the R.1 manpage:
-USE_PERL5_BUILD= yes
+USES+= perl5
+USE_PERL5= build
MAN1= R.1 Rscript.1
diff --git a/math/cvc3/Makefile b/math/cvc3/Makefile
index 2b4dd659a13f..b5d1d2346f5a 100644
--- a/math/cvc3/Makefile
+++ b/math/cvc3/Makefile
@@ -18,12 +18,8 @@ CONFIGURE_ARGS= --enable-dynamic \
--with-extra-libs=${LOCALBASE}/lib
CXXFLAGS+= -fPIC
GNU_CONFIGURE= yes
-USES= bison
-USE_GMAKE= yes
+USES= bison gmake perl5
USE_LDCONFIG= yes
-USE_PERL5= yes
-
-.include <bsd.port.pre.mk>
post-patch:
${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' ${WRKSRC}/Makefile.std
@@ -33,4 +29,4 @@ post-patch:
post-install:
${INSTALL_PROGRAM} `readlink ${WRKSRC}/bin/cvc3` ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/maxima/Makefile b/math/maxima/Makefile
index 02d51af6000e..d7503419021d 100644
--- a/math/maxima/Makefile
+++ b/math/maxima/Makefile
@@ -19,8 +19,9 @@ RUN_DEPENDS= ${LOCALBASE}/bin/${LISPPORT} \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
USE_TK = 84+
+USES= gmake perl5
USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_PYTHON_BUILD= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} \
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 721790e15300..a646d894c34d 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -32,10 +32,9 @@ LIB_DEPENDS= GraphicsMagick:${PORTSDIR}/graphics/GraphicsMagick \
umfpack.1:${PORTSDIR}/math/suitesparse \
glpk:${PORTSDIR}/math/glpk
-USES= charsetfix pkgconfig
+USES= charsetfix gmake perl5 pkgconfig
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
-USE_GMAKE= yes
+USE_PERL5= build
USE_TEX= dvipsk:build
GNU_CONFIGURE= yes
#USE_AUTOTOOLS= autoconf
diff --git a/math/p5-Parse-Range/Makefile b/math/p5-Parse-Range/Makefile
index 5bc5a9b8e288..d48fbb2ca9f2 100644
--- a/math/p5-Parse-Range/Makefile
+++ b/math/p5-Parse-Range/Makefile
@@ -20,10 +20,9 @@ BUILD_DEPENDS= p5-Module-Build>=0.4:${PORTSDIR}/devel/p5-Module-Build \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Parse::Range.3
-.include <bsd.port.pre.mk>
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
index 4d7baadf6524..74d30bd07649 100644
--- a/math/proofgeneral/Makefile
+++ b/math/proofgeneral/Makefile
@@ -20,9 +20,8 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USE_EMACS= yes
-USE_GMAKE= yes
INSTALLS_ICONS= yes
-USE_PERL5= yes
+USES= gmake perl5
.include <bsd.port.pre.mk>
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 30992668a8ac..98f8b8cbb4d4 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= plot.4:${PORTSDIR}/graphics/plotutils \
OPTIONS_DEFINE= GUI PGSQL
USE_GNOME= libxml2
-USE_PERL5_BUILD=yes
-USES= iconv
+USE_PERL5= build
+USES= iconv gmake perl5
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/math/stp/Makefile b/math/stp/Makefile
index 35377a839c57..1ad7841da00e 100644
--- a/math/stp/Makefile
+++ b/math/stp/Makefile
@@ -12,10 +12,9 @@ COMMENT= A Decision Procedure for Bitvectors and Arrays
LICENSE= MIT
-USES= bison
+USES= bison gmake perl5
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
CONFIGURE_SCRIPT= scripts/configure
CONFIGURE_ARGS= --with-prefix=${PREFIX} \
diff --git a/x11-fonts/terminus-font/Makefile b/x11-fonts/terminus-font/Makefile
index a1d1c885dca5..d4f04479215f 100644
--- a/x11-fonts/terminus-font/Makefile
+++ b/x11-fonts/terminus-font/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: terminus-font
-# Date Created: 04 Nov 2002
-# Whom: Michael Hsin <mhsin@mhsin.org>
-#
+# Created by: Michael Hsin <mhsin@mhsin.org>
# $FreeBSD$
-#
PORTNAME= terminus-font
PORTVERSION= 4.38
@@ -18,8 +14,8 @@ BUILD_DEPENDS= mkitalic:${PORTSDIR}/x11-fonts/mkbold-mkitalic \
mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
-USE_PERL5_BUILD=yes
-USE_GMAKE= yes
+USES= gmake perl5
+USE_PERL5= build
OPTIONS_DEFINE= AO2 DV1 GE2 GQ2 IJ1 KA2 HI2 LL2 TD1
AO2_DESC= Variant of letter 'a'
diff --git a/x11-fonts/wqy/Makefile b/x11-fonts/wqy/Makefile
index 5b64136d1330..b9238a6be985 100644
--- a/x11-fonts/wqy/Makefile
+++ b/x11-fonts/wqy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wqy font
-# Date created: 11 May 2005
-# Whom: Dryice Liu <dryice@liu.com.cn>
-#
+# Created by: Dryice Liu <dryice@liu.com.cn>
# $FreeBSD$
-#
PORTNAME= wqy-fonts
PORTVERSION= 20100803
@@ -29,7 +25,8 @@ BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
fc-cache:${PORTSDIR}/x11-fonts/fontconfig
USE_XORG= x11
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
FONTSDIR= lib/X11/fonts/wqy
CONFDDIR= etc/fonts/conf.d
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index b568b1dc6f51..86b7e0594fca 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -42,9 +42,8 @@ USE_FAM= yes
USE_GNOME= libxml2 libxslt
USE_KDE4= kdehier kdeprefix oxygen \
attica automoc4 ontologies sharedmime soprano strigi
-USES= cmake:outsource gettext
+USES= cmake:outsource gettext perl5
USE_OPENSSL= yes
-USE_PERL5= yes
USE_QT4= corelib dbus declarative designer_build gui \
network opengl phonon qt3support \
qtestlib script sql svg webkit xml \
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index 25f0ca401e46..b7f5ccd57a70 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -23,13 +23,11 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/lib//}
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_XFCE= configenv libmenu libutil
USE_XORG= x11
-USES= desktop-file-utils pathfix pkgconfig
+USES= desktop-file-utils gmake pathfix perl5 pkgconfig
OPTIONS_DEFINE= DOCS NLS
diff --git a/x11/libxfce4util/Makefile b/x11/libxfce4util/Makefile
index 478a7c7977eb..84f2f4e44edc 100644
--- a/x11/libxfce4util/Makefile
+++ b/x11/libxfce4util/Makefile
@@ -13,12 +13,10 @@ COMMENT= Extension library for the Xfce desktop environment
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 intltool intlhack
-USE_PERL5= yes
USE_LDCONFIG= yes
USE_XFCE= configenv
-USES= pathfix pkgconfig
+USES= gmake pathfix perl5 pkgconfig
OPTIONS_DEFINE= NLS DOCS
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 702990d9e6c4..3a71c6498930 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -15,8 +15,8 @@ USE_XORG= sm
USE_GNOME= gtk20 lthack vte
USE_AUTOTOOLS= libtool
LIBTOOLFILES= configure kiklib/configure mkf/configure
-USE_PERL5_BUILD=yes
-USES= gettext pkgconfig
+USE_PERL5= build
+USES= gettext pkgconfig perl5
CONFIGURE_ARGS= --with-imagelib=gdk-pixbuf2 --enable-utmp \
--enable-optimize-redrawing \
--with-tools="mlclient,mlconfig,mlterm-menu,mlcc,w3mmlconfig,mlimgloader" \
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index f23b9b3ed38a..4a5185320e60 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -17,13 +17,12 @@ LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_XFCE= configenv libutil
USE_XORG= x11
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig perl5
OPTIONS_DEFINE= DOCS PERL NLS
diff --git a/x11/xkbset/Makefile b/x11/xkbset/Makefile
index 45a94d0fc90a..62b749c69a9d 100644
--- a/x11/xkbset/Makefile
+++ b/x11/xkbset/Makefile
@@ -12,7 +12,8 @@ COMMENT= Manage various XKB features of X Window
MAN1= xkbset.1
USE_XORG= x11
-USE_PERL5_BUILD= yes
+USE_PERL5= build
+USES= perl5
MAKE_ARGS= X11BASE="${LOCALBASE}" X11PREFIX="${PREFIX}" \
INSTALL_DATA="${INSTALL_DATA}" \