aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/qcad/Makefile4
-rw-r--r--cad/qcad/files/patch-src_core_RS.cpp11
2 files changed, 14 insertions, 1 deletions
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index c94bbd205a26..1e850d39d75c 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qcad
PORTVERSION= 3.7.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MASTER_SITES= http://github.com/${PORTNAME}/${PORTNAME}/archive/${DISTNAME}.tar.gz?dummy=/ \
https://github.com/${PORTNAME}/${PORTNAME}/archive/${DISTNAME}.tar.gz?dummy=/
@@ -50,6 +50,8 @@ QSCRIPTS= bbox dwg2bmp dwg2pdf dwg2svg
pre-configure:
${REINPLACE_CMD} -e "s|%%DATADIR%%|${DATADIR}|" \
+ ${WRKSRC}/src/core/RS.cpp
+ ${REINPLACE_CMD} -e "s|%%DATADIR%%|${DATADIR}|" \
${WRKSRC}/src/core/RSettings.cpp
# Temporary hack for Qt 4.8.6 support while upstream does not add proper
diff --git a/cad/qcad/files/patch-src_core_RS.cpp b/cad/qcad/files/patch-src_core_RS.cpp
new file mode 100644
index 000000000000..9663a39262db
--- /dev/null
+++ b/cad/qcad/files/patch-src_core_RS.cpp
@@ -0,0 +1,11 @@
+--- src/core/RS.cpp.orig 2015-01-30 18:11:57.235513076 +0100
++++ src/core/RS.cpp 2015-01-30 18:12:23.988630795 +0100
+@@ -119,4 +119,8 @@
+ */
+
++#ifdef Q_OS_FREEBSD
++ dirList.append("%%DATADIR%%/" + subDirectory);
++#endif
++
+ // Individual directories:
+ /*