aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-HTML_Page2/Makefile25
-rw-r--r--devel/pear-HTML_Page2/distinfo2
-rw-r--r--devel/pear-HTML_Page2/pkg-descr20
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e891fc51601e..db733e9fdc57 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1105,6 +1105,7 @@
SUBDIR += pear-HTML_Common
SUBDIR += pear-HTML_Form
SUBDIR += pear-HTML_Javascript
+ SUBDIR += pear-HTML_Page2
SUBDIR += pear-HTML_QuickForm
SUBDIR += pear-HTML_QuickForm_Controller
SUBDIR += pear-HTML_QuickForm_SelectFilter
diff --git a/devel/pear-HTML_Page2/Makefile b/devel/pear-HTML_Page2/Makefile
new file mode 100644
index 000000000000..aa1cc10e24d4
--- /dev/null
+++ b/devel/pear-HTML_Page2/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-HTML_Page2
+# Date created: 21 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_Page2
+PORTVERSION= 0.5.0
+CATEGORIES= devel www pear
+DISTNAME= ${PORTNAME}-${PORTVERSION}beta
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR base class for XHTML page generation
+
+BUILD_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTML
+FILES= Page2.php Page2/Doctypes.php Page2/Namespaces.php
+EXAMPLES= Page2_NoDoctype.php Page2_Simple.php Page2_Complex.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_Page2/distinfo b/devel/pear-HTML_Page2/distinfo
new file mode 100644
index 000000000000..cea9ed685950
--- /dev/null
+++ b/devel/pear-HTML_Page2/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTML_Page2-0.5.0beta.tgz) = a10646c904fafb3a39ecaf6920f0d174
+SIZE (PEAR/HTML_Page2-0.5.0beta.tgz) = 15467
diff --git a/devel/pear-HTML_Page2/pkg-descr b/devel/pear-HTML_Page2/pkg-descr
new file mode 100644
index 000000000000..b010dc2aec94
--- /dev/null
+++ b/devel/pear-HTML_Page2/pkg-descr
@@ -0,0 +1,20 @@
+The PEAR::HTML_Page2 package provides a simple interface for generating an
+XHTML compliant page:
+ * supports virtually all HTML doctypes, from HTML 2.0 through XHTML 1.1 and
+ XHTML Basic 1.0 plus preliminary support for XHTML 2.0
+ * namespace support
+ * global language declaration for the document
+ * line ending styles
+ * full META tag support
+ * support for stylesheet declaration in the head section
+ * support for script declaration in the head section
+ * support for linked stylesheets and scripts
+ * full support for header link tags
+ * body can be a string, object with toHtml or toString methods or an array
+ (can be combined)
+
+Ideas for use:
+ * Use to validate the output of a class for XHTML compliance
+ * Quick prototyping using PEAR packages is now a breeze.
+
+WWW: http://pear.php.net/package/HTML_Page2/