aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/mirall/Makefile43
-rw-r--r--deskutils/mirall/distinfo4
-rw-r--r--deskutils/mirall/files/patch-src__CMakeLists.txt8
-rw-r--r--deskutils/mirall/files/patch-src__mirall__application.cpp11
-rw-r--r--deskutils/mirall/files/patch-src__mirall__filesystem.cpp10
-rw-r--r--deskutils/mirall/files/patch-src__mirall__folderwatcher.cpp11
-rw-r--r--deskutils/mirall/files/patch-src__mirall__generalsettings.cpp23
-rw-r--r--deskutils/mirall/files/patch-src__mirall__mirallconfigfile.cpp25
-rw-r--r--deskutils/mirall/pkg-descr4
-rw-r--r--deskutils/mirall/pkg-plist133
10 files changed, 208 insertions, 64 deletions
diff --git a/deskutils/mirall/Makefile b/deskutils/mirall/Makefile
index 5cd430cfd85b..1870363c7f28 100644
--- a/deskutils/mirall/Makefile
+++ b/deskutils/mirall/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mirall
-PORTVERSION= 1.5.3
-PORTREVISION= 1
+PORTVERSION= 1.6.0
CATEGORIES= deskutils
MASTER_SITES= http://download.owncloud.com/desktop/stable/
@@ -12,37 +11,41 @@ COMMENT= The ownCloud Desktop Syncing Client
LICENSE= GPLv2
-LIB_DEPENDS= libocsync.so:${PORTSDIR}/net/owncloud-csync \
- libinotify.so:${PORTSDIR}/devel/libinotify \
- libqtkeychain.so:${PORTSDIR}/security/qtkeychain
+LIB_DEPENDS= libinotify.so:${PORTSDIR}/devel/libinotify \
+ libqtkeychain.so:${PORTSDIR}/security/qtkeychain \
+ libneon.so:${PORTSDIR}/www/neon29
-USES= cmake:outsource pkgconfig gmake compiler:c++11-lang tar:bzip2
-USE_QT4= corelib dbus gui linguist moc network qmake qtestlib rcc uic webkit xml
-CMAKE_ENV= CSYNC_DIR=${LOCALBASE} INOTIFY_LIB=${LOCALBASE}/lib
-CMAKE_ARGS= -DCSYNC_INCLUDE_PATH:STRING=${LOCALBASE}/include/ocsync/
+USES= cmake:outsource compiler:c++11-lang gmake pkgconfig tar:bzip2
+USE_QT4= corelib dbus gui network qtestlib webkit xml \
+ linguist_build moc_build qmake_build rcc_build uic_build
+CMAKE_ENV= INOTIFY_LIB="${LOCALBASE}/lib"
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR:STRING=${MANPREFIX}/man/
+USE_SQLITE= 3
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-ALL_TARGET= all
+CONFLICTS= owncloud-csync-[0-9]*
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
-DOCS_USE= TEX=latex:build
-DOCS_CMAKE_ON= WITH_DOC=true
-DOCS_ALL_TARGET= doc-html doc-pdf
+DOCS_USE= TEX=latex:build
+DOCS_CMAKE_ON= WITH_DOC=true
+DOCS_ALL_TARGET= all doc-html doc-pdf
-PLIST_SUB+= VERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|.lst |.lst.sample |' ${WRKSRC}/CMakeLists.txt
-.include <bsd.port.options.mk>
+post-build:
+ @(cd ${WRKSRC} && ${CP} -f sync-exclude.lst sync-exclude.lst.sample)
-.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${INSTALL_WRKSRC}/doc/latex && ${INSTALL_DATA} *.pdf \
+ ${STAGEDIR}${DOCSDIR})
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
- ${INSTALL_DATA} ${INSTALL_WRKSRC}/doc/latex/ownCloudClientManual.pdf ${STAGEDIR}${DOCSDIR}
- (cd ${INSTALL_WRKSRC}/doc/html/unthemed && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/html)
- ${MV} ${STAGEDIR}${PREFIX}/etc/ownCloud/sync-exclude.lst ${STAGEDIR}${PREFIX}/etc/ownCloud/sync-exclude.lst.sample
-.endif
+ @(cd ${INSTALL_WRKSRC}/doc/html/unthemed && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${DOCSDIR}/html)
.include <bsd.port.mk>
diff --git a/deskutils/mirall/distinfo b/deskutils/mirall/distinfo
index e7fec3176ec9..dc7c7e275ded 100644
--- a/deskutils/mirall/distinfo
+++ b/deskutils/mirall/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mirall-1.5.3.tar.bz2) = a50f235eba7a24915e583c3c5bb68ccd86171296151a9520f5a375842b3ced8e
-SIZE (mirall-1.5.3.tar.bz2) = 7841424
+SHA256 (mirall-1.6.0.tar.bz2) = 12b5da4b5598db3ef5d4d26e464de3534f3a6b8a864719949d82c77cfc353ab5
+SIZE (mirall-1.6.0.tar.bz2) = 7868930
diff --git a/deskutils/mirall/files/patch-src__CMakeLists.txt b/deskutils/mirall/files/patch-src__CMakeLists.txt
index 4d918b044e20..f3c955f0ed4b 100644
--- a/deskutils/mirall/files/patch-src__CMakeLists.txt
+++ b/deskutils/mirall/files/patch-src__CMakeLists.txt
@@ -1,9 +1,9 @@
---- ./src/CMakeLists.txt.orig 2014-03-10 12:22:06.000000000 +0100
-+++ ./src/CMakeLists.txt 2014-03-18 17:12:29.000000000 +0100
-@@ -136,6 +136,7 @@
+--- src/CMakeLists.txt.orig
++++ src/CMakeLists.txt
+@@ -131,6 +131,7 @@
+
IF( NOT WIN32 AND NOT APPLE )
set(libsync_SRCS ${libsync_SRCS} mirall/folderwatcher_linux.cpp)
- set(libsync_HEADERS ${libsync_HEADERS} mirall/folderwatcher_linux.h)
+ link_directories($ENV{INOTIFY_LIB})
ENDIF()
IF( WIN32 )
diff --git a/deskutils/mirall/files/patch-src__mirall__application.cpp b/deskutils/mirall/files/patch-src__mirall__application.cpp
deleted file mode 100644
index d82f52c980de..000000000000
--- a/deskutils/mirall/files/patch-src__mirall__application.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/mirall/application.cpp.orig 2014-03-25 17:13:11.000000000 +0100
-+++ ./src/mirall/application.cpp 2014-03-25 17:13:36.000000000 +0100
-@@ -64,7 +64,7 @@
-
- QString applicationTrPath()
- {
--#ifdef Q_OS_LINUX
-+#if defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
- return QString::fromLatin1(DATADIR"/"APPLICATION_EXECUTABLE"/i18n/");
- #endif
- #ifdef Q_OS_MAC
diff --git a/deskutils/mirall/files/patch-src__mirall__filesystem.cpp b/deskutils/mirall/files/patch-src__mirall__filesystem.cpp
new file mode 100644
index 000000000000..f5d446f3b15c
--- /dev/null
+++ b/deskutils/mirall/files/patch-src__mirall__filesystem.cpp
@@ -0,0 +1,10 @@
+--- src/mirall/filesystem.cpp.orig
++++ src/mirall/filesystem.cpp
+@@ -12,6 +12,7 @@
+ */
+
+ #include "filesystem.h"
++#include <sys/time.h>
+ #include <QFile>
+ #include <QDebug>
+
diff --git a/deskutils/mirall/files/patch-src__mirall__folderwatcher.cpp b/deskutils/mirall/files/patch-src__mirall__folderwatcher.cpp
deleted file mode 100644
index c3ef23449696..000000000000
--- a/deskutils/mirall/files/patch-src__mirall__folderwatcher.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/mirall/folderwatcher.cpp.orig 2014-03-10 12:22:06.000000000 +0100
-+++ ./src/mirall/folderwatcher.cpp 2014-03-24 14:18:20.000000000 +0100
-@@ -29,7 +29,7 @@
- #include "mirall/folderwatcher_win.h"
- #elif defined(Q_OS_MAC)
- #include "mirall/folderwatcher_mac.h"
--#elif defined(Q_OS_LINUX)
-+#elif defined(Q_OS_LINUX) || defined(Q_OS_FREEBSD)
- #include "mirall/folderwatcher_linux.h"
- #endif
-
diff --git a/deskutils/mirall/files/patch-src__mirall__generalsettings.cpp b/deskutils/mirall/files/patch-src__mirall__generalsettings.cpp
new file mode 100644
index 000000000000..6e43072d852b
--- /dev/null
+++ b/deskutils/mirall/files/patch-src__mirall__generalsettings.cpp
@@ -0,0 +1,23 @@
+--- src/mirall/generalsettings.cpp.orig
++++ src/mirall/generalsettings.cpp
+@@ -76,6 +76,7 @@
+
+ void GeneralSettings::slotUpdateInfo()
+ {
++#if 0
+ if (OCUpdater *updater = dynamic_cast<OCUpdater*>(Updater::instance()))
+ {
+ connect(updater, SIGNAL(downloadStateChanged()), SLOT(slotUpdateInfo()), Qt::UniqueConnection);
+@@ -84,9 +85,12 @@
+ _ui->updateStateLabel->setText(updater->statusString());
+ _ui->restartButton->setVisible(updater->downloadState() == OCUpdater::DownloadComplete);
+ } else {
++#endif
+ // can't have those infos from sparkle currently
+ _ui->updatesGroupBox->setVisible(false);
++#if 0
+ }
++#endif
+ }
+
+ void GeneralSettings::saveMiscSettings()
diff --git a/deskutils/mirall/files/patch-src__mirall__mirallconfigfile.cpp b/deskutils/mirall/files/patch-src__mirall__mirallconfigfile.cpp
new file mode 100644
index 000000000000..f62f16cf6276
--- /dev/null
+++ b/deskutils/mirall/files/patch-src__mirall__mirallconfigfile.cpp
@@ -0,0 +1,25 @@
+--- src/mirall/mirallconfigfile.cpp.orig
++++ src/mirall/mirallconfigfile.cpp
+@@ -359,11 +359,22 @@
+ QString con( connection );
+ if( connection.isEmpty() ) con = defaultConnection();
+
++#if 0
+ QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
++#else
++ QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true);
++#endif
+ fallback = getValue(QLatin1String(skipUpdateCheckC), QString(), fallback);
+
+ QVariant value = getPolicySetting(QLatin1String(skipUpdateCheckC), fallback);
++#if 0
+ return value.toBool();
++#else
++ if ( !value.toBool() )
++ qDebug() << "FreeBSD package disabled the UpdateCheck mechanism.";
++
++ return true;
++#endif
+ }
+
+ void MirallConfigFile::setSkipUpdateCheck( bool skip, const QString& connection )
diff --git a/deskutils/mirall/pkg-descr b/deskutils/mirall/pkg-descr
index 069d9f2f9ab6..f1fcb658c092 100644
--- a/deskutils/mirall/pkg-descr
+++ b/deskutils/mirall/pkg-descr
@@ -1,4 +1,4 @@
-Mirall is a tool to synchronize files from ownCloud Server with your computer.
-It uses OCSync as its syncing backend.
+Mirall is a tool to synchronize files from ownCloud Server with your
+computer. It uses OCSync as its syncing backend.
WWW: https://github.com/owncloud/mirall
diff --git a/deskutils/mirall/pkg-plist b/deskutils/mirall/pkg-plist
index c51b41bd2df1..d9b793363686 100644
--- a/deskutils/mirall/pkg-plist
+++ b/deskutils/mirall/pkg-plist
@@ -1,22 +1,27 @@
bin/owncloud
bin/owncloudcmd
@sample etc/ownCloud/sync-exclude.lst.sample
+include/httpbf.h
include/owncloudsync/creds/abstractcredentials.h
include/owncloudsync/creds/httpcredentials.h
include/owncloudsync/mirall/account.h
-include/owncloudsync/mirall/csyncthread.h
include/owncloudsync/mirall/folder.h
include/owncloudsync/mirall/folderman.h
include/owncloudsync/mirall/folderwatcher.h
include/owncloudsync/mirall/mirallconfigfile.h
include/owncloudsync/mirall/networkjobs.h
include/owncloudsync/mirall/progressdispatcher.h
+include/owncloudsync/mirall/syncengine.h
include/owncloudsync/mirall/syncfileitem.h
include/owncloudsync/mirall/syncjournaldb.h
include/owncloudsync/mirall/syncresult.h
+lib/libhttpbf.a
lib/libowncloudsync.so
lib/libowncloudsync.so.0
-lib/libowncloudsync.so.%%VERSION%%
+lib/libowncloudsync.so.1.6.0
+lib/owncloud/libocsync.so
+lib/owncloud/libocsync.so.0
+lib/owncloud/libocsync.so.0.2.1
share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/.buildinfo
%%PORTDOCS%%%%DOCSDIR%%/html/_images/folderwizard_local.png
@@ -38,12 +43,14 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/autoupdate.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/building.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/conffile.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/_sources/faq.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/glossary.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/index.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/introduction.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/options.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/owncloud.1.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/owncloudcmd.1.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/_sources/owncloudcmd.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/troubleshooting.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_sources/visualtour.txt
%%PORTDOCS%%%%DOCSDIR%%/html/_static/ajax-loader.gif
@@ -72,6 +79,7 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/autoupdate.html
%%PORTDOCS%%%%DOCSDIR%%/html/building.html
%%PORTDOCS%%%%DOCSDIR%%/html/conffile.html
+%%PORTDOCS%%%%DOCSDIR%%/html/faq.html
%%PORTDOCS%%%%DOCSDIR%%/html/genindex.html
%%PORTDOCS%%%%DOCSDIR%%/html/glossary.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
@@ -80,10 +88,112 @@ share/applications/owncloud.desktop
%%PORTDOCS%%%%DOCSDIR%%/html/options.html
%%PORTDOCS%%%%DOCSDIR%%/html/owncloud.1.html
%%PORTDOCS%%%%DOCSDIR%%/html/owncloudcmd.1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/owncloudcmd.html
%%PORTDOCS%%%%DOCSDIR%%/html/search.html
%%PORTDOCS%%%%DOCSDIR%%/html/searchindex.js
%%PORTDOCS%%%%DOCSDIR%%/html/troubleshooting.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/.buildinfo
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/folderwizard_local.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/folderwizard_remote.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/icon.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/ignored_files_editor.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/menu.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_account.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_activity.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_general.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/settings_network.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard_overview.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard_targetfolder.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard_url.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/wizard_user.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/accountsetup.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/advancedusage.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/architecture.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/autoupdate.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/building.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/conffile.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/faq.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/glossary.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/introduction.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/options.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/owncloud.1.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/owncloudcmd.1.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/owncloudcmd.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/troubleshooting.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_sources/visualtour.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/ajax-loader.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/comment-bright.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/comment-close.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/comment.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/default.css
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/doctools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/down-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/down.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/file.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/minus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/plus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/pygments.css
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/sidebar.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/underscore.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/up-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/up.png
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_static/websupport.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/accountsetup.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/advancedusage.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/architecture.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/autoupdate.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/building.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/conffile.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/genindex.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/options.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/owncloud.1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/owncloudcmd.1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/owncloudcmd.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/search.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/searchindex.js
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/troubleshooting.html
+%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/visualtour.html
%%PORTDOCS%%%%DOCSDIR%%/html/visualtour.html
+%%PORTDOCS%%%%DOCSDIR%%/latex/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/latex/fncychap.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/folderwizard_local.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/folderwizard_remote.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/icon.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/ignored_files_editor.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/logo-blue.pdf
+%%PORTDOCS%%%%DOCSDIR%%/latex/menu.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.aux
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.idx
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.ilg
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.ind
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.log
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.out
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.tex
+%%PORTDOCS%%%%DOCSDIR%%/latex/ownCloudClientManual.toc
+%%PORTDOCS%%%%DOCSDIR%%/latex/python.ist
+%%PORTDOCS%%%%DOCSDIR%%/latex/settings_account.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/settings_activity.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/settings_general.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/settings_network.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinx.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxhowto.cls
+%%PORTDOCS%%%%DOCSDIR%%/latex/sphinxmanual.cls
+%%PORTDOCS%%%%DOCSDIR%%/latex/tabulary.sty
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard_overview.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard_targetfolder.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard_url.png
+%%PORTDOCS%%%%DOCSDIR%%/latex/wizard_user.png
+%%PORTDOCS%%%%DOCSDIR%%/logo-blue.pdf
%%PORTDOCS%%%%DOCSDIR%%/ownCloudClientManual.pdf
share/icons/hicolor/128x128/apps/owncloud.png
share/icons/hicolor/22x22/apps/owncloud.png
@@ -116,28 +226,23 @@ share/owncloud/i18n/mirall_sk.qm
share/owncloud/i18n/mirall_sl.qm
share/owncloud/i18n/mirall_sv.qm
share/owncloud/i18n/mirall_th.qm
+share/owncloud/i18n/mirall_tr.qm
share/owncloud/i18n/mirall_uk.qm
share/owncloud/i18n/mirall_zh_CN.qm
share/owncloud/i18n/mirall_zh_TW.qm
@dirrm share/owncloud/i18n
@dirrm share/owncloud
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/22x22/apps
-@dirrmtry share/icons/hicolor/22x22
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/latex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/unthemed/_static
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/unthemed/_sources
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/unthemed/_images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/unthemed
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/_static
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/_sources
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/_images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry lib/owncloud
@dirrmtry include/owncloudsync/mirall
@dirrmtry include/owncloudsync/creds
@dirrmtry include/owncloudsync