aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/p5-Text-Kakasi/Makefile1
-rw-r--r--japanese/p5-Text-Kakasi/files/patch-Kakasi.xs11
2 files changed, 12 insertions, 0 deletions
diff --git a/japanese/p5-Text-Kakasi/Makefile b/japanese/p5-Text-Kakasi/Makefile
index 3c6baed601cf..7682d199835a 100644
--- a/japanese/p5-Text-Kakasi/Makefile
+++ b/japanese/p5-Text-Kakasi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Text-Kakasi
PORTVERSION= 1.05
+PORTREVISION= 1
CATEGORIES= japanese perl5
MASTER_SITES= http://www.daionet.gr.jp/~knok/kakasi/
diff --git a/japanese/p5-Text-Kakasi/files/patch-Kakasi.xs b/japanese/p5-Text-Kakasi/files/patch-Kakasi.xs
new file mode 100644
index 000000000000..b4299f41d93c
--- /dev/null
+++ b/japanese/p5-Text-Kakasi/files/patch-Kakasi.xs
@@ -0,0 +1,11 @@
+--- Kakasi.xs.orig Wed Apr 11 16:58:38 2001
++++ Kakasi.xs Sat Oct 5 20:20:42 2002
+@@ -110,7 +110,7 @@
+ tmp ++;
+ cur ++;
+ }
+- free(rtmp);
++ if (*rtmp) free(rtmp);
+ } while (cur < slen);
+ if (ret != NULL) {
+ RETVAL = newSVpv(ret, rcur - 1);