aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-fonts/fontconfig/Makefile4
-rw-r--r--x11-fonts/fontconfig/files/patch-fc-cache_meson.build10
-rw-r--r--x11-fonts/fontconfig/files/patch-meson__options.txt8
3 files changed, 21 insertions, 1 deletions
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
index 9241ea59b6e0..8977dc2dabd8 100644
--- a/x11-fonts/fontconfig/Makefile
+++ b/x11-fonts/fontconfig/Makefile
@@ -26,6 +26,8 @@ SHEBANG_FILES= conf.d/link_confs.py \
fc-lang/fc-lang.py
TEST_TARGET= test
+SUB_FILES= pkg-install
+SUB_LIST= PREFIX=${PREFIX}
# Custom configuration variables
FCDEFAULTFONTS= ${PREFIX}/share/fonts
@@ -33,7 +35,7 @@ FCADDFONTS= ${LOCALBASE}/lib/X11/fonts
# To avoid circular dependency rebuild of docs (including manpages) needs to be
# disabled as they depend on textproc/docbook-utils which requires fontconfig
-MESON_ARGS= -Ddefault_library=both -Ddoc=disabled
+MESON_ARGS= -Ddefault_library=both -Ddoc=disabled -Dfc-cache=disabled
PLIST_SUB= PREFERRED_HINTING=${PREFERRED_HINTING}
PORTDOCS= fontconfig-user.html fontconfig-user.pdf fontconfig-user.txt
diff --git a/x11-fonts/fontconfig/files/patch-fc-cache_meson.build b/x11-fonts/fontconfig/files/patch-fc-cache_meson.build
new file mode 100644
index 000000000000..cdb981f4abee
--- /dev/null
+++ b/x11-fonts/fontconfig/files/patch-fc-cache_meson.build
@@ -0,0 +1,10 @@
+--- fc-cache/meson.build.orig 2021-01-28 11:53:32 UTC
++++ fc-cache/meson.build
+@@ -8,6 +8,6 @@ fccache = executable('fc-cache', ['fc-cache.c', fcstdi
+ tools_man_pages += ['fc-cache']
+
+ # Do not try to execute target's fc-cache on host when cross compiling
+-if not meson.is_cross_build()
++if get_option('fc-cache').enabled() and not meson.is_cross_build()
+ meson.add_install_script(fccache, '-s', '-f', '-v')
+ endif
diff --git a/x11-fonts/fontconfig/files/patch-meson__options.txt b/x11-fonts/fontconfig/files/patch-meson__options.txt
new file mode 100644
index 000000000000..50bafa0c91ff
--- /dev/null
+++ b/x11-fonts/fontconfig/files/patch-meson__options.txt
@@ -0,0 +1,8 @@
+--- meson_options.txt.orig 2020-12-03 11:45:00 UTC
++++ meson_options.txt
+@@ -11,3 +11,5 @@ option('tests', type : 'feature', value : 'auto', yiel
+ description: 'Enable unit tests')
+ option('tools', type : 'feature', value : 'auto', yield : true,
+ description: 'Build command-line tools (fc-list, fc-query, etc.)')
++option('fc-cache', type: 'feature', value : 'enabled',
++ description : 'Run fc-cache on install')