aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/lsof/Makefile1
-rw-r--r--sysutils/lsof/files/patch-proc.c19
2 files changed, 20 insertions, 0 deletions
diff --git a/sysutils/lsof/Makefile b/sysutils/lsof/Makefile
index 1b65be0b11ed..cc373f29607f 100644
--- a/sysutils/lsof/Makefile
+++ b/sysutils/lsof/Makefile
@@ -8,6 +8,7 @@
PORTNAME= lsof
PORTVERSION= 4.81
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= sysutils
MASTER_SITES= http://ftp.cerias.purdue.edu/pub/tools/unix/sysutils/lsof/ \
diff --git a/sysutils/lsof/files/patch-proc.c b/sysutils/lsof/files/patch-proc.c
new file mode 100644
index 000000000000..998a446f6c5c
--- /dev/null
+++ b/sysutils/lsof/files/patch-proc.c
@@ -0,0 +1,19 @@
+*** /tmp/T0fSaqTh Sun Nov 2 07:48:14 2008
+--- proc.c Sun Nov 2 07:44:24 2008
+***************
+*** 841,847 ****
+ {
+ if (Lf->sf & SELEXCLF)
+ return;
+! if (((Selflags & SELNET) == SELNET) && !(Lf->sf & SELNET))
+ return;
+ Lp->pss |= PS_SEC;
+ if (Plf)
+--- 841,847 ----
+ {
+ if (Lf->sf & SELEXCLF)
+ return;
+! if ((Selflags == SELNET) && !(Lf->sf & SELNET))
+ return;
+ Lp->pss |= PS_SEC;
+ if (Plf)