aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-Structure_LinkedList/Makefile19
-rw-r--r--devel/pear-Structure_LinkedList/distinfo2
-rw-r--r--devel/pear-Structure_LinkedList/pkg-descr5
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bed2ca2f5d02..dffd1cd2cda2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2908,6 +2908,7 @@
SUBDIR += pear-PHP_UML
SUBDIR += pear-Pager
SUBDIR += pear-PhpDocumentor
+ SUBDIR += pear-Structure_LinkedList
SUBDIR += pear-Structures_DataGrid
SUBDIR += pear-Structures_DataGrid_Renderer_Console
SUBDIR += pear-Structures_DataGrid_Renderer_HTMLSortForm
diff --git a/devel/pear-Structure_LinkedList/Makefile b/devel/pear-Structure_LinkedList/Makefile
new file mode 100644
index 000000000000..f8ae4fed70b3
--- /dev/null
+++ b/devel/pear-Structure_LinkedList/Makefile
@@ -0,0 +1,19 @@
+# Ports collection makefile for: pear-Structures_LinkedList
+# Date created: 26 April 2012
+# Whom: Muhammad Moinur Rahman <5u623l20@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Structures_LinkedList
+PORTVERSION= 0.2.2
+CATEGORIES= devel pear
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Implements singly and doubly-linked lists
+
+PEAR_AUTOINSTALL= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Structure_LinkedList/distinfo b/devel/pear-Structure_LinkedList/distinfo
new file mode 100644
index 000000000000..6e45644a449c
--- /dev/null
+++ b/devel/pear-Structure_LinkedList/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/Structures_LinkedList-0.2.2.tgz) = 26e16610444ff6d09f847e68b0e38c522ff96eb64a4b2f07c91742a213ade692
+SIZE (PEAR/Structures_LinkedList-0.2.2.tgz) = 12486
diff --git a/devel/pear-Structure_LinkedList/pkg-descr b/devel/pear-Structure_LinkedList/pkg-descr
new file mode 100644
index 000000000000..2185ce6a41e4
--- /dev/null
+++ b/devel/pear-Structure_LinkedList/pkg-descr
@@ -0,0 +1,5 @@
+A singly-linked list offers the ability to insert or delete
+nodes at any point within the list. A doubly-linked list also offers the
+ability to request previous nodes in the list.
+
+WWW: http://pear.php.net/package/Structures_LinkedList/