aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Sequence/Makefile31
-rw-r--r--math/p5-Math-Sequence/distinfo3
-rw-r--r--math/p5-Math-Sequence/pkg-descr26
-rw-r--r--math/p5-Math-Sequence/pkg-plist5
5 files changed, 66 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index f2c53539c19c..e2be70aa9ef5 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -187,6 +187,7 @@
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-MT
SUBDIR += p5-Math-Round
+ SUBDIR += p5-Math-Sequence
SUBDIR += p5-Math-SimpleVariable
SUBDIR += p5-Math-Spline
SUBDIR += p5-Math-Symbolic
diff --git a/math/p5-Math-Sequence/Makefile b/math/p5-Math-Sequence/Makefile
new file mode 100644
index 000000000000..ea71f5028d67
--- /dev/null
+++ b/math/p5-Math-Sequence/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Math-Sequence
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Sequence
+PORTVERSION= 1.00
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension dealing with mathematic sequences
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Sequence.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Sequence/distinfo b/math/p5-Math-Sequence/distinfo
new file mode 100644
index 000000000000..79d72487cf98
--- /dev/null
+++ b/math/p5-Math-Sequence/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Sequence-1.00.tar.gz) = 48d460ccfca4bc52a60ce6c170e0261d
+SHA256 (Math-Sequence-1.00.tar.gz) = d5bd0501f4f2ea6d19d77f9e32109414f28fee5fd9ee5c7968c48138b15631af
+SIZE (Math-Sequence-1.00.tar.gz) = 4914
diff --git a/math/p5-Math-Sequence/pkg-descr b/math/p5-Math-Sequence/pkg-descr
new file mode 100644
index 000000000000..1a291e934590
--- /dev/null
+++ b/math/p5-Math-Sequence/pkg-descr
@@ -0,0 +1,26 @@
+Math::Sequence defines a class for simple mathematic sequences with a
+recursive definition such as x_(n+1) = 1 / (x_n + 1). Creation of a
+Math::Sequence object is described below in the paragraph about the
+constructor.
+
+Math::Sequence uses Math::Symbolic to parse and modify the recursive
+sequence definitions. That means you specify the sequence as a string
+which is parsed by Math::Symbolic. Alternatively, you can pass the
+constructor a Math::Symbolic tree directly.
+
+Because Math::Sequence uses Math::Symbolic for its implementation, all
+results will be Math::Symbolic objects which may contain other variables
+than the sequence variable itself.
+
+Each Math::Sequence object is an iterator to iterate over the elements of
+the sequence starting at the first element (which was specified by the
+starting element, the second argument to the new() constructor). It offers
+facilities to cache all calculated elements and access any element
+directly, though unless the element has been cached in a previous
+calculation, this is just a shortcut for repeated use of the iterator.
+
+Every element in the sequence may only access its predecessor, not the
+elements before that.
+
+WWW: http://search.cpan.org/dist/Math-Sequence
+Author: Steffen Mueller <sequence-module@steffen-mueller.net>
diff --git a/math/p5-Math-Sequence/pkg-plist b/math/p5-Math-Sequence/pkg-plist
new file mode 100644
index 000000000000..0e0b3780cc68
--- /dev/null
+++ b/math/p5-Math-Sequence/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/Sequence.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Sequence/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Sequence
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math