aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-visvis/19
-rw-r--r--graphics/py-visvis/211
-rw-r--r--graphics/py-visvis/Makefile30
-rw-r--r--graphics/py-visvis/distinfo3
-rw-r--r--graphics/py-visvis/pkg-descr13
6 files changed, 67 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 6ab0fecf6f1d..34bf61237842 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -882,6 +882,7 @@
SUBDIR += py-termtosvg
SUBDIR += py-toyplot
SUBDIR += py-traitsui
+ SUBDIR += py-visvis
SUBDIR += py-wand
SUBDIR += py-webcolors
SUBDIR += py-willow
diff --git a/graphics/py-visvis/1 b/graphics/py-visvis/1
new file mode 100644
index 000000000000..57277d6c7ea3
--- /dev/null
+++ b/graphics/py-visvis/1
@@ -0,0 +1,9 @@
+/usr/ports/x11-toolkits/fltk
+/usr/ports/graphics/mesa-libs
+/usr/ports/x11-toolkits/wxgtk30
+/usr/ports/graphics/py-imageio
+/usr/ports/math/py-numpy
+/usr/ports/graphics/py-PyOpenGL
+/usr/ports/devel/pyside2
+/usr/ports/devel/py-setuptools
+/usr/ports/lang/python37
diff --git a/graphics/py-visvis/2 b/graphics/py-visvis/2
new file mode 100644
index 000000000000..79d44aa1d0a9
--- /dev/null
+++ b/graphics/py-visvis/2
@@ -0,0 +1,11 @@
+/usr/ports/x11-toolkits/fltk
+/usr/ports/graphics/mesa-libs
+/usr/ports/x11-toolkits/wxgtk30
+/usr/ports/graphics/py-imageio
+/usr/ports/math/py-numpy
+/usr/ports/graphics/py-PyOpenGL
+/usr/ports/devel/pyside2
+/usr/ports/devel/py-setuptools
+/usr/ports/lang/python37
+/usr/ports/devel/py-qt5-core
+/usr/ports/x11-toolkits/py-qt5-gui
diff --git a/graphics/py-visvis/Makefile b/graphics/py-visvis/Makefile
new file mode 100644
index 000000000000..2229bd9eb510
--- /dev/null
+++ b/graphics/py-visvis/Makefile
@@ -0,0 +1,30 @@
+# Created by: Rainer Hurling <rhurlin@gwdg.de>
+# $FreeBSD$
+
+PORTNAME= visvis
+PORTVERSION= 1.12.2
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rhurlin@gwdg.de
+COMMENT= Object oriented approach to visualization of 1D to 4D data
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}imageio>=0:graphics/py-imageio@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyside2>=0:devel/pyside2@${PY_FLAVOR}
+LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
+
+USES= gl python pyqt:5
+USE_GL= gl
+USE_PYQT= core gui
+USE_PYTHON= autoplist distutils
+USE_WX= 3.0+
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-visvis/distinfo b/graphics/py-visvis/distinfo
new file mode 100644
index 000000000000..b0a28e19087b
--- /dev/null
+++ b/graphics/py-visvis/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1572088205
+SHA256 (visvis-1.12.2.tar.gz) = ccfc5fc81223080f1d344617816d8a1acae462a80fb753e54ae2cdcb0af14705
+SIZE (visvis-1.12.2.tar.gz) = 4811730
diff --git a/graphics/py-visvis/pkg-descr b/graphics/py-visvis/pkg-descr
new file mode 100644
index 000000000000..6de253b9bfb4
--- /dev/null
+++ b/graphics/py-visvis/pkg-descr
@@ -0,0 +1,13 @@
+Visvis is a pure Python library for visualization of 1D to 4D data in an bject
+oriented way. Essentially, visvis is an object oriented layer of Python on top
+of OpenGl, thereby combining the power of OpenGl with the usability of Python. A
+Matlab-like interface in the form of a set of functions allows easy creation of
+objects (e.g. plot(), imshow(), volshow(), surf()).
+
+With visvis a range of different data can be visualized by simply adding world
+objects to a scene (or axes). These world objects can be anything from plots
+(lines with markers), to images, 3D rendered volumes, shaded meshes, or you can
+program your own world object class. If required, these data can also be moved
+in time.
+
+WWW: https://github.com/almarklein/visvis