aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/cl-md5-clisp/Makefile24
-rw-r--r--security/cl-md5-clisp/pkg-descr5
-rw-r--r--security/cl-md5-clisp/pkg-plist0
4 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 10f32bffc4ba..d80fa5815285 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -65,6 +65,7 @@
SUBDIR += chrootuid
SUBDIR += cksfv
SUBDIR += cl-md5
+ SUBDIR += cl-md5-clisp
SUBDIR += cl-md5-sbcl
SUBDIR += clamassassin
SUBDIR += clamav
diff --git a/security/cl-md5-clisp/Makefile b/security/cl-md5-clisp/Makefile
new file mode 100644
index 000000000000..115c04779230
--- /dev/null
+++ b/security/cl-md5-clisp/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: cl-md5-clisp
+# Date created: 16 January 2010
+# Whom: Giacomo Olgeni
+#
+# $FreeBSD$
+
+PORTNAME= md5
+PORTVERSION= 1.8.5
+CATEGORIES= security lisp
+PKGNAMEPREFIX= cl-
+DISTFILES= # none
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= A native MD5 implementation in Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/md5/md5.asd:${PORTSDIR}/security/cl-md5
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/md5/md5.asd:${PORTSDIR}/security/cl-md5
+
+USE_ASDF_FASL= yes
+FASL_TARGET= clisp
+FASL_BUILD= yes
+
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
+.include <bsd.port.mk>
diff --git a/security/cl-md5-clisp/pkg-descr b/security/cl-md5-clisp/pkg-descr
new file mode 100644
index 000000000000..72fe87a4f41f
--- /dev/null
+++ b/security/cl-md5-clisp/pkg-descr
@@ -0,0 +1,5 @@
+A native MD5 implementation in Common Lisp.
+
+This package is compiled with CLISP.
+
+WWW: http://www.cliki.net/MD5
diff --git a/security/cl-md5-clisp/pkg-plist b/security/cl-md5-clisp/pkg-plist
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/security/cl-md5-clisp/pkg-plist