aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jgoodies-common/Makefile60
-rw-r--r--devel/jgoodies-common/distinfo2
-rw-r--r--devel/jgoodies-common/pkg-descr6
4 files changed, 69 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c64054abf572..c1948a4b4cd9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -331,6 +331,7 @@
SUBDIR += devtodo
SUBDIR += dfuife-curses
SUBDIR += jech-dht
+ SUBDIR += jgoodies-common
SUBDIR += dia2code
SUBDIR += diffuse
SUBDIR += ding-libs
diff --git a/devel/jgoodies-common/Makefile b/devel/jgoodies-common/Makefile
new file mode 100644
index 000000000000..fe53fd509c9f
--- /dev/null
+++ b/devel/jgoodies-common/Makefile
@@ -0,0 +1,60 @@
+# Created by: Mikhail Teterin <mi@aldan.algebra.com>
+# $FreeBSD$
+
+PORTNAME= jgoodies-common
+PORTVERSION= 1.2.1
+CATEGORIES= devel java
+MASTER_SITES= http://www.jgoodies.com/download/libraries/common/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S|.|_|g}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Abstract and helper classes used by all other JGoodies libs
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+USE_ANT= yes
+MAKE_ARGS+= -Djunit4.jar=${LOCALBASE}/share/java/classes/junit.jar
+ALL_TARGET= jar test
+EXTRACT_AFTER_ARGS=-d ${WRKDIR} -x '*/api/*' '*.jar'
+USE_DOS2UNIX= yes
+REINPLACE_ARGS= -i ""
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+JARFILE= ${PORTNAME}.jar
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= javadoc
+PORTDOCS= *
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} 's|haltonfailure="no"|haltonfailure="yes"|' \
+ ${WRKSRC}/build.xml
+ ${FIND} ${WRKSRC} -type f -not -name '*.gif' | ${XARGS} \
+ ${REINPLACE_CMD} -E 's|[[:blank:]]+$$||'
+.if defined(NO_LICENSES_INSTALL) || defined(DISABLE_LICENSES)
+ ${REINPLACE_CMD} -E 's|<a .[^>]+>License</a>|<abbr title="BSD 3-clause. License-file installation disabled">License</abbr>|'\
+ ${WRKSRC}/README.html
+.else
+ ${REINPLACE_CMD} -E 's|href="LICENSE.txt"|href="../../../${_LICENSE_DIR_REL}/BSD"|' \
+ ${WRKSRC}/README.html
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/build/${JARFILE} ${JAVAJARDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/README.html ${WRKSRC}/RELEASE-NOTES.txt ${WRKSRC}/docs ${DOCSDIR}/
+ @${CP} -R ${WRKSRC}/build/docs/api ${DOCSDIR}/docs
+ # Documentation, including javadoc-generated, was installed in ${DOCSDIR}.
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/jgoodies-common/distinfo b/devel/jgoodies-common/distinfo
new file mode 100644
index 000000000000..140df8114ec4
--- /dev/null
+++ b/devel/jgoodies-common/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jgoodies-common-1_2_1.zip) = 0fe2ede31e70a633c2a157b99594701e4206c4207f7a3f6e97b15121cac32dfb
+SIZE (jgoodies-common-1_2_1.zip) = 271803
diff --git a/devel/jgoodies-common/pkg-descr b/devel/jgoodies-common/pkg-descr
new file mode 100644
index 000000000000..7f5249435640
--- /dev/null
+++ b/devel/jgoodies-common/pkg-descr
@@ -0,0 +1,6 @@
+The JGoodies is a collection of Java GUI packages.
+
+The jgoodies-common port installs the abstract and helper classes
+used by all of them.
+
+WWW: http://www.jgoodies.com/