aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/mrtg/Makefile11
-rw-r--r--net/mrtg/Makefile11
2 files changed, 16 insertions, 6 deletions
diff --git a/net-mgmt/mrtg/Makefile b/net-mgmt/mrtg/Makefile
index 219f5eb6d771..c1c2bedd556b 100644
--- a/net-mgmt/mrtg/Makefile
+++ b/net-mgmt/mrtg/Makefile
@@ -15,16 +15,21 @@ MASTER_SITE_SUBDIR= net/mrtg
MAINTAINER= demon@FreeBSD.org
+.if defined(WITH_GD2)
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
+CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
+ --with-gd-inc=${LOCALBASE}/include
+.else
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
+ --with-gd-inc=${LOCALBASE}/include/gd
+.endif
USE_PERL5= YES
MAKE_ENV+= PERL=${PERL}
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
- --with-gd-inc=${LOCALBASE}/include/gd
-
CONFIGURE_ENV= PERL=${PERL}
MAN1= cfgmaker.1 contrib.1 faq.1 forum.1 indexmaker.1 logfile.1 \
diff --git a/net/mrtg/Makefile b/net/mrtg/Makefile
index 219f5eb6d771..c1c2bedd556b 100644
--- a/net/mrtg/Makefile
+++ b/net/mrtg/Makefile
@@ -15,16 +15,21 @@ MASTER_SITE_SUBDIR= net/mrtg
MAINTAINER= demon@FreeBSD.org
+.if defined(WITH_GD2)
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
+CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
+ --with-gd-inc=${LOCALBASE}/include
+.else
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
+ --with-gd-inc=${LOCALBASE}/include/gd
+.endif
USE_PERL5= YES
MAKE_ENV+= PERL=${PERL}
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
- --with-gd-inc=${LOCALBASE}/include/gd
-
CONFIGURE_ENV= PERL=${PERL}
MAN1= cfgmaker.1 contrib.1 faq.1 forum.1 indexmaker.1 logfile.1 \