aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/scim-table-imengine/Makefile28
-rw-r--r--textproc/scim-table-imengine/distinfo4
-rw-r--r--textproc/scim-table-imengine/files/patch-Makefile.in21
-rw-r--r--textproc/scim-table-imengine/files/patch-icons-Makefile.in12
-rw-r--r--textproc/scim-table-imengine/pkg-plist19
5 files changed, 69 insertions, 15 deletions
diff --git a/textproc/scim-table-imengine/Makefile b/textproc/scim-table-imengine/Makefile
index 050135f5c3c4..c97563b853f7 100644
--- a/textproc/scim-table-imengine/Makefile
+++ b/textproc/scim-table-imengine/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scim-table-imengine
-PORTVERSION= 0.5.1
-PORTREVISION= 4
+PORTVERSION= 0.5.2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=scim
@@ -16,8 +15,8 @@ DISTNAME= scim-tables-${PORTVERSION}
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= SCIM table based input method engine
-BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
+RUN_DEPENDS= ${BUILD_DEPENDS}
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -34,6 +33,27 @@ EXTRA_PATCHES= ${FILESDIR}/extrapatch-4-stable-src-Makefile.in
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
+PLIST_SUB= SKIM="@comment "
+
+pre-fetch:
+ @${ECHO_MSG} Define WITH_SKIM to enable skim support
+
+.if exists(${LOCALBASE}/bin/skim)
+WITH_SKIM= yes
+pre-patch:
+ @${ECHO_MSG} Skim is detected, support enabled.
+.endif
+
+.if defined(WITH_SKIM)
+BUILD_DEPENDS+= skim:${PORTSDIR}/textproc/skim
+CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+PLIST_SUB= SKIM=""
+post-patch:
+ @${REINPLACE_CMD} -e "/^DIST_SUBDIRS/s/$$/ skim/" \
+ -e "/^@SCIM_TABLES_ENABLE_SKIM_SUPPORT_TRUE@SKIM_SUBDIR =/s/$$/ skim/" \
+ ${WRKSRC}/Makefile.in
+.endif
+
post-install:
.if ${OSVERSION} < 500035
@${INSTALL_SCRIPT} ${FILESDIR}/scim-make-table.sh ${PREFIX}/bin/scim-make-table
diff --git a/textproc/scim-table-imengine/distinfo b/textproc/scim-table-imengine/distinfo
index 66a76343b203..99ef99620bb8 100644
--- a/textproc/scim-table-imengine/distinfo
+++ b/textproc/scim-table-imengine/distinfo
@@ -1,2 +1,2 @@
-MD5 (scim-tables-0.5.1.tar.gz) = 3249d0fbdb731c2003bea093dc43f19c
-SIZE (scim-tables-0.5.1.tar.gz) = 4718906
+MD5 (scim-tables-0.5.2.tar.gz) = 04749a3341bd37af20820497f1d68f7a
+SIZE (scim-tables-0.5.2.tar.gz) = 5539476
diff --git a/textproc/scim-table-imengine/files/patch-Makefile.in b/textproc/scim-table-imengine/files/patch-Makefile.in
index 0d046e780093..0bdf44860957 100644
--- a/textproc/scim-table-imengine/files/patch-Makefile.in
+++ b/textproc/scim-table-imengine/files/patch-Makefile.in
@@ -1,11 +1,22 @@
---- Makefile.in.orig Tue Mar 1 14:02:56 2005
-+++ Makefile.in Tue Mar 1 14:03:08 2005
-@@ -247,7 +247,7 @@
+--- Makefile.in.orig Sun Aug 7 21:42:34 2005
++++ Makefile.in Thu Oct 20 22:13:30 2005
+@@ -75,7 +75,7 @@
+ uninstall-recursive
+ ETAGS = etags
+ CTAGS = ctags
+-DIST_SUBDIRS = intl m4 src zh ja ko ne additional icons po skim
++DIST_SUBDIRS = intl m4 src icons po skim
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ distdir = $(PACKAGE)-$(VERSION)
+ top_distdir = $(distdir)
+@@ -258,8 +258,8 @@
EXTRA_DIST = config.rpath mkinstalldirs bootstrap scim-tables.spec
AUTOMAKE_OPTIONS = gnu
--SUBDIRS = intl m4 src zh ja ko additional icons po
-+SUBDIRS = intl m4 src icons po
+-@SCIM_TABLES_ENABLE_SKIM_SUPPORT_TRUE@SKIM_SUBDIR = skim
+-SUBDIRS = intl m4 src zh ja ko ne additional icons po $(SKIM_SUBDIR)
++@SCIM_TABLES_ENABLE_SKIM_SUPPORT_TRUE@SKIM_SUBDIR =
++SUBDIRS = intl m4 src icons po $(SKIM_SUBDIR)
MAINTAINERCLEANFILES = Makefile.in aclocal.m4 configure $(AUX_DIST)
CLEANFILES = *.bak
ACLOCAL_AMFLAGS = -I m4
diff --git a/textproc/scim-table-imengine/files/patch-icons-Makefile.in b/textproc/scim-table-imengine/files/patch-icons-Makefile.in
index 567be752d4f5..24aa89aa75a4 100644
--- a/textproc/scim-table-imengine/files/patch-icons-Makefile.in
+++ b/textproc/scim-table-imengine/files/patch-icons-Makefile.in
@@ -1,6 +1,6 @@
---- icons/Makefile.in.orig Tue Mar 1 14:02:22 2005
-+++ icons/Makefile.in Tue Mar 1 14:02:45 2005
-@@ -222,33 +222,7 @@
+--- icons/Makefile.in.orig Sun Aug 7 21:42:32 2005
++++ icons/Makefile.in Thu Oct 20 21:11:30 2005
+@@ -233,37 +233,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
MAINTAINERCLEANFILES = Makefile.in
@@ -23,13 +23,17 @@
- HIRAGANA.png \
- Jyutping.png \
- KATAKANA.png \
+- LaTeX.png \
+- Nepali.png \
- Nippon.png \
- Simplex.png \
- Viqr.png \
+- Wu.png \
- Wubi.png \
- Yawerty.png \
- ZhuYin.png \
-- Ziranma.png
+- Ziranma.png \
+- IPA-X-SAMPA.png
-
+INST_ICONS = table.png
EXTRA_DIST = $(INST_ICONS)
diff --git a/textproc/scim-table-imengine/pkg-plist b/textproc/scim-table-imengine/pkg-plist
index 6f9021b29aba..bdfb7463866d 100644
--- a/textproc/scim-table-imengine/pkg-plist
+++ b/textproc/scim-table-imengine/pkg-plist
@@ -8,5 +8,24 @@ share/locale/ja/LC_MESSAGES/scim-tables.mo
share/locale/ko/LC_MESSAGES/scim-tables.mo
share/locale/de/LC_MESSAGES/scim-tables.mo
share/locale/fr/LC_MESSAGES/scim-tables.mo
+share/locale/it/LC_MESSAGES/scim-tables.mo
+%%SKIM%%@cwd %%LOCALBASE%%
+%%SKIM%%lib/kde3/kcm_skimplugin_scim_tables.la
+%%SKIM%%lib/kde3/kcm_skimplugin_scim_tables.so
+%%SKIM%%share/services/skimconfiguredialog/skimplugin_scim_table_config.desktop
+%%SKIM%%share/config.kcfg/generictable.kcfg
+%%SKIM%%share/locale/zh_CN/LC_MESSAGES/skim-scim-tables.mo
+%%SKIM%%share/locale/zh_TW/LC_MESSAGES/skim-scim-tables.mo
+%%SKIM%%share/locale/de/LC_MESSAGES/skim-scim-tables.mo
+%%SKIM%%share/locale/fr/LC_MESSAGES/skim-scim-tables.mo
+%%SKIM%%share/locale/ja/LC_MESSAGES/skim-scim-tables.mo
+%%SKIM%%share/locale/it/LC_MESSAGES/skim-scim-tables.mo
+%%SKIM%%share/locale/ko/LC_MESSAGES/skim-scim-tables.mo
+%%SKIM%%share/apps/skim/pics/scim-tables.png
+%%SKIM%%@unexec rmdir %D/share/apps/skim/pics 2>/dev/null || true
+%%SKIM%%@unexec rmdir %D/share/apps/skim 2>/dev/null || true
+%%SKIM%%@unexec rmdir %D/share/config.kcfg 2>/dev/null || true
+%%SKIM%%@unexec rmdir %D/share/services/skimconfiguredialog 2>/dev/null || true
+%%SKIM%%@cwd %%X11BASE%%
@unexec rmdir %D/lib/scim-1.0/IMEngine 2>/dev/null || true
@unexec rmdir %D/lib/scim-1.0/SetupUI 2>/dev/null || true