aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/glpk/Makefile35
-rw-r--r--math/glpk/distinfo6
-rw-r--r--math/glpk/pkg-plist6
3 files changed, 40 insertions, 7 deletions
diff --git a/math/glpk/Makefile b/math/glpk/Makefile
index 0705112a004b..a47b02689582 100644
--- a/math/glpk/Makefile
+++ b/math/glpk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= glpk
-PORTVERSION= 4.25
+PORTVERSION= 4.28
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glpk
@@ -16,6 +16,9 @@ COMMENT= A GNU Linear Programming Kit
LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp4
+OPTIONS= IODBC "Enable MathProg iodbc support" Off \
+ MYSQL "Enable MathProg mysql support" Off
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
@@ -24,11 +27,37 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_IODBC || WITH_MYSQL)
+CONFIGURE_ARGS+= --enable-dl=dlfcn
+.else
+CONFIGURE_ARGS+= --disable-dl
+.endif
+
+.ifdef(WITH_IODBC)
+CONFIGURE_ARGS+= --enable-odbc
+LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+.else
+CONFIGURE_ARGS+= --disable-odbc
+.endif
+
+.ifdef(WITH_MYSQL)
+CONFIGURE_ARGS+= --enable-mysql
+USE_MYSQL= yes
+.else
+CONFIGURE_ARGS+= --disable-mysql
+.endif
+
.if !defined(NOPORTDOCS)
PORTDOCS= bench.txt bench1.txt glpk.ps glpk_faq.txt gmpl.ps \
- gomory.djvu opb.txt
+ gomory.djvu opb.txt tables.txt
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s;\/usr\/include\/mysql;${LOCALBASE}\/include\/mysql;g" \
+ ${WRKSRC}/configure
+
post-install:
@${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/
@@ -40,4 +69,4 @@ post-install:
done
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/glpk/distinfo b/math/glpk/distinfo
index 7e215bc27f4d..190a567c0995 100644
--- a/math/glpk/distinfo
+++ b/math/glpk/distinfo
@@ -1,3 +1,3 @@
-MD5 (glpk-4.25.tar.gz) = 3bd85385acb1123a2b62420af45bcc39
-SHA256 (glpk-4.25.tar.gz) = a178a5ac51d4f344090bd71782f229c7cf69ba86f185c494f57a61d6f2948841
-SIZE (glpk-4.25.tar.gz) = 1487597
+MD5 (glpk-4.28.tar.gz) = 6e4f30c37fb189aec6c71b27f0a57449
+SHA256 (glpk-4.28.tar.gz) = 8faeb202e58a3a9f6a6a8b0e8ae557bcc30f712060b4871a530f070c14939fd8
+SIZE (glpk-4.28.tar.gz) = 1546104
diff --git a/math/glpk/pkg-plist b/math/glpk/pkg-plist
index 2ed84592fd9e..ca413c66cb4e 100644
--- a/math/glpk/pkg-plist
+++ b/math/glpk/pkg-plist
@@ -3,6 +3,7 @@ include/glpapi.h
include/glpavl.h
include/glpbfd.h
include/glpbfx.h
+include/glpcli.h
include/glpdmp.h
include/glpfhv.h
include/glpgmp.h
@@ -20,14 +21,17 @@ include/glpmat.h
include/glpmpl.h
include/glppds.h
include/glpqmd.h
+include/glprgr.h
include/glprng.h
include/glpscf.h
include/glpscg.h
+include/glpspm.h
include/glpspx.h
+include/glpsql.h
include/glpssx.h
include/glpstd.h
include/glptsp.h
lib/libglpk.a
lib/libglpk.la
lib/libglpk.so
-lib/libglpk.so.10
+lib/libglpk.so.13