aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/mergeant/Makefile30
-rw-r--r--databases/mergeant/distinfo3
-rw-r--r--databases/mergeant/pkg-descr9
-rw-r--r--databases/mergeant/pkg-plist120
5 files changed, 163 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index eb8526e6d5c4..107ab2120c50 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -132,6 +132,7 @@
SUBDIR += maatkit
SUBDIR += mantis
SUBDIR += mdbtools
+ SUBDIR += mergeant
SUBDIR += memcached
SUBDIR += memcachedb
SUBDIR += metakit
diff --git a/databases/mergeant/Makefile b/databases/mergeant/Makefile
new file mode 100644
index 000000000000..3028bbcbd2bb
--- /dev/null
+++ b/databases/mergeant/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mergeant
+# Date created: 14 September 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/databases/mergeant/Makefile,v 1.20 2008/02/05 13:30:46 kwm Exp $
+#
+
+PORTNAME= mergeant
+PORTVERSION= 0.67
+CATEGORIES= databases gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Provide uniform access to data sources for the GNOME 2 environment
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix intlhack gnomehack libgnomedb
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+INSTALLS_OMF= yes
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/databases/mergeant/distinfo b/databases/mergeant/distinfo
new file mode 100644
index 000000000000..0535470a8d54
--- /dev/null
+++ b/databases/mergeant/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/mergeant-0.67.tar.bz2) = c0cf45891f7704b11fb00281068b2f6f
+SHA256 (gnome2/mergeant-0.67.tar.bz2) = 1673aa6336a011b37ef8daadab6f1e9d7548b2c46bc7f47446bb249fa2a3c9ca
+SIZE (gnome2/mergeant-0.67.tar.bz2) = 1016777
diff --git a/databases/mergeant/pkg-descr b/databases/mergeant/pkg-descr
new file mode 100644
index 000000000000..7e19742611d2
--- /dev/null
+++ b/databases/mergeant/pkg-descr
@@ -0,0 +1,9 @@
+mergeant can be considered as an extension of the libgda project.
+
+Its aims are the same: to provide universal data source access for
+client applications, as well as development tools and libraries
+for doing so. mergeant; is an extension to libgda; because it adds
+support to the architecture for the GNOME project. mergeant was formed
+by merging components from gnome-db and gASQL.
+
+WWW: http://www.gnome-db.org/
diff --git a/databases/mergeant/pkg-plist b/databases/mergeant/pkg-plist
new file mode 100644
index 000000000000..e82a712f0d63
--- /dev/null
+++ b/databases/mergeant/pkg-plist
@@ -0,0 +1,120 @@
+bin/mergeant
+libdata/bonobo/servers/GNOME_Mergeant.server
+share/applications/mergeant.desktop
+share/gnome/help/mergeant/C/topic.dat
+share/icons/hicolor/48x48/mimetypes/application-x-mergeant.png
+share/locale/am/LC_MESSAGES/mergeant.mo
+share/locale/ar/LC_MESSAGES/mergeant.mo
+share/locale/az/LC_MESSAGES/mergeant.mo
+share/locale/ca/LC_MESSAGES/mergeant.mo
+share/locale/cs/LC_MESSAGES/mergeant.mo
+share/locale/da/LC_MESSAGES/mergeant.mo
+share/locale/de/LC_MESSAGES/mergeant.mo
+share/locale/dz/LC_MESSAGES/mergeant.mo
+share/locale/el/LC_MESSAGES/mergeant.mo
+share/locale/en_CA/LC_MESSAGES/mergeant.mo
+share/locale/en_GB/LC_MESSAGES/mergeant.mo
+share/locale/es/LC_MESSAGES/mergeant.mo
+share/locale/eu/LC_MESSAGES/mergeant.mo
+share/locale/fa/LC_MESSAGES/mergeant.mo
+share/locale/fi/LC_MESSAGES/mergeant.mo
+share/locale/fr/LC_MESSAGES/mergeant.mo
+share/locale/gl/LC_MESSAGES/mergeant.mo
+share/locale/hr/LC_MESSAGES/mergeant.mo
+share/locale/it/LC_MESSAGES/mergeant.mo
+share/locale/ja/LC_MESSAGES/mergeant.mo
+share/locale/lt/LC_MESSAGES/mergeant.mo
+share/locale/lv/LC_MESSAGES/mergeant.mo
+share/locale/ml/LC_MESSAGES/mergeant.mo
+share/locale/ms/LC_MESSAGES/mergeant.mo
+share/locale/nb/LC_MESSAGES/mergeant.mo
+share/locale/ne/LC_MESSAGES/mergeant.mo
+share/locale/nl/LC_MESSAGES/mergeant.mo
+share/locale/oc/LC_MESSAGES/mergeant.mo
+share/locale/pl/LC_MESSAGES/mergeant.mo
+share/locale/pt/LC_MESSAGES/mergeant.mo
+share/locale/pt_BR/LC_MESSAGES/mergeant.mo
+share/locale/ru/LC_MESSAGES/mergeant.mo
+share/locale/rw/LC_MESSAGES/mergeant.mo
+share/locale/sk/LC_MESSAGES/mergeant.mo
+share/locale/sl/LC_MESSAGES/mergeant.mo
+share/locale/sq/LC_MESSAGES/mergeant.mo
+share/locale/sr/LC_MESSAGES/mergeant.mo
+share/locale/sr@Latn/LC_MESSAGES/mergeant.mo
+share/locale/sv/LC_MESSAGES/mergeant.mo
+share/locale/tr/LC_MESSAGES/mergeant.mo
+share/locale/uk/LC_MESSAGES/mergeant.mo
+share/locale/vi/LC_MESSAGES/mergeant.mo
+share/locale/zh_CN/LC_MESSAGES/mergeant.mo
+share/locale/zh_HK/LC_MESSAGES/mergeant.mo
+share/locale/zh_TW/LC_MESSAGES/mergeant.mo
+share/mime/application/x-mergeant.xml
+share/mime/packages/mergeant.xml
+share/omf/mergeant/mergeant-C.omf
+share/pixmaps/mergeant.png
+share/pixmaps/mergeant/mergeant_connect.png
+share/pixmaps/mergeant/mergeant_connect_small.png
+share/pixmaps/mergeant/mergeant_disconnect.png
+share/pixmaps/mergeant/mergeant_disconnect_small.png
+share/pixmaps/mergeant/mergeant_foot.png
+share/pixmaps/mergeant/mergeant_forms.png
+share/pixmaps/mergeant/mergeant_queries.png
+share/pixmaps/mergeant/mergeant_rels.png
+share/pixmaps/mergeant/mergeant_rels_small.png
+share/pixmaps/mergeant/mergeant_sequences.png
+share/pixmaps/mergeant/mergeant_tables.png
+share/pixmaps/mergeant/mg-extra-form.png
+share/pixmaps/mergeant/mg-extra-grid.png
+share/pixmaps/mergeant/query-view-query_16x16.png
+share/pixmaps/mergeant/query-view-table_16x16.png
+share/pixmaps/mergeant/query-view-view_16x16.png
+@dirrm share/pixmaps/mergeant
+@dirrm share/omf/mergeant
+@dirrmtry share/local/zh_TW/LC_MESSAGES
+@dirrmtry share/local/zh_TW
+@dirrmtry share/local/zh_HK/LC_MESSAGES
+@dirrmtry share/local/zh_HK
+@dirrmtry share/local/zh_CN/LC_MESSAGES
+@dirrmtry share/local/zh_CN
+@dirrmtry share/local/uk/LC_MESSAGES
+@dirrmtry share/local/uk
+@dirrmtry share/local/sr/LC_MESSAGES
+@dirrmtry share/local/sr
+@dirrmtry share/local/sl/LC_MESSAGES
+@dirrmtry share/local/sl
+@dirrmtry share/local/sk/LC_MESSAGES
+@dirrmtry share/local/sk
+@dirrmtry share/local/rw/LC_MESSAGES
+@dirrmtry share/local/rw
+@dirrmtry share/local/pt/LC_MESSAGES
+@dirrmtry share/local/pt
+@dirrmtry share/local/pl/LC_MESSAGES
+@dirrmtry share/local/pl
+@dirrmtry share/local/oc/LC_MESSAGES
+@dirrmtry share/local/oc
+@dirrmtry share/local/ne/LC_MESSAGES
+@dirrmtry share/local/ne
+@dirrmtry share/local/gl/LC_MESSAGES
+@dirrmtry share/local/gl
+@dirrmtry share/local/fi/LC_MESSAGES
+@dirrmtry share/local/fi
+@dirrmtry share/local/el/LC_MESSAGES
+@dirrmtry share/local/el
+@dirrmtry share/local/dz/LC_MESSAGES
+@dirrmtry share/local/dz
+@dirrmtry share/local/cs/LC_MESSAGES
+@dirrmtry share/local/cs
+@dirrmtry share/local/ca/LC_MESSAGES
+@dirrmtry share/local/ca
+@dirrm share/gnome/help/mergeant/C/stylesheet-images
+@dirrm share/gnome/help/mergeant/C/images
+@dirrm share/gnome/help/mergeant/C
+@dirrm share/gnome/help/mergeant
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz