aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/orthanc/Makefile8
-rw-r--r--science/orthanc/distinfo6
-rw-r--r--science/orthanc/files/patch-OrthancFramework_Resources_CMake_CivetwebConfiguration.cmake8
-rw-r--r--science/orthanc/pkg-plist4
4 files changed, 14 insertions, 12 deletions
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index 9e7f31c21893..4e9d324c6885 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -1,7 +1,7 @@
# Created by: maintainer.freebsd@xpoundit.com
PORTNAME= orthanc
-DISTVERSION= 1.9.3
+DISTVERSION= 1.9.7
CATEGORIES= science
MASTER_SITES= https://www.orthanc-server.com/downloads/get.php?path=/orthanc/
DISTNAME= Orthanc-${PORTVERSION}
@@ -30,13 +30,15 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/Orthanc-${PORTVERSION}
-CMAKE_SOURCE_PATH= ${WRKSRC}/OrthancServer
CMAKE_OFF= BUILD_CONNECTIVITY_CHECKS UNIT_TESTS_WITH_HTTP_CONNEXIONS
CMAKE_ON= USE_SYSTEM_BOOST USE_SYSTEM_CIVETWEB USE_SYSTEM_DCMTK \
USE_SYSTEM_GOOGLE_TEST USE_SYSTEM_JSONCPP USE_SYSTEM_LIBICONV \
USE_SYSTEM_LIBJPEG USE_SYSTEM_LIBPNG USE_SYSTEM_LUA \
USE_SYSTEM_OPENSSL USE_SYSTEM_PUGIXML USE_SYSTEM_SQLITE \
USE_SYSTEM_UUID USE_SYSTEM_ZLIB
+CMAKE_OFF= BUILD_CONNECTIVITY_CHECKS UNIT_TESTS_WITH_HTTP_CONNEXIONS
+CMAKE_SOURCE_PATH= ${WRKSRC}/OrthancServer
+
CFLAGS+= -DNDEBUG
CXXFLAGS+= -DNDEBUG
@@ -45,7 +47,7 @@ USE_RC_SUBR= orthanc
USERS= orthanc
GROUPS= orthanc
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+PLIST_SUB+= DISTVERSION=${DISTVERSION}
post-install:
${MKDIR} ${STAGEDIR}/var/db/orthanc/db/db-v5
diff --git a/science/orthanc/distinfo b/science/orthanc/distinfo
index ed25e78020f7..9f7ae409e3b5 100644
--- a/science/orthanc/distinfo
+++ b/science/orthanc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620899601
-SHA256 (Orthanc-1.9.3.tar.gz) = 41cc35a3d15ecb0d7b834e8e28a740cc4ffa1f333c019a764228d60e96608960
-SIZE (Orthanc-1.9.3.tar.gz) = 1818313
+TIMESTAMP = 1634131378
+SHA256 (Orthanc-1.9.7.tar.gz) = dd662add29808a15e4f1b24582021d5ea84146eefb2b6437da018c7db2168e51
+SIZE (Orthanc-1.9.7.tar.gz) = 1856489
diff --git a/science/orthanc/files/patch-OrthancFramework_Resources_CMake_CivetwebConfiguration.cmake b/science/orthanc/files/patch-OrthancFramework_Resources_CMake_CivetwebConfiguration.cmake
index b1cd8bd06165..0237ef13ed79 100644
--- a/science/orthanc/files/patch-OrthancFramework_Resources_CMake_CivetwebConfiguration.cmake
+++ b/science/orthanc/files/patch-OrthancFramework_Resources_CMake_CivetwebConfiguration.cmake
@@ -1,6 +1,6 @@
---- OrthancFramework/Resources/CMake/CivetwebConfiguration.cmake.orig 2021-05-12 13:54:35 UTC
+--- OrthancFramework/Resources/CMake/CivetwebConfiguration.cmake.orig 2021-08-30 20:14:33 UTC
+++ OrthancFramework/Resources/CMake/CivetwebConfiguration.cmake
-@@ -98,32 +98,38 @@ else()
+@@ -109,32 +109,38 @@ else()
cmake_reset_check_state()
set(CMAKE_REQUIRED_LIBRARIES dl pthread)
@@ -34,7 +34,7 @@
+ message(FATAL_ERROR "Unable to use mg_start from civetweb library")
+ endif()
+
-+ CHECK_LIBRARY_EXISTS(${CIVETWEB_LIB} mg_disable_keep_alive "" CIVETWEB_HAS_DISABLE_KEEP_ALIVE)
++ CHECK_LIBRARY_EXISTS(${CIVETWEB_LIB} mg_disable_connection_keep_alive "" CIVETWEB_HAS_DISABLE_KEEP_ALIVE)
+ if (CIVETWEB_HAS_DISABLE_KEEP_ALIVE)
+ add_definitions(
+ -DCIVETWEB_HAS_DISABLE_KEEP_ALIVE=1
@@ -42,7 +42,7 @@
+ )
+ message("Performance: Your system-wide distribution of civetweb is configured for best performance")
+ else()
-+ message(WARNING "Performance: Your system-wide distribution of civetweb does not feature the mg_disable_keep_alive() function, and WebDAV will only be available for read-only access")
++ message(WARNING "Performance: Your system-wide distribution of civetweb does not feature the mg_disable_connection_keep_alive() function, and WebDAV will only be available for read-only access")
+ add_definitions(
+ -DCIVETWEB_HAS_DISABLE_KEEP_ALIVE=0
+ -DCIVETWEB_HAS_WEBDAV_WRITING=0
diff --git a/science/orthanc/pkg-plist b/science/orthanc/pkg-plist
index 3c86361bc527..c31909c48a74 100644
--- a/science/orthanc/pkg-plist
+++ b/science/orthanc/pkg-plist
@@ -13,6 +13,6 @@ include/orthanc/OrthancCDatabasePlugin.h
include/orthanc/OrthancCPlugin.h
sbin/Orthanc
%%DATADIR%%/plugins/libModalityWorklists.so
-%%DATADIR%%/plugins/libModalityWorklists.so.%%PORTVERSION%%
+%%DATADIR%%/plugins/libModalityWorklists.so.%%DISTVERSION%%
%%DATADIR%%/plugins/libServeFolders.so
-%%DATADIR%%/plugins/libServeFolders.so.%%PORTVERSION%%
+%%DATADIR%%/plugins/libServeFolders.so.%%DISTVERSION%%