aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--mail/Makefile1
-rw-r--r--mail/bogofilter-current/Makefile129
-rw-r--r--mail/bogofilter-current/distinfo2
-rw-r--r--mail/bogofilter-current/pkg-descr7
-rw-r--r--mail/bogofilter-current/pkg-install12
-rw-r--r--mail/bogofilter-current/pkg-plist10
7 files changed, 1 insertions, 161 deletions
diff --git a/MOVED b/MOVED
index 47af5e3db748..ccc51f7732c1 100644
--- a/MOVED
+++ b/MOVED
@@ -1495,3 +1495,4 @@ audio/mpeg4ip-faad||2005-05-19|Port no longer needed with new mpeg4ip-1.3
net/iperf|benchmarks/iperf|2005-05-21|better category
misc/kile-i18n|editors/kile|2005-05-22|Merged with kile
x11-wm/gnome2wmaker||2005-05-22|obsolete and unsupported
+mail/bogofilter-current||2005-05-26|newer stable version available
diff --git a/mail/Makefile b/mail/Makefile
index 73ec950bd563..c57c3bab81bb 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -28,7 +28,6 @@
SUBDIR += bincimap
SUBDIR += bmf
SUBDIR += bogofilter
- SUBDIR += bogofilter-current
SUBDIR += bogofilter-qdbm
SUBDIR += bogofilter-tdb
SUBDIR += bsfilter
diff --git a/mail/bogofilter-current/Makefile b/mail/bogofilter-current/Makefile
deleted file mode 100644
index 1de6a259f14c..000000000000
--- a/mail/bogofilter-current/Makefile
+++ /dev/null
@@ -1,129 +0,0 @@
-# ports collection Makefile for: bogofilter
-# Whom: Matthias Andree <matthias.andree@gmx.de>
-# Date created: 2002-10-17
-#
-# $FreeBSD$
-#
-
-PORTNAME= bogofilter
-PORTVERSION= 0.94.11
-CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-PKGNAMESUFFIX= -current
-
-MAINTAINER= marcus@corp.grupos.com.br
-COMMENT= "Fast, teachable, learning spam detector"
-
-CONFLICTS?= bogofilter-tdb-[0-9]* bogofilter-qdbm-[0-9]* [a-z][a-z]-bogofilter-[0-9]* \
- bogofilter-[0-9]*
-
-USE_BZIP2= yes
-USE_REINPLACE= yes
-USE_PERL5_RUN= yes
-GNU_CONFIGURE= yes
-
-OPTIONS= DB43 "Use Berkeley DB 4.3 backend" on \
- TDB "Use TDB backend" off \
- SQLITE3 "Use SQLITE 3 backend" off \
- GSL "Use GSL library" on \
- BASH "Include BASH Scripts" on \
-
-.include <bsd.port.pre.mk>
-
-CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-CONFIGURE_TARGET+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-INSTALL_TARGET= install-strip prefix=${PREFIX}
-
-MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
-
-.if !defined(WITHOUT_DB43)
-LIB_DEPENDS+= db-4.3:${PORTSDIR}/databases/db43
-CONFIGURE_ARGS+= --with-database=db
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/db43" LDFLAGS="-L${LOCALBASE}/lib/db43"
-.if defined(WITH_TDB) || defined(WITH_SQLITE3)
-BROKEN= "Please select only one DB"
-.endif
-.endif
-
-.if defined(WITH_TDB)
-LIB_DEPENDS+= tdb.1:${PORTSDIR}/databases/tdb
-CONFIGURE_ARGS+= --with-database=tdb
-.if !defined(WITHOUT_DB43) || defined(WITH_SQLITE3)
-BROKEN= "Please select only one DB"
-.endif
-.endif
-
-.if defined(WITH_SQLITE3)
-LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
-CONFIGURE_ARGS+= --with-database=sqlite
-.if !defined(WITHOUT_DB43) || defined(WITH_TDB)
-BROKEN= "Please select only one DB"
-.endif
-.endif
-
-.if !defined(WITHOUT_GSL)
-LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
-CONFIGURE_ARGS+= --with-included-gsl
-.endif
-
-.if !defined(WITHOUT_BASH)
-RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
- ${WRKSRC}/contrib/randomtrain \
- ${WRKSRC}/contrib/scramble \
- ${WRKSRC}/contrib/trainbogo.sh
- ${REINPLACE_CMD} -e 's|^#!.*perl|#! ${PERL}|' \
- ${WRKSRC}/src/tests/unsort.pl \
- ${WRKSRC}/contrib/bogofilter-milter.pl \
- ${WRKSRC}/contrib/bogominitrain.pl \
- ${WRKSRC}/contrib/mime.get.rfc822 \
- ${WRKSRC}/contrib/printmaildir.pl
-
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
-
-post-build::
- cd ${WRKSRC} && make check SHELL=${SH}
-
-post-install::
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in contrib html programmer xml
- @${MKDIR} ${DOCSDIR}/${i}
-.endfor
-.for i in AUTHORS COPYING INSTALL NEWS README README.cvs \
- doc/README.validation TODO RELEASE.NOTES GETTING.STARTED \
- doc/integrating-with-postfix doc/integrating-with-qmail \
- doc/bogofilter-tuning.HOWTO.html doc/bogofilter-SA-2002-01 \
- doc/README.tdb
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/trio/AUTHORS ${DOCSDIR}/AUTHORS.trio
-.for i in contrib/bogo.R contrib/bogofilter-qfe \
- contrib/mime.get.rfc822 contrib/printmaildir.pl \
- contrib/bogominitrain.pl contrib/README.contrib
- ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${DOCSDIR}/${i}
-.endfor
-.for i in contrib/dot-qmail-bogofilter-default
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
-.endfor
- ${INSTALL_PROGRAM} ${WRKSRC}/contrib/bogogrep ${DOCSDIR}/contrib/
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/*.xml ${DOCSDIR}/xml
- ${INSTALL_DATA} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
-.endif
-.if !defined(WITHOUT_BASH)
-.for i in randomtrain scramble trainbogo.sh
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/${i} ${DOCSDIR}/contrib/
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/contrib/README.randomtrain ${DOCSDIR}/contrib/
-.endif
- ${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
-.include <bsd.port.post.mk>
diff --git a/mail/bogofilter-current/distinfo b/mail/bogofilter-current/distinfo
deleted file mode 100644
index d4a80c635128..000000000000
--- a/mail/bogofilter-current/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (bogofilter-0.94.11.tar.bz2) = 89d9fe3f46c310fd7a436e69e2c0a0f3
-SIZE (bogofilter-0.94.11.tar.bz2) = 715241
diff --git a/mail/bogofilter-current/pkg-descr b/mail/bogofilter-current/pkg-descr
deleted file mode 100644
index dfbd62a10800..000000000000
--- a/mail/bogofilter-current/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Bogofilter takes an email message or other text on standard input, parses it
-into words, does a statistical check against data bases of "good" and "bad"
-words, and returns a status code indicating whether or not the message is spam.
-Bogofilter decodes base64 or quoted-printable encoded texts and ignores non-text
-attachments and HTML comments.
-
-WWW: http://bogofilter.sourceforge.net/
diff --git a/mail/bogofilter-current/pkg-install b/mail/bogofilter-current/pkg-install
deleted file mode 100644
index ff8e56e0cac8..000000000000
--- a/mail/bogofilter-current/pkg-install
+++ /dev/null
@@ -1,12 +0,0 @@
-if [ "$2" = "POST-INSTALL" ] && [ -e ${PKG_PREFIX}/etc/bogofilter.cf ] ; then
-cat - <<_EOF
-
---------------------------------------------------------------------------
-The recent bogofilter versions have undergone substantial changes that can
-affect compatibility and may require that you change your configuration.
-
-See the RELEASE.NOTES files that shipped with bogofilter for details.
---------------------------------------------------------------------------
-
-_EOF
-fi
diff --git a/mail/bogofilter-current/pkg-plist b/mail/bogofilter-current/pkg-plist
deleted file mode 100644
index cdfeeddebeeb..000000000000
--- a/mail/bogofilter-current/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-bin/bf_compact
-bin/bf_copy
-bin/bf_resize
-bin/bf_tar
-bin/bogofilter
-bin/bogolexer
-bin/bogotune
-bin/bogoutil
-bin/bogoupgrade
-etc/bogofilter.cf.example