aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IO-Null/Makefile22
-rw-r--r--devel/p5-IO-Null/distinfo3
-rw-r--r--devel/p5-IO-Null/pkg-descr10
-rw-r--r--devel/p5-IO-Null/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8c8514477b48..ffea3f936b4c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1035,6 +1035,7 @@
SUBDIR += p5-IO-LockedFile
SUBDIR += p5-IO-Multiplex
SUBDIR += p5-IO-NestedCapture
+ SUBDIR += p5-IO-Null
SUBDIR += p5-IO-Pager
SUBDIR += p5-IO-Prompt
SUBDIR += p5-IO-String
diff --git a/devel/p5-IO-Null/Makefile b/devel/p5-IO-Null/Makefile
new file mode 100644
index 000000000000..c778e3c5a677
--- /dev/null
+++ b/devel/p5-IO-Null/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-IO-Null
+# Date created: 06/06/2006
+# Whom: Rouslan Iskhakov <rouslan@rshell.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Null
+PORTVERSION= 1.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rouslan@rshell.net
+COMMENT= IO::Null - class for null filehandles
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Null.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-Null/distinfo b/devel/p5-IO-Null/distinfo
new file mode 100644
index 000000000000..7f72f07c2260
--- /dev/null
+++ b/devel/p5-IO-Null/distinfo
@@ -0,0 +1,3 @@
+MD5 (IO-Null-1.01.tar.gz) = 54d6084398f8b4e7062660b9ccc835a8
+SHA256 (IO-Null-1.01.tar.gz) = 3a9adeffff8d64b157c3ddb9c54468e7296356a07081739e9ab903b4953248b3
+SIZE (IO-Null-1.01.tar.gz) = 5130
diff --git a/devel/p5-IO-Null/pkg-descr b/devel/p5-IO-Null/pkg-descr
new file mode 100644
index 000000000000..e26715ba9e37
--- /dev/null
+++ b/devel/p5-IO-Null/pkg-descr
@@ -0,0 +1,10 @@
+IO::Null
+========
+
+Calling a constructor of this class always succeeds, returning a new
+null filehabdle. Writing to any object of this class is always a no-
+operation, and returns true. Reading from any object of this class is
+always nooperation, and returns empty-string or empty-list, as
+appropriate.
+
+WWW: http://search.cpan.org/dist/IO-Null/
diff --git a/devel/p5-IO-Null/pkg-plist b/devel/p5-IO-Null/pkg-plist
new file mode 100644
index 000000000000..86d7b874c9e1
--- /dev/null
+++ b/devel/p5-IO-Null/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/IO/Null.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Null/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Null
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IO
+@dirrmtry %%SITE_PERL%%/IO